summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Ressel <aranea@aixah.de>2015-10-16 00:42:02 +0200
committerLuis Ressel <aranea@aixah.de>2015-10-19 13:35:54 +0200
commit4f28038d4ce6cfa11a205e2c86730796a98c3b25 (patch)
tree5f0d126395cb66c69630755f52e4312bd6afee96 /games-roguelike
parentgames-roguelike/nethack: Remove old revisions (diff)
downloadgentoo-4f28038d4ce6cfa11a205e2c86730796a98c3b25.tar.gz
gentoo-4f28038d4ce6cfa11a205e2c86730796a98c3b25.tar.bz2
gentoo-4f28038d4ce6cfa11a205e2c86730796a98c3b25.zip
games-roguelike/nethack: Minor cleanup
* Drop \ after && and || * Drop reference to old X11 libdir
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/nethack/nethack-3.4.3-r5.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/games-roguelike/nethack/nethack-3.4.3-r5.ebuild b/games-roguelike/nethack/nethack-3.4.3-r5.ebuild
index b8cfdfd87b06..6762a44a77c8 100644
--- a/games-roguelike/nethack/nethack-3.4.3-r5.ebuild
+++ b/games-roguelike/nethack/nethack-3.4.3-r5.ebuild
@@ -116,7 +116,6 @@ src_install() {
emake \
CC="$(tc-getCC)" \
CFLAGS="${CFLAGS}" \
- LFLAGS="-L/usr/X11R6/lib" \
GAMEPERM=02755 \
GAMEUID="root" GAMEGRP="${NETHACK_GROUP}" \
PREFIX="${D}/usr" \
@@ -209,21 +208,21 @@ pkg_postinst() {
cd "${ROOT}/${STATEDIR}" || die "Failed to enter ${STATEDIR} directory"
if [[ -v migration ]] ; then
- cp "$T/"{logfile,record} . || \
+ cp "$T/"{logfile,record} . ||
die "Failed to preserve ${ROOT}/${STATEDIR} files"
- chown -R root:"${NETHACK_GROUP}" . && \
- chmod -R 660 . && \
- chmod 770 . save || \
+ chown -R root:"${NETHACK_GROUP}" . &&
+ chmod -R 660 . &&
+ chmod 770 . save ||
die "Adjustment of file permissions in ${ROOT}/${STATEDIR} failed"
fi
# we don't want to overwrite existing files, as they contain user data
local files="logfile perm record"
- touch $files && \
- chmod 660 $files && \
- chown root:"${NETHACK_GROUP}" $files || \
+ touch $files &&
+ chmod 660 $files &&
+ chown root:"${NETHACK_GROUP}" $files ||
die "Adjustment of file permissions in "${ROOT}/${STATEDIR}" failed"
elog "You may want to look at /etc/skel/.nethackrc for interesting options"