summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-19 05:31:19 +0100
committerSam James <sam@gentoo.org>2023-04-19 05:31:49 +0100
commit3c1783ba6b70fe31cc48439a3fbc51fa62640199 (patch)
tree36f292b639d5479e34f161db0b7205b00e311e1e /games-rpg/manaplus
parentgames-strategy/colobot: drop -Werror (diff)
downloadgentoo-3c1783ba6b70fe31cc48439a3fbc51fa62640199.tar.gz
gentoo-3c1783ba6b70fe31cc48439a3fbc51fa62640199.tar.bz2
gentoo-3c1783ba6b70fe31cc48439a3fbc51fa62640199.zip
games-rpg/manaplus: fix build w/ gcc 13
Closes: https://bugs.gentoo.org/899028 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-rpg/manaplus')
-rw-r--r--games-rpg/manaplus/files/manaplus-1.9.3.23-gcc13.patch37
-rw-r--r--games-rpg/manaplus/manaplus-1.9.3.23-r1.ebuild3
2 files changed, 39 insertions, 1 deletions
diff --git a/games-rpg/manaplus/files/manaplus-1.9.3.23-gcc13.patch b/games-rpg/manaplus/files/manaplus-1.9.3.23-gcc13.patch
new file mode 100644
index 000000000000..1a2ae7e078d8
--- /dev/null
+++ b/games-rpg/manaplus/files/manaplus-1.9.3.23-gcc13.patch
@@ -0,0 +1,37 @@
+https://bugs.gentoo.org/899028
+--- a/src/net/ea/chatrecv.h
++++ b/src/net/ea/chatrecv.h
+@@ -23,14 +23,7 @@
+ #ifndef NET_EA_CHATRECV_H
+ #define NET_EA_CHATRECV_H
+
+-#if defined(__GXX_EXPERIMENTAL_CXX0X__)
+-#if defined(__APPLE__)
+-#include <tr1/cstdint>
+-#endif // defined(__APPLE__)
+-#else // defined(__GXX_EXPERIMENTAL_CXX0X__)
+-#include <stdint.h>
+-#endif // defined(__GXX_EXPERIMENTAL_CXX0X__)
+-
++#include <cstdint>
+ #include <string>
+ #include <queue>
+ #ifndef __time_t_defined
+--- a/src/net/ea/traderecv.h
++++ b/src/net/ea/traderecv.h
+@@ -23,14 +23,7 @@
+ #ifndef NET_EA_TRADERECV_H
+ #define NET_EA_TRADERECV_H
+
+-#if defined(__GXX_EXPERIMENTAL_CXX0X__)
+-#if defined(__APPLE__)
+-#include <tr1/cstdint>
+-#endif // defined(__APPLE__)
+-#else // defined(__GXX_EXPERIMENTAL_CXX0X__)
+-#include <stdint.h>
+-#endif // defined(__GXX_EXPERIMENTAL_CXX0X__)
+-
++#include <cstdint>
+ #include <string>
+
+ namespace Net
diff --git a/games-rpg/manaplus/manaplus-1.9.3.23-r1.ebuild b/games-rpg/manaplus/manaplus-1.9.3.23-r1.ebuild
index f481e1cd9b21..0780865cfa73 100644
--- a/games-rpg/manaplus/manaplus-1.9.3.23-r1.ebuild
+++ b/games-rpg/manaplus/manaplus-1.9.3.23-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -57,6 +57,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${PN}-1.9.3.23-gcc12-time.patch
+ "${FILESDIR}"/${PN}-1.9.3.23-gcc13.patch
)
src_prepare() {