summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-16 07:59:02 +0100
committerSam James <sam@gentoo.org>2021-04-16 12:17:45 +0100
commitf6dcca49afe7eef003b88b767bf820b4d29f8c33 (patch)
tree9db9745e8ac6abcd73e99af51e34420495af418a /games-sports
parentgames-simulation/train-valley: eutils->wrapper (diff)
downloadgentoo-f6dcca49afe7eef003b88b767bf820b4d29f8c33.tar.gz
gentoo-f6dcca49afe7eef003b88b767bf820b4d29f8c33.tar.bz2
gentoo-f6dcca49afe7eef003b88b767bf820b4d29f8c33.zip
games-sports/foobillard: port to EAPI 7, toolchain-funcs--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/foobillard/files/foobillard-3.0a-as-needed.patch4
-rw-r--r--games-sports/foobillard/files/foobillard-3.0a-fbsd.patch12
-rw-r--r--games-sports/foobillard/files/foobillard-3.0a-freetype_pkgconfig.patch8
-rw-r--r--games-sports/foobillard/files/foobillard-3.0a-gl-clamp.patch5
-rw-r--r--games-sports/foobillard/files/foobillard-3.0a-no_nvidia.patch4
-rw-r--r--games-sports/foobillard/foobillard-3.0a-r1.ebuild26
6 files changed, 29 insertions, 30 deletions
diff --git a/games-sports/foobillard/files/foobillard-3.0a-as-needed.patch b/games-sports/foobillard/files/foobillard-3.0a-as-needed.patch
index 272f9c711778..db37416a9900 100644
--- a/games-sports/foobillard/files/foobillard-3.0a-as-needed.patch
+++ b/games-sports/foobillard/files/foobillard-3.0a-as-needed.patch
@@ -1,5 +1,5 @@
---- foobillard-3.0a.old/src/Makefile.am 2004-02-25 07:23:56.000000000 +0100
-+++ foobillard-3.0a/src/Makefile.am 2008-12-06 21:57:03.000000000 +0100
+--- a/src/Makefile.am
++++ b/src/Makefile.am
@@ -83,6 +83,5 @@ AM_CFLAGS = -Wall `freetype-config --cfl
#LIBS = -L$(LIBDIR) -lglut -lGLU -lGL -lXext -lXaw -lm -lXi -lpng -lz
diff --git a/games-sports/foobillard/files/foobillard-3.0a-fbsd.patch b/games-sports/foobillard/files/foobillard-3.0a-fbsd.patch
index 3b7fc953a4de..08fa262f415f 100644
--- a/games-sports/foobillard/files/foobillard-3.0a-fbsd.patch
+++ b/games-sports/foobillard/files/foobillard-3.0a-fbsd.patch
@@ -1,7 +1,5 @@
-Index: foobillard-3.0a/configure.in
-===================================================================
---- foobillard-3.0a.orig/configure.in
-+++ foobillard-3.0a/configure.in
+--- a/configure.in
++++ b/configure.in
@@ -13,7 +13,7 @@ dnl Checks for libraries.
dnl Checks for header files.
@@ -11,10 +9,8 @@ Index: foobillard-3.0a/configure.in
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
-Index: foobillard-3.0a/src/billard3d.c
-===================================================================
---- foobillard-3.0a.orig/src/billard3d.c
-+++ foobillard-3.0a/src/billard3d.c
+--- a/src/billard3d.c
++++ b/src/billard3d.c
@@ -24,7 +24,11 @@
#include <string.h>
#include <math.h>
diff --git a/games-sports/foobillard/files/foobillard-3.0a-freetype_pkgconfig.patch b/games-sports/foobillard/files/foobillard-3.0a-freetype_pkgconfig.patch
index b01c53ecbc8b..57ce7ca94b1c 100644
--- a/games-sports/foobillard/files/foobillard-3.0a-freetype_pkgconfig.patch
+++ b/games-sports/foobillard/files/foobillard-3.0a-freetype_pkgconfig.patch
@@ -1,5 +1,5 @@
---- foobillard-3.0a/configure.in
-+++ foobillard-3.0a/configure.in
+--- a/configure.in
++++ b/configure.in
@@ -13,7 +13,7 @@
dnl Checks for header files.
@@ -9,8 +9,8 @@
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
---- foobillard-3.0a/src/Makefile.am
-+++ foobillard-3.0a/src/Makefile.am
+--- a/src/Makefile.am
++++ b/src/Makefile.am
@@ -50,7 +50,7 @@
#CC = gcc
#CXXFLAGS = -O6 -s
diff --git a/games-sports/foobillard/files/foobillard-3.0a-gl-clamp.patch b/games-sports/foobillard/files/foobillard-3.0a-gl-clamp.patch
index 972d14cabb0a..3d185e8d2776 100644
--- a/games-sports/foobillard/files/foobillard-3.0a-gl-clamp.patch
+++ b/games-sports/foobillard/files/foobillard-3.0a-gl-clamp.patch
@@ -1,6 +1,5 @@
-diff -ur foobillard-3.0a/src/table.c foobillard-3.0a-glclamp/src/table.c
---- foobillard-3.0a/src/table.c 2004-01-11 21:53:02.000000000 +0000
-+++ foobillard-3.0a-glclamp/src/table.c 2011-02-21 09:14:36.000000000 +0000
+--- a/src/table.c
++++ b/src/table.c
@@ -1214,8 +1214,8 @@
GL_UNSIGNED_BYTE, tabletexdata);
glTexParameteri(GL_TEXTURE_2D, GL_TEXTURE_MIN_FILTER, options_tex_min_filter);
diff --git a/games-sports/foobillard/files/foobillard-3.0a-no_nvidia.patch b/games-sports/foobillard/files/foobillard-3.0a-no_nvidia.patch
index 8a9a33c43ea4..82e80cef0b7f 100644
--- a/games-sports/foobillard/files/foobillard-3.0a-no_nvidia.patch
+++ b/games-sports/foobillard/files/foobillard-3.0a-no_nvidia.patch
@@ -1,5 +1,5 @@
---- a/src/ball.c.orig 2004-06-02 07:00:57.000000000 -0400
-+++ b/src/ball.c 2004-06-02 07:03:52.000000000 -0400
+--- a/src/ball.c
++++ b/src/ball.c
@@ -1821,6 +1821,7 @@
} else if( options_cuberef && cuberef_binds!=0 ){
glBindTexture(GL_TEXTURE_CUBE_MAP_ARB, cuberef_binds[i]);
diff --git a/games-sports/foobillard/foobillard-3.0a-r1.ebuild b/games-sports/foobillard/foobillard-3.0a-r1.ebuild
index 1e0053bfc696..c25b7f5ae4e4 100644
--- a/games-sports/foobillard/foobillard-3.0a-r1.ebuild
+++ b/games-sports/foobillard/foobillard-3.0a-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools desktop flag-o-matic toolchain-funcs
+EAPI=7
+
+inherit autotools desktop flag-o-matic
DESCRIPTION="8ball, 9ball, snooker and carambol game"
HOMEPAGE="http://foobillard.sourceforge.net/"
@@ -22,17 +23,20 @@ RDEPEND="x11-libs/libXaw
sdl? ( media-libs/libsdl[video] )
!sdl? ( media-libs/freeglut )
"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-no_nvidia.patch
+ "${FILESDIR}"/${P}-freetype_pkgconfig.patch
+ "${FILESDIR}"/${P}-fbsd.patch
+ "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-gl-clamp.patch
+)
src_prepare() {
default
- eapply \
- "${FILESDIR}"/${P}-no_nvidia.patch \
- "${FILESDIR}"/${P}-freetype_pkgconfig.patch \
- "${FILESDIR}"/${P}-fbsd.patch \
- "${FILESDIR}"/${P}-as-needed.patch \
- "${FILESDIR}"/${P}-gl-clamp.patch
+
mv configure.{in,ac} || die
rm aclocal.m4