summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/gorky17-demo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/gorky17-demo')
-rw-r--r--games-strategy/gorky17-demo/Manifest2
-rw-r--r--games-strategy/gorky17-demo/gorky17-demo-1.0.1.0.1-r1.ebuild76
-rw-r--r--games-strategy/gorky17-demo/metadata.xml5
3 files changed, 83 insertions, 0 deletions
diff --git a/games-strategy/gorky17-demo/Manifest b/games-strategy/gorky17-demo/Manifest
new file mode 100644
index 000000000000..dee44049db68
--- /dev/null
+++ b/games-strategy/gorky17-demo/Manifest
@@ -0,0 +1,2 @@
+DIST gorky17-demo-1.0-1.0.1-x86.run 955547 SHA256 557bd97400101da9b557a5bfc5e6b9d352a9f10f79c927f31d74581ba7acc16b SHA512 ffd054aa1b169de5cca3c85d58ce2cba127f0caca533f8d4f0046ce63e5505a0ea25c3bbea9a2dde863a8fecefb7f8d322968f90ab3f688dee70a2f0d44826ba WHIRLPOOL c133f6175cfaf5e71c183687fa78b49ab7df1816f6ec9ee8696f9be0c7d5ea2b4e0d39decbb7561db9a7e5ceacb78958e11072fbc5812f7c6627b58dde03cf4a
+DIST gorky17_demo.run 158781516 SHA256 35cf62e06747bfe3445c1d3a61ad1644922528c264ff2ec7b5b510f9bc9dd51a SHA512 7e7bf2a6a9f815381381ef5c50135232db7c6ec734300b807794107ab1b902d659f55569ea03c7d68c3e6dbf98e366de8bca4fd13dac3c688ba48d2f244e9f00 WHIRLPOOL 5e4188d85efb60f3abaa56941a1005c14de26ba4a458cfb2dd3753cde825a1f3945351a06c82b934b4f1c94c9dacf1e2d9b00d17852eb1e140166131dab66192
diff --git a/games-strategy/gorky17-demo/gorky17-demo-1.0.1.0.1-r1.ebuild b/games-strategy/gorky17-demo/gorky17-demo-1.0.1.0.1-r1.ebuild
new file mode 100644
index 000000000000..d2c38d9e0a1b
--- /dev/null
+++ b/games-strategy/gorky17-demo/gorky17-demo-1.0.1.0.1-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker versionator games
+
+MY_PN="gorky17"
+MY_PV=$(replace_version_separator 2 '-')
+
+DESCRIPTION="Horror conspiracy game mixing elements of strategy and role-playing"
+HOMEPAGE="http://www.linuxgamepublishing.com/info.php?id=gorky17"
+SRC_URI="http://demofiles.linuxgamepublishing.com/${MY_PN}/${MY_PN}_demo.run
+ http://updatefiles.linuxgamepublishing.com/gorky17-demo/${PN}-${MY_PV}-x86.run"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RESTRICT="mirror bindist strip"
+
+RDEPEND="
+ >=media-libs/alsa-lib-1.0.27.2[abi_x86_32(-)]
+ >=media-libs/libsdl-1.2.15-r4[abi_x86_32(-)]
+ >=sys-libs/zlib-1.2.8-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXau-1.0.7-r1[abi_x86_32(-)]
+ >=x11-libs/libXdmcp-1.1.1-r1[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+QA_EXECSTACK="${dir:1}/gorky17_demo ${dir:1}/gorky17_demo.dynamic"
+
+src_unpack() {
+ unpack_makeself ${MY_PN}_demo.run
+ unpack ./data/data.tar.gz
+
+ mkdir patch_dir
+ cd patch_dir
+ unpack_makeself ${PN}-${MY_PV}-x86.run
+ cd "${S}"
+
+ # Apply patch
+ mv bin/Linux/x86/* .
+ mv patch_dir/*.sh .
+ ./patch_dir/bin/Linux/x86/loki_patch patch_dir/patch.dat . || die
+
+ rm -r update.sh *patch.sh data lgp_* patch_dir setup* bin
+}
+
+src_install() {
+ insinto "${dir}"
+ doins -r *
+ rm "${Ddir}"/${MY_PN}*
+
+ exeinto "${dir}"
+ doexe ${MY_PN}*
+
+ games_make_wrapper ${PN} ./${MY_PN}_demo "${dir}" "${dir}"
+ newicon icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Gorky 17 (Demo)" ${PN}
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ elog "The instruction manual is available as:"
+ elog " http://demofiles.linuxgamepublishing.com/gorky17/manual.pdf"
+ echo
+}
diff --git a/games-strategy/gorky17-demo/metadata.xml b/games-strategy/gorky17-demo/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-strategy/gorky17-demo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>