summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-util/dfarc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-util/dfarc')
-rw-r--r--games-util/dfarc/Manifest2
-rw-r--r--games-util/dfarc/dfarc-3.10.ebuild60
-rw-r--r--games-util/dfarc/dfarc-3.12.ebuild53
-rw-r--r--games-util/dfarc/metadata.xml5
4 files changed, 120 insertions, 0 deletions
diff --git a/games-util/dfarc/Manifest b/games-util/dfarc/Manifest
new file mode 100644
index 000000000000..50d7f3aa68f7
--- /dev/null
+++ b/games-util/dfarc/Manifest
@@ -0,0 +1,2 @@
+DIST dfarc-3.10.tar.gz 282667 SHA256 072ef7938cf9dc35617dea3660bec459cfe6b1e376f2decb419f44b67222d280 SHA512 71067e1acbb0d96b5abde0ad050bd5e68b87d62d3d90c55ce59e7921860029a6682841b95bc55f6183c08d86e4b0952bfded2786e9a38fb6b90436c524573f87 WHIRLPOOL 5efe75cf36facab53ec65ed0d4bad2c2a9ca90824c1f4ac3bcd64a79e049dd78b112d65993a9760a210a4d58afd4571b0df9616ec6d0a73f106ecd7939b6cf10
+DIST dfarc-3.12.tar.gz 329925 SHA256 222a84cc91967abce4d86fb4ed8ba43455b818aecdb8487b0fe52d76ade29a83 SHA512 e87e89e67e383c3d25a6620edc38c6ab6f90b9df52b84d6e6de20af1ac3b50588b3037575f2f89a14c90c14151053c08a7bb97143f24471e33326f3f2d2574ab WHIRLPOOL af2c4646de591d3c09e3e2e8a7cd94a070e6086a977fc3d819077a6b812d638ba79762e7c0dde8dba1df7d1004c31005f02c5ba5de8710f5038f7b8e5b9c39d2
diff --git a/games-util/dfarc/dfarc-3.10.ebuild b/games-util/dfarc/dfarc-3.10.ebuild
new file mode 100644
index 000000000000..0d8c841b78a9
--- /dev/null
+++ b/games-util/dfarc/dfarc-3.10.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="2.8"
+inherit gnome2-utils fdo-mime wxwidgets games
+
+DESCRIPTION="Frontend and .dmod installer for GNU FreeDink"
+HOMEPAGE="http://www.freedink.org/"
+SRC_URI="mirror://gnu/freedink/${P}.tar.gz"
+
+LICENSE="GPL-3 BZIP2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+
+RDEPEND="
+ app-arch/bzip2
+ x11-misc/xdg-utils
+ x11-libs/wxGTK:${WX_GTK_VER}"
+DEPEND="${RDEPEND}
+ nls? ( >=dev-util/intltool-0.31 )"
+
+src_prepare() {
+ sed -i \
+ -e 's#^datarootdir =.*$#datarootdir = /usr/share#' \
+ share/Makefile.in || die
+}
+
+src_configure() {
+ egamesconf \
+ $(use_enable nls) \
+ --disable-desktopfiles
+}
+
+src_install() {
+ default
+ dodoc TRANSLATIONS.txt
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/games-util/dfarc/dfarc-3.12.ebuild b/games-util/dfarc/dfarc-3.12.ebuild
new file mode 100644
index 000000000000..bd54f01709dd
--- /dev/null
+++ b/games-util/dfarc/dfarc-3.12.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+WX_GTK_VER="3.0"
+inherit gnome2-utils fdo-mime wxwidgets games
+
+DESCRIPTION="Frontend and .dmod installer for GNU FreeDink"
+HOMEPAGE="http://www.freedink.org/"
+SRC_URI="mirror://gnu/freedink/${P}.tar.gz"
+
+LICENSE="GPL-3 BZIP2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+
+RDEPEND="
+ app-arch/bzip2
+ x11-misc/xdg-utils
+ x11-libs/wxGTK:${WX_GTK_VER}"
+DEPEND="${RDEPEND}
+ nls? ( >=dev-util/intltool-0.31 )"
+
+src_configure() {
+ egamesconf \
+ $(use_enable nls) \
+ --disable-desktopfiles
+}
+
+src_install() {
+ default
+ dodoc TRANSLATIONS.txt
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/games-util/dfarc/metadata.xml b/games-util/dfarc/metadata.xml
new file mode 100644
index 000000000000..cad5a2aa1773
--- /dev/null
+++ b/games-util/dfarc/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+</pkgmetadata>