summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/cjs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/cjs')
-rw-r--r--gnome-extra/cjs/Manifest3
-rw-r--r--gnome-extra/cjs/cjs-2.4.2.ebuild75
-rw-r--r--gnome-extra/cjs/cjs-2.6.0.ebuild75
-rw-r--r--gnome-extra/cjs/cjs-2.6.1.ebuild75
-rw-r--r--gnome-extra/cjs/files/cjs-2.4.0-disable-unittest-1.patch48
-rw-r--r--gnome-extra/cjs/files/cjs-2.4.0-disable-unittest-2.patch40
-rw-r--r--gnome-extra/cjs/files/cjs-2.4.0-disable-unittest-3.patch35
-rw-r--r--gnome-extra/cjs/metadata.xml8
8 files changed, 359 insertions, 0 deletions
diff --git a/gnome-extra/cjs/Manifest b/gnome-extra/cjs/Manifest
new file mode 100644
index 000000000000..2dab1c2c39df
--- /dev/null
+++ b/gnome-extra/cjs/Manifest
@@ -0,0 +1,3 @@
+DIST cjs-2.4.2.tar.gz 324509 SHA256 1310a2bfdebd6a50a09718abf3627daab097233781757509121257445e0423e3 SHA512 95c46808120392f4c9d74d5d94ee030be1b3a8a36ddabbd12560ea0ed16ac6bdeb78016a09eec315536ee094109c6f6fe07ee624300bd1eae88fdbdefbed0565 WHIRLPOOL e0dca618e2d166ee29ebc303d162dd7cd37c8d5381d68fd1c5824aba173cd651ab9825437f2096aede2be667bcd9633a21acd3bdee9002fee1d2f350cc454730
+DIST cjs-2.6.0.tar.gz 324623 SHA256 bb65b7238eabb265de256d6de0a183018a4ec28b7d161d439a809875ca6e2927 SHA512 49d920a81965575aa1ea9777dd1b41911cd61bc3b29ecb87d1c1923cf3a5d43520a9b036bfca006539be27ea7c83c1c9ddea7beafaf470d255322dad0bd170ec WHIRLPOOL 197199f4c5d53c0a6c77d411b0c3fce93cef81a4dd91b84387e0402b2b7d7e51e273c449a05cf39c1491c20b911847682e3d8dbe2c2549c4bf738e477d10b51b
+DIST cjs-2.6.1.tar.gz 324886 SHA256 1b431ccacfc6dac5f393ff6807dac69751eb943488422b7e26554f164a0e4309 SHA512 1c382a590def70f2d0ed554c5a345f3094d06ae4999aeb6b836d2867f947aeb5f60b222e4c139d89bdba0e855e6e844f80f4d0b08e3921e84c2e214e9d371a61 WHIRLPOOL 1cded0ba6da3baba6484785080cff9e08db5529e3f2a5c0a740e5f1a06b0c1e89b299f686c931724412ebdb0eb9dee509e517da5fad403eab5c4c043afabec84
diff --git a/gnome-extra/cjs/cjs-2.4.2.ebuild b/gnome-extra/cjs/cjs-2.4.2.ebuild
new file mode 100644
index 000000000000..b492980b7963
--- /dev/null
+++ b/gnome-extra/cjs/cjs-2.4.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2 pax-utils virtualx
+
+DESCRIPTION="Linux Mint's fork of gjs for Cinnamon"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/cjs/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
+SLOT="0"
+IUSE="+cairo examples gtk test"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ dev-lang/spidermonkey:24
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/gobject-introspection-1.38:=
+ sys-libs/readline:0
+ virtual/libffi
+ cairo? ( x11-libs/cairo[X,glib] )
+ gtk? ( x11-libs/gtk+:3 )
+"
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( sys-apps/dbus )
+"
+# Cinnamon 2.2 does not work with this release.
+RDEPEND="${RDEPEND}
+ !<gnome-extra/cinnamon-2.4
+"
+
+src_prepare() {
+ # Disable broken unittests
+ epatch "${FILESDIR}"/${PN}-2.4.0-disable-unittest-*.patch
+
+ epatch_user
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # FIXME: add systemtap/dtrace support, like in glib:2
+ # FIXME: --enable-systemtap installs files in ${D}/${D} for some reason
+ # XXX: Do NOT enable coverage, completely useless for portage installs
+ gnome2_src_configure \
+ --disable-systemtap \
+ --disable-dtrace \
+ --disable-coverage \
+ $(use_with cairo) \
+ $(use_with gtk)
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ # installation sometimes fails in parallel
+ gnome2_src_install -j1
+
+ if use examples; then
+ insinto /usr/share/doc/"${PF}"/examples
+ doins "${S}"/examples/*
+ fi
+
+ # Required for cjs-console to run correctly on PaX systems
+ pax-mark mr "${ED}/usr/bin/cjs-console"
+}
diff --git a/gnome-extra/cjs/cjs-2.6.0.ebuild b/gnome-extra/cjs/cjs-2.6.0.ebuild
new file mode 100644
index 000000000000..7f766c8bd95c
--- /dev/null
+++ b/gnome-extra/cjs/cjs-2.6.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2 pax-utils virtualx
+
+DESCRIPTION="Linux Mint's fork of gjs for Cinnamon"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/cjs/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
+SLOT="0"
+IUSE="+cairo examples gtk test"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/spidermonkey:24
+ >=dev-libs/glib-2.37.3:2
+ >=dev-libs/gobject-introspection-1.38:=
+ sys-libs/readline:0
+ virtual/libffi
+ cairo? ( x11-libs/cairo[X,glib] )
+ gtk? ( x11-libs/gtk+:3 )
+"
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( sys-apps/dbus )
+"
+# Cinnamon 2.2 does not work with this release.
+RDEPEND="${RDEPEND}
+ !<gnome-extra/cinnamon-2.4
+"
+
+src_prepare() {
+ # Disable broken unittests
+ epatch "${FILESDIR}"/${PN}-2.4.0-disable-unittest-*.patch
+
+ epatch_user
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # FIXME: add systemtap/dtrace support, like in glib:2
+ # FIXME: --enable-systemtap installs files in ${D}/${D} for some reason
+ # XXX: Do NOT enable coverage, completely useless for portage installs
+ gnome2_src_configure \
+ --disable-systemtap \
+ --disable-dtrace \
+ --disable-coverage \
+ $(use_with cairo) \
+ $(use_with gtk)
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ # installation sometimes fails in parallel
+ gnome2_src_install -j1
+
+ if use examples; then
+ insinto /usr/share/doc/"${PF}"/examples
+ doins "${S}"/examples/*
+ fi
+
+ # Required for cjs-console to run correctly on PaX systems
+ pax-mark mr "${ED}/usr/bin/cjs-console"
+}
diff --git a/gnome-extra/cjs/cjs-2.6.1.ebuild b/gnome-extra/cjs/cjs-2.6.1.ebuild
new file mode 100644
index 000000000000..7f766c8bd95c
--- /dev/null
+++ b/gnome-extra/cjs/cjs-2.6.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2 pax-utils virtualx
+
+DESCRIPTION="Linux Mint's fork of gjs for Cinnamon"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/cjs/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
+SLOT="0"
+IUSE="+cairo examples gtk test"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/spidermonkey:24
+ >=dev-libs/glib-2.37.3:2
+ >=dev-libs/gobject-introspection-1.38:=
+ sys-libs/readline:0
+ virtual/libffi
+ cairo? ( x11-libs/cairo[X,glib] )
+ gtk? ( x11-libs/gtk+:3 )
+"
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( sys-apps/dbus )
+"
+# Cinnamon 2.2 does not work with this release.
+RDEPEND="${RDEPEND}
+ !<gnome-extra/cinnamon-2.4
+"
+
+src_prepare() {
+ # Disable broken unittests
+ epatch "${FILESDIR}"/${PN}-2.4.0-disable-unittest-*.patch
+
+ epatch_user
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # FIXME: add systemtap/dtrace support, like in glib:2
+ # FIXME: --enable-systemtap installs files in ${D}/${D} for some reason
+ # XXX: Do NOT enable coverage, completely useless for portage installs
+ gnome2_src_configure \
+ --disable-systemtap \
+ --disable-dtrace \
+ --disable-coverage \
+ $(use_with cairo) \
+ $(use_with gtk)
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ # installation sometimes fails in parallel
+ gnome2_src_install -j1
+
+ if use examples; then
+ insinto /usr/share/doc/"${PF}"/examples
+ doins "${S}"/examples/*
+ fi
+
+ # Required for cjs-console to run correctly on PaX systems
+ pax-mark mr "${ED}/usr/bin/cjs-console"
+}
diff --git a/gnome-extra/cjs/files/cjs-2.4.0-disable-unittest-1.patch b/gnome-extra/cjs/files/cjs-2.4.0-disable-unittest-1.patch
new file mode 100644
index 000000000000..5afd89293695
--- /dev/null
+++ b/gnome-extra/cjs/files/cjs-2.4.0-disable-unittest-1.patch
@@ -0,0 +1,48 @@
+From 554c220e78172213e9637f9a901009b4bc964e3a Mon Sep 17 00:00:00 2001
+From: "Jasper St. Pierre" <jstpierre@mecheye.net>
+Date: Wed, 15 Jan 2014 17:00:22 -0500
+Subject: [PATCH] gjs-tests: Remove dumpstack test
+
+OK, I lied. This is the most useless test ever.
+---
+ test/gjs-tests.cpp | 17 -----------------
+ 1 file changed, 17 deletions(-)
+
+diff --git a/test/gjs-tests.cpp b/test/gjs-tests.cpp
+index b79b616..6cade7b 100644
+--- a/test/gs-tests.cpp
++++ b/test/gjs-tests.cpp
+@@ -163,22 +163,6 @@ gjstest_test_func_gjs_jsapi_util_string_js_string_utf8(void)
+ }
+
+ static void
+-gjstest_test_func_gjs_stack_dump(void)
+-{
+- GjsContext *context;
+-
+- /* TODO this test could be better - maybe expose dumpstack as a JS API
+- * so that we have a JS stack to dump? At least here we're getting some
+- * coverage.
+- */
+- context = gjs_context_new();
+-
+- gjs_dumpstack();
+- g_object_unref(context);
+- gjs_dumpstack();
+-}
+-
+-static void
+ gjstest_test_func_gjs_jsapi_util_error_throw(void)
+ {
+ GjsUnitTestFixture fixture;
+@@ -348,7 +332,6 @@ main(int argc,
+ g_test_add_func("/gjs/jsutil/strip_shebang/no_shebang", gjstest_test_strip_shebang_no_advance_for_no_shebang);
+ g_test_add_func("/gjs/jsutil/strip_shebang/have_shebang", gjstest_test_strip_shebang_advance_for_shebang);
+ g_test_add_func("/gjs/jsutil/strip_shebang/only_shebang", gjstest_test_strip_shebang_return_null_for_just_shebang);
+- g_test_add_func("/gjs/stack/dump", gjstest_test_func_gjs_stack_dump);
+ g_test_add_func("/util/glib/strv/concat/null", gjstest_test_func_util_glib_strv_concat_null);
+ g_test_add_func("/util/glib/strv/concat/pointers", gjstest_test_func_util_glib_strv_concat_pointers);
+
+--
+2.1.2
+
diff --git a/gnome-extra/cjs/files/cjs-2.4.0-disable-unittest-2.patch b/gnome-extra/cjs/files/cjs-2.4.0-disable-unittest-2.patch
new file mode 100644
index 000000000000..2490a63fea90
--- /dev/null
+++ b/gnome-extra/cjs/files/cjs-2.4.0-disable-unittest-2.patch
@@ -0,0 +1,40 @@
+From 4ea9fda3f323355d10e946d19d817fe8c4e6b533 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 12 Oct 2014 21:57:11 +0200
+Subject: [PATCH 1/2] Comment broken unittests
+
+---
+ test/gjs-tests.cpp | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/test/gjs-tests.cpp b/test/gjs-tests.cpp
+index 6cade7b..4d6c61e 100644
+--- a/test/gjs-tests.cpp
++++ b/test/gjs-tests.cpp
+@@ -324,18 +324,18 @@ main(int argc,
+
+ g_test_init(&argc, &argv, NULL);
+
+- g_test_add_func("/gjs/context/construct/destroy", gjstest_test_func_gjs_context_construct_destroy);
++ /* g_test_add_func("/gjs/context/construct/destroy", gjstest_test_func_gjs_context_construct_destroy); */
+ g_test_add_func("/gjs/context/construct/eval", gjstest_test_func_gjs_context_construct_eval);
+- g_test_add_func("/gjs/jsapi/util/array", gjstest_test_func_gjs_jsapi_util_array);
+- g_test_add_func("/gjs/jsapi/util/error/throw", gjstest_test_func_gjs_jsapi_util_error_throw);
+- g_test_add_func("/gjs/jsapi/util/string/js/string/utf8", gjstest_test_func_gjs_jsapi_util_string_js_string_utf8);
++ /* g_test_add_func("/gjs/jsapi/util/array", gjstest_test_func_gjs_jsapi_util_array); */
++ /* g_test_add_func("/gjs/jsapi/util/error/throw", gjstest_test_func_gjs_jsapi_util_error_throw); */
++ /* g_test_add_func("/gjs/jsapi/util/string/js/string/utf8", gjstest_test_func_gjs_jsapi_util_string_js_string_utf8); */
+ g_test_add_func("/gjs/jsutil/strip_shebang/no_shebang", gjstest_test_strip_shebang_no_advance_for_no_shebang);
+ g_test_add_func("/gjs/jsutil/strip_shebang/have_shebang", gjstest_test_strip_shebang_advance_for_shebang);
+ g_test_add_func("/gjs/jsutil/strip_shebang/only_shebang", gjstest_test_strip_shebang_return_null_for_just_shebang);
+ g_test_add_func("/util/glib/strv/concat/null", gjstest_test_func_util_glib_strv_concat_null);
+ g_test_add_func("/util/glib/strv/concat/pointers", gjstest_test_func_util_glib_strv_concat_pointers);
+
+- gjs_test_add_tests_for_coverage ();
++ /* gjs_test_add_tests_for_coverage (); */
+
+ g_test_run();
+
+--
+2.1.2
+
diff --git a/gnome-extra/cjs/files/cjs-2.4.0-disable-unittest-3.patch b/gnome-extra/cjs/files/cjs-2.4.0-disable-unittest-3.patch
new file mode 100644
index 000000000000..7b2898b75cf5
--- /dev/null
+++ b/gnome-extra/cjs/files/cjs-2.4.0-disable-unittest-3.patch
@@ -0,0 +1,35 @@
+From da18a2676477138693e893d3245316f987d74497 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 12 Oct 2014 21:57:45 +0200
+Subject: [PATCH 2/2] Comment broken JS unittest
+
+---
+ installed-tests/js/testLocale.js | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/installed-tests/js/testLocale.js b/installed-tests/js/testLocale.js
+index b086a66..0c5abb1 100644
+--- a/installed-tests/js/testLocale.js
++++ b/installed-tests/js/testLocale.js
+@@ -1,14 +1,14 @@
+ // tests for JS_SetLocaleCallbacks().
+ const JSUnit = imports.jsUnit;
+
+-function testToLocaleDateString() {
+- let date = new Date();
++//function testToLocaleDateString() {
++ //let date = new Date();
+ // %A is the weekday name, this tests locale_to_unicode
+ // we're basically just testing for a non-crash, since
+ // we'd have to run in a specific locale to have any
+ // idea about the result.
+- date.toLocaleDateString("%A");
+-}
++ //date.toLocaleDateString("%A");
++//}
+
+ function testToLocaleLowerCase() {
+ JSUnit.assertEquals("aaa", "AAA".toLocaleLowerCase());
+--
+2.1.2
+
diff --git a/gnome-extra/cjs/metadata.xml b/gnome-extra/cjs/metadata.xml
new file mode 100644
index 000000000000..72406f132664
--- /dev/null
+++ b/gnome-extra/cjs/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <upstream>
+ <remote-id type="github">linuxmint/cjs</remote-id>
+ </upstream>
+</pkgmetadata>