summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/docky
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/docky')
-rw-r--r--gnome-extra/docky/Manifest1
-rw-r--r--gnome-extra/docky/docky-2.2.0.ebuild44
-rw-r--r--gnome-extra/docky/metadata.xml12
3 files changed, 57 insertions, 0 deletions
diff --git a/gnome-extra/docky/Manifest b/gnome-extra/docky/Manifest
new file mode 100644
index 000000000000..b4cdf24329df
--- /dev/null
+++ b/gnome-extra/docky/Manifest
@@ -0,0 +1 @@
+DIST docky-2.2.0.tar.xz 570248 SHA256 28710b2deb998992184c96f1bfebdf43a8db1a074f716e309f955596be8f8af5 SHA512 054c3f8b10ccdc85b8defd108178ebcd880e46ec3d7d558cd2de8cc56f311dafe2efdb552ac8ff9a92cbe9279fdc44a66cad2395791e4a6de59a1cee1d2c6919 WHIRLPOOL db72c05e9e587eb0be661c2d0e6598064bfa4ea7456d16d08f4e533659c5e2cc76cfd6f1a4f669d67e8aa0275005ad0851b0c530715179f5d039e2edb200dde6
diff --git a/gnome-extra/docky/docky-2.2.0.ebuild b/gnome-extra/docky/docky-2.2.0.ebuild
new file mode 100644
index 000000000000..af5c88245917
--- /dev/null
+++ b/gnome-extra/docky/docky-2.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils gnome2 mono
+
+DESCRIPTION="Elegant, powerful, clean dock"
+HOMEPAGE="https://wiki.go-docky.com"
+SRC_URI="http://launchpad.net/${PN}/${PV%.*}/${PV}/+download/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug nls"
+
+RDEPEND="dev-dotnet/dbus-sharp
+ dev-dotnet/dbus-sharp-glib
+ dev-dotnet/gconf-sharp
+ >=dev-dotnet/gio-sharp-0.2-r1
+ dev-dotnet/glib-sharp
+ dev-dotnet/gnome-desktop-sharp
+ dev-dotnet/gnome-keyring-sharp
+ dev-dotnet/gtk-sharp
+ dev-dotnet/mono-addins[gtk]
+ dev-dotnet/notify-sharp
+ dev-dotnet/rsvg-sharp
+ dev-dotnet/wnck-sharp"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-release
+ $(use_enable nls)"
+
+ DOCS="AUTHORS NEWS"
+}
+
+src_prepare() {
+ sed -i -e "/warnaserror/d" configure.ac || die
+ eautoreconf
+}
diff --git a/gnome-extra/docky/metadata.xml b/gnome-extra/docky/metadata.xml
new file mode 100644
index 000000000000..6fe12e4ad789
--- /dev/null
+++ b/gnome-extra/docky/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+ <maintainer>
+ <email>angelos@gentoo.org</email>
+ <name>Christoph Mende</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">docky</remote-id>
+ </upstream>
+</pkgmetadata>