summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/gnome-builder
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/gnome-builder')
-rw-r--r--gnome-extra/gnome-builder/Manifest1
-rw-r--r--gnome-extra/gnome-builder/gnome-builder-3.16.3.ebuild59
-rw-r--r--gnome-extra/gnome-builder/metadata.xml5
3 files changed, 65 insertions, 0 deletions
diff --git a/gnome-extra/gnome-builder/Manifest b/gnome-extra/gnome-builder/Manifest
new file mode 100644
index 000000000000..e915c345ca44
--- /dev/null
+++ b/gnome-extra/gnome-builder/Manifest
@@ -0,0 +1 @@
+DIST gnome-builder-3.16.3.tar.xz 1733356 SHA256 a1d7b287d39ce724114c128e25bb00e273ecd8982ed22c8aba48cad9c4d51e61 SHA512 bd552763e958dd121f20adefab68de7d40d66fb3253c21ac9fe97eef7ffb5e98ea2b4ba21522db2cf1626c989bd6c04b27a16ba5e7ecb0bb66afc6299979652c WHIRLPOOL e690fafd8271fd9fd2908424f684bf2704bb768e51e50a8a983eb32f22e1d6807d66f381ebee849b8d7b73d4658301a57fbe6eeb32958ca9dd84ecb934a01d61
diff --git a/gnome-extra/gnome-builder/gnome-builder-3.16.3.ebuild b/gnome-extra/gnome-builder/gnome-builder-3.16.3.ebuild
new file mode 100644
index 000000000000..6ddc3f450381
--- /dev/null
+++ b/gnome-extra/gnome-builder/gnome-builder-3.16.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit gnome2 python-single-r1 virtualx
+
+DESCRIPTION="Builder attempts to be an IDE for writing software for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Builder"
+
+LICENSE="GPL-3+ GPL-2+ LGPL-3+ LGPL-2+ MIT CC-BY-SA-3.0 CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+introspection"
+
+# FIXME: some unittests seem to hang forever
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/gjs-1.42
+ >=dev-libs/glib-2.44:2
+ dev-libs/libgit2[ssh,threads]
+ >=dev-libs/libgit2-glib-0.22.6[ssh]
+ >=dev-libs/libxml2-2.9
+ dev-python/pygobject:3
+ >=dev-util/devhelp-3.16
+ dev-util/uncrustify
+ sys-devel/clang
+ >=x11-libs/gtk+-3.16.1:3[introspection?]
+ >=x11-libs/gtksourceview-3.16.1:3.0[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.42 )
+"
+DEPEND="${RDEPEND}
+ dev-libs/appstream-glib
+ >=dev-util/gtk-doc-am-1.11
+ >=dev-util/intltool-0.50.1
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ PYTHON3_CONFIG=${PYTHON}-config
+}
+
+src_test() {
+ # FIXME: this should be handled at eclass level
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data/gsettings" || die
+
+ GSETTINGS_SCHEMA_DIR="${S}/data/gsettings" Xemake check
+}
diff --git a/gnome-extra/gnome-builder/metadata.xml b/gnome-extra/gnome-builder/metadata.xml
new file mode 100644
index 000000000000..dad9001338dc
--- /dev/null
+++ b/gnome-extra/gnome-builder/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+</pkgmetadata>