summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/gnome-user-share
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/gnome-user-share')
-rw-r--r--gnome-extra/gnome-user-share/Manifest1
-rw-r--r--gnome-extra/gnome-user-share/files/gnome-user-share-3.10.2-launch-obexd.patch29
-rw-r--r--gnome-extra/gnome-user-share/gnome-user-share-3.14.2.ebuild47
-rw-r--r--gnome-extra/gnome-user-share/metadata.xml6
4 files changed, 83 insertions, 0 deletions
diff --git a/gnome-extra/gnome-user-share/Manifest b/gnome-extra/gnome-user-share/Manifest
new file mode 100644
index 000000000000..677a4eeddb83
--- /dev/null
+++ b/gnome-extra/gnome-user-share/Manifest
@@ -0,0 +1 @@
+DIST gnome-user-share-3.14.2.tar.xz 391916 SHA256 6b05b3ef31af3bb39c903f94a0d163c0a9c4aa5266ae98e2281e0613f2972ee9 SHA512 d42587c0c64fda9d051f3d6c792358d02c32b95193df512016a04a0ee4861483f3060f1579de6fa229676795e420cf88732da334757471b79410d3be6ebe8bd1 WHIRLPOOL 14a191b8cbfa218e4dcde379212a00f0753d02726b55b16b9f67fbc2c5484038d9d18ababb5c2019624856041257a88cea6b00a3d4cf21a83c9369b9486452be
diff --git a/gnome-extra/gnome-user-share/files/gnome-user-share-3.10.2-launch-obexd.patch b/gnome-extra/gnome-user-share/files/gnome-user-share-3.10.2-launch-obexd.patch
new file mode 100644
index 000000000000..a6bb00156fe2
--- /dev/null
+++ b/gnome-extra/gnome-user-share/files/gnome-user-share-3.10.2-launch-obexd.patch
@@ -0,0 +1,29 @@
+From 5bca8742e96bc5f3447be18e9c6ac5692cc3e3cd Mon Sep 17 00:00:00 2001
+From: Mario Sanchez Prada <mario@endlessm.com>
+Date: Thu, 30 Oct 2014 11:06:44 -0700
+Subject: obex: Make sure obexd daemon is launched if needed when starting to
+ watch it
+
+This fixes a situation where files can't be sent to the computer (e.g.
+from a phone) until you enable and then disable the bluetooth sharing
+options at least once, as the shutting down will cause the obexd daemon
+to run due to the UnregisterAgent D-Bus call in obex_agent_down().
+
+https://bugzilla.gnome.org/show_bug.cgi?id=739417
+
+diff --git a/src/obexpush.c b/src/obexpush.c
+index 6424bd2..6d305d7 100644
+--- a/src/obexpush.c
++++ b/src/obexpush.c
+@@ -740,7 +740,7 @@ on_bus_acquired (GDBusConnection *connection,
+
+ self->obexd_watch_id = g_bus_watch_name_on_connection (self->connection,
+ MANAGER_SERVICE,
+- G_BUS_NAME_WATCHER_FLAGS_NONE,
++ G_BUS_NAME_WATCHER_FLAGS_AUTO_START,
+ obexd_appeared_cb,
+ NULL,
+ self,
+--
+cgit v0.10.1
+
diff --git a/gnome-extra/gnome-user-share/gnome-user-share-3.14.2.ebuild b/gnome-extra/gnome-user-share/gnome-user-share-3.14.2.ebuild
new file mode 100644
index 000000000000..76200e169599
--- /dev/null
+++ b/gnome-extra/gnome-user-share/gnome-user-share-3.14.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 multilib
+
+DESCRIPTION="Personal file sharing for the GNOME desktop"
+HOMEPAGE="https://git.gnome.org/browse/gnome-user-share"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="bluetooth"
+
+# FIXME: could libnotify be made optional ?
+# FIXME: selinux automagic support
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=x11-libs/gtk+-3:3
+ >=gnome-base/nautilus-2.91.7
+ media-libs/libcanberra[gtk3]
+ >=www-apache/mod_dnssd-0.6
+ >=www-servers/apache-2.2[apache2_modules_dav,apache2_modules_dav_fs,apache2_modules_authn_file,apache2_modules_auth_digest,apache2_modules_authz_groupfile,apache2_mpms_prefork]
+ >=x11-libs/libnotify-0.7:=
+ bluetooth? (
+ >=net-wireless/gnome-bluetooth-3.9.3:2=
+ >=net-wireless/bluez-5[obex] )
+"
+DEPEND="${RDEPEND}
+ !<gnome-base/gnome-control-center-3.9
+ app-text/yelp-tools
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable bluetooth) \
+ --with-httpd=apache2 \
+ --with-modules-path=/usr/$(get_libdir)/apache2/modules/
+}
diff --git a/gnome-extra/gnome-user-share/metadata.xml b/gnome-extra/gnome-user-share/metadata.xml
new file mode 100644
index 000000000000..e98dd9082dc1
--- /dev/null
+++ b/gnome-extra/gnome-user-share/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>
+