summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-15 11:03:21 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-15 11:30:10 +0100
commit30a11ad2f14354f47b50c64e2f529e31fad66e52 (patch)
tree28b14d1340ffe67f8871e80c0559866981d21826 /gnome-extra/gtkhtml
parentgnome-extra/gnome-weather: Drop old (diff)
downloadgentoo-30a11ad2f14354f47b50c64e2f529e31fad66e52.tar.gz
gentoo-30a11ad2f14354f47b50c64e2f529e31fad66e52.tar.bz2
gentoo-30a11ad2f14354f47b50c64e2f529e31fad66e52.zip
gnome-extra/gtkhtml: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'gnome-extra/gtkhtml')
-rw-r--r--gnome-extra/gtkhtml/Manifest1
-rw-r--r--gnome-extra/gtkhtml/gtkhtml-4.10.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/gnome-extra/gtkhtml/Manifest b/gnome-extra/gtkhtml/Manifest
index 786af27bf4db..f00edc5fd261 100644
--- a/gnome-extra/gtkhtml/Manifest
+++ b/gnome-extra/gtkhtml/Manifest
@@ -1 +1,2 @@
+DIST gtkhtml-4.10.0.tar.xz 1050628 SHA256 ca3b6424fb2c7ac5d9cb8fdafb69318fa2e825c9cf6ed17d1e38d9b29e5606c3 SHA512 efb159f902a910abd259cf38a86894a363dfd6b632aaad5ca88baf278780e653a2efc783ae48d9e4239f9fbfcbab15a5f343b60c910166d04e6663d4e34843e0 WHIRLPOOL 2c4e2bbb97d31b751ebd05a9f2e898ac1ce5242826d025978f878e9a6e3266aff32e6256f42eb05007d3a9c13f05347029b9c9d4a67eb78789762a7163cd1d33
DIST gtkhtml-4.8.5.tar.xz 1049900 SHA256 2ff5bbec4d8e7eca66a36f7e3863a104e098ce9b58e6d0374de7cb80c3d93e8d SHA512 c35d67b22254570a92739c73a610230659a2ac63ab5e5a135a634655e679b39ad876cdf6abec4adabd0a9ba9ef87834745d03c7e0c005372bfe5485adff5ade3 WHIRLPOOL 665ab2d5319f3824ac26328b012bce0419b0c031b982ed0ef380679f8966f485c2813c2ea0e3a56688c610e1e3fc663592ab7c16cd546292c88254dd9e716d61
diff --git a/gnome-extra/gtkhtml/gtkhtml-4.10.0.ebuild b/gnome-extra/gtkhtml/gtkhtml-4.10.0.ebuild
new file mode 100644
index 000000000000..f5939c663b55
--- /dev/null
+++ b/gnome-extra/gtkhtml/gtkhtml-4.10.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Lightweight HTML rendering/printing/editing engine"
+HOMEPAGE="https://git.gnome.org/browse/gtkhtml"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="4.0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE=""
+
+# orbit is referenced in configure, but is not used anywhere else
+RDEPEND="
+ >=x11-libs/gtk+-3.2:3
+ >=x11-libs/cairo-1.10:=
+ x11-libs/pango
+ >=app-text/enchant-1.1.7:=
+ gnome-base/gsettings-desktop-schemas
+ >=app-text/iso-codes-0.49
+ >=net-libs/libsoup-2.26.0:2.4
+"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Don't collide with 3.14 slot
+ mv "${ED}"/usr/bin/gtkhtml-editor-test{,-${SLOT}} || die
+}