summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/synapse
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/synapse')
-rw-r--r--gnome-extra/synapse/Manifest1
-rw-r--r--gnome-extra/synapse/files/synapse-0.2.10-check-null-exec.patch16
-rw-r--r--gnome-extra/synapse/files/synapse-0.2.10-fix-border-painting.patch74
-rw-r--r--gnome-extra/synapse/files/synapse-0.2.10-fix-check-desktop.patch30
-rw-r--r--gnome-extra/synapse/files/synapse-0.2.10-gnome-3.10.patch75
-rw-r--r--gnome-extra/synapse/files/synapse-0.2.10-libgee-0.8.patch87
-rw-r--r--gnome-extra/synapse/files/synapse-0.2.10-zeitgeist.patch12
-rw-r--r--gnome-extra/synapse/files/synapse-0.2.8.2-underlinking.patch12
-rw-r--r--gnome-extra/synapse/files/synapse-0.2.8.2-zeitgeist.patch12
-rw-r--r--gnome-extra/synapse/metadata.xml15
-rw-r--r--gnome-extra/synapse/synapse-0.2.10-r1.ebuild81
-rw-r--r--gnome-extra/synapse/synapse-0.2.10.ebuild83
12 files changed, 498 insertions, 0 deletions
diff --git a/gnome-extra/synapse/Manifest b/gnome-extra/synapse/Manifest
new file mode 100644
index 000000000000..86bd46727911
--- /dev/null
+++ b/gnome-extra/synapse/Manifest
@@ -0,0 +1 @@
+DIST synapse-0.2.10.tar.gz 625327 SHA256 d94f724be51f20e2085ead203495d398c5fece24071ffed7e805108be2219540 SHA512 e21e30b7b180642d3102aa17b5135917f2380a6a656e304ec4077f19021d65750f73c49a0c837e2761d4acb9ecad49db97e02f4d2a82a9f255af61efe4b0adc6 WHIRLPOOL 5ecf09168ec04f4bc7ebb0f955bd7490c10b053d5c0ab1cd1662ccb21f773fb72369682edcb0c7c0ff95a680885eb23b4361f08fe36af71f29734ba371ccbe68
diff --git a/gnome-extra/synapse/files/synapse-0.2.10-check-null-exec.patch b/gnome-extra/synapse/files/synapse-0.2.10-check-null-exec.patch
new file mode 100644
index 000000000000..77820ecbbfde
--- /dev/null
+++ b/gnome-extra/synapse/files/synapse-0.2.10-check-null-exec.patch
@@ -0,0 +1,16 @@
+diff -Naur synapse-0.2.10.orig/src/core/desktop-file-service.vala synapse-0.2.10/src/core/desktop-file-service.vala
+--- synapse-0.2.10.orig/src/core/desktop-file-service.vala 2012-03-18 20:02:41.000000000 +0100
++++ synapse-0.2.10/src/core/desktop-file-service.vala 2012-12-26 18:07:55.962276823 +0100
+@@ -125,7 +125,11 @@
+ }
+
+ name = app_info.get_name ();
+- exec = app_info.get_executable ();
++ exec = app_info.get_commandline ();
++ if (exec == null)
++ {
++ throw new DesktopFileError.UNINTERESTING_ENTRY ("Unable to get exec for %s".printf (name));
++ }
+
+ // check for hidden desktop files
+ if (keyfile.has_key (GROUP, "Hidden") &&
diff --git a/gnome-extra/synapse/files/synapse-0.2.10-fix-border-painting.patch b/gnome-extra/synapse/files/synapse-0.2.10-fix-border-painting.patch
new file mode 100644
index 000000000000..38dc6ed83354
--- /dev/null
+++ b/gnome-extra/synapse/files/synapse-0.2.10-fix-border-painting.patch
@@ -0,0 +1,74 @@
+Index: synapse-0.2.10/src/ui/widgets.vala
+===================================================================
+--- synapse-0.2.10.orig/src/ui/widgets.vala
++++ synapse-0.2.10/src/ui/widgets.vala
+@@ -232,7 +232,7 @@ namespace Synapse.Gui
+ real_size = real_size - 1;
+ a.value = this.size_to_scale[real_size];
+ layout.context_changed ();
+- requistion_for_size (out req, null, real_size, true);
++ requisition_for_size (out req, null, real_size, true);
+
+ if (allocation.width >= req.width)
+ {
+@@ -306,10 +306,9 @@ namespace Synapse.Gui
+ return true;
+ }
+
+- protected void requistion_for_size (out Requisition req, out int char_width, Size s, bool return_only_width = false)
++ protected void requisition_for_size (out Requisition req, out int char_width, Size s, bool return_only_width = false)
+ {
+- req.width = this.xpad * 2;
+- req.height = this.ypad * 2;
++ req = { this.xpad * 2, this.ypad * 2 };
+
+ Pango.Rectangle logical_rect;
+ layout.set_width (-1);
+@@ -334,7 +333,7 @@ namespace Synapse.Gui
+ {
+ layout.set_markup ("<span size=\"%s\">%s</span>".printf (size_to_string[_size], this.text), -1);
+ int char_width;
+- this.requistion_for_size (out req, out char_width, this._size);
++ this.requisition_for_size (out req, out char_width, this._size);
+ last_req.width = req.width;
+ last_req.height = req.height;
+ if (!this.natural_requisition && (this.ellipsize != Pango.EllipsizeMode.NONE || animate))
+@@ -755,6 +754,10 @@ namespace Synapse.Gui
+ ctx.set_operator (Cairo.Operator.OVER);
+ ctx.set_line_width (1.25);
+
++ Gdk.cairo_rectangle (ctx, event.area);
++ ctx.clip ();
++ ctx.save ();
++
+ double x = this.allocation.x + this.left_padding,
+ y = this.allocation.y + this.top_padding,
+ w = this.allocation.width - this.left_padding - this.right_padding - 3.0,
+@@ -764,16 +767,13 @@ namespace Synapse.Gui
+ ch.set_source_rgba (ctx, input_alpha, ch.StyleType.BG, StateType.NORMAL, ch.Mod.DARKER);
+ else
+ ch.set_source_rgba (ctx, input_alpha, ch.StyleType.FG, StateType.NORMAL, ch.Mod.INVERTED);
+- Cairo.Path path = ctx.copy_path ();
+- ctx.save ();
+- ctx.clip ();
+- ctx.paint ();
++ ctx.fill_preserve ();
+ var pat = new Cairo.Pattern.linear (0, y, 0, y + shadow_height);
+ ch.add_color_stop_rgba (pat, 0, 0.6 * input_alpha, ch.StyleType.FG, StateType.NORMAL);
+ ch.add_color_stop_rgba (pat, 0.3, 0.25 * input_alpha, ch.StyleType.FG, StateType.NORMAL);
+ ch.add_color_stop_rgba (pat, 1.0, 0, ch.StyleType.FG, StateType.NORMAL);
+ ctx.set_source (pat);
+- ctx.paint ();
++ ctx.fill ();
+ if (_focus_widget != null)
+ {
+ /*
+@@ -818,7 +818,7 @@ namespace Synapse.Gui
+ ctx.paint ();
+ }
+ ctx.restore ();
+- ctx.append_path (path);
++ Utils.cairo_rounded_rect (ctx, x, y, w, h, border_radius);
+ ch.set_source_rgba (ctx, 0.6 * input_alpha, ch.StyleType.FG, StateType.NORMAL);
+ ctx.stroke ();
+ }
diff --git a/gnome-extra/synapse/files/synapse-0.2.10-fix-check-desktop.patch b/gnome-extra/synapse/files/synapse-0.2.10-fix-check-desktop.patch
new file mode 100644
index 000000000000..16e039b48a28
--- /dev/null
+++ b/gnome-extra/synapse/files/synapse-0.2.10-fix-check-desktop.patch
@@ -0,0 +1,30 @@
+diff -Naur synapse-0.2.10.orig/src/core/desktop-file-service.vala synapse-0.2.10/src/core/desktop-file-service.vala
+--- synapse-0.2.10.orig/src/core/desktop-file-service.vala 2012-03-18 20:02:41.000000000 +0100
++++ synapse-0.2.10/src/core/desktop-file-service.vala 2012-03-19 12:06:43.080443401 +0100
+@@ -248,13 +248,23 @@
+
+ private void get_environment_type ()
+ {
+- unowned string? session_var = Environment.get_variable ("DESKTOP_SESSION");
+-
++ unowned string? session_var;
++ session_var = Environment.get_variable ("XDG_CURRENT_DESKTOP");
++ if (session_var == null)
++ {
++ session_var = Environment.get_variable ("DESKTOP_SESSION");
++ }
++
+ if (session_var == null) return;
+
+ string session = session_var.down ();
+
+- if (session.has_prefix ("kde"))
++ if (session.has_prefix ("unity"))
++ {
++ session_type = DesktopFileInfo.EnvironmentType.UNITY;
++ session_type_str = "Unity";
++ }
++ else if (session.has_prefix ("kde"))
+ {
+ session_type = DesktopFileInfo.EnvironmentType.KDE;
+ session_type_str = "KDE";
diff --git a/gnome-extra/synapse/files/synapse-0.2.10-gnome-3.10.patch b/gnome-extra/synapse/files/synapse-0.2.10-gnome-3.10.patch
new file mode 100644
index 000000000000..b7ad5ed2de96
--- /dev/null
+++ b/gnome-extra/synapse/files/synapse-0.2.10-gnome-3.10.patch
@@ -0,0 +1,75 @@
+Index: synapse-0.2.10/src/ui/inspector.vala
+===================================================================
+--- synapse-0.2.10.orig/src/ui/inspector.vala
++++ synapse-0.2.10/src/ui/inspector.vala
+@@ -28,7 +28,7 @@ namespace UI
+
+ public Inspector ()
+ {
+- timer_id = Timeout.add (500, this.check_window_at_pointer);
++ timer_id = Gtk.Timeout.add (500, this.check_window_at_pointer);
+ }
+
+ ~Inspector ()
+Index: synapse-0.2.10/src/ui/widgets-matchlistview.vala
+===================================================================
+--- synapse-0.2.10.orig/src/ui/widgets-matchlistview.vala
++++ synapse-0.2.10/src/ui/widgets-matchlistview.vala
+@@ -551,7 +551,7 @@ namespace Synapse.Gui
+ }
+ if (needs_animation)
+ {
+- if (tid == 0) tid = Timeout.add (ANIM_TIMEOUT, this.update_current_offsets);
++ if (tid == 0) tid = Gtk.Timeout.add (ANIM_TIMEOUT, this.update_current_offsets);
+ this.queue_draw ();
+ return true;
+ }
+@@ -734,7 +734,7 @@ namespace Synapse.Gui
+ this.inhibit_move = true;
+ this.set_indexes (this.dragdrop_target_item, this.dragdrop_target_item);
+ this.selected_index_changed (this.select_index);
+- Timeout.add (Gtk.Settings.get_default ().gtk_double_click_time ,()=>{
++ Gtk.Timeout.add (Gtk.Settings.get_default ().gtk_double_click_time ,()=>{
+ if (inhibit_move)
+ {
+ inhibit_move = false;
+Index: synapse-0.2.10/src/ui/widgets.vala
+===================================================================
+--- synapse-0.2.10.orig/src/ui/widgets.vala
++++ synapse-0.2.10/src/ui/widgets.vala
+@@ -185,7 +185,7 @@ namespace Synapse.Gui
+ {
+ if (tid != 0) return;
+
+- tid = Timeout.add (40, ()=>{
++ tid = Gtk.Timeout.add (40, ()=>{
+ offset = (offset - 1) % (_anim_width);
+ queue_draw ();
+ return true;
+@@ -245,7 +245,7 @@ namespace Synapse.Gui
+ {
+ if (tid == 0)
+ {
+- tid = Timeout.add (INITIAL_TIMEOUT, ()=>{
++ tid = Gtk.Timeout.add (INITIAL_TIMEOUT, ()=>{
+ tid = 0;
+ start_animation ();
+ return false;
+@@ -1085,7 +1085,7 @@ namespace Synapse.Gui
+ }
+ if (tid == 0)
+ {
+- tid = Timeout.add (30, ()=>{
++ tid = Gtk.Timeout.add (30, ()=>{
+ return update_current_offset ();
+ });
+ }
+@@ -1121,7 +1121,7 @@ namespace Synapse.Gui
+ });
+ this.size_allocate.connect (()=>{
+ if (tid == 0)
+- tid = Timeout.add (30, ()=>{
++ tid = Gtk.Timeout.add (30, ()=>{
+ return update_current_offset ();
+ });
+ });
diff --git a/gnome-extra/synapse/files/synapse-0.2.10-libgee-0.8.patch b/gnome-extra/synapse/files/synapse-0.2.10-libgee-0.8.patch
new file mode 100644
index 000000000000..28bdf1acc61c
--- /dev/null
+++ b/gnome-extra/synapse/files/synapse-0.2.10-libgee-0.8.patch
@@ -0,0 +1,87 @@
+diff -Naur synapse-0.2.10.orig/configure.ac synapse-0.2.10/configure.ac
+--- synapse-0.2.10.orig/configure.ac 2012-03-18 20:11:39.000000000 +0100
++++ synapse-0.2.10/configure.ac 2014-08-12 02:52:44.447243355 +0200
+@@ -59,7 +59,7 @@
+ gtk+-2.0 >= $MIN_GTK_VERSION \
+ gtkhotkey-1.0 \
+ gobject-2.0 \
+- gee-1.0 >= $MIN_GEE_VERSION \
++ gee-0.8 >= $MIN_GEE_VERSION \
+ gio-unix-2.0 \
+ json-glib-1.0 >= $MIN_JSON_VERSION \
+ libnotify \
+diff -Naur synapse-0.2.10.orig/src/core/Makefile.am synapse-0.2.10/src/core/Makefile.am
+--- synapse-0.2.10.orig/src/core/Makefile.am 2012-03-18 20:02:58.000000000 +0100
++++ synapse-0.2.10/src/core/Makefile.am 2014-08-12 02:53:07.964488996 +0200
+@@ -7,7 +7,7 @@
+
+ libsynapsecore_la_VALAFLAGS = \
+ --pkg gtk+-2.0 \
+- --pkg gee-1.0 \
++ --pkg gee-0.8 \
+ --pkg json-glib-1.0 \
+ --pkg dbus-glib-1 \
+ --pkg gio-unix-2.0 \
+diff -Naur synapse-0.2.10.orig/src/core/result-set.vala synapse-0.2.10/src/core/result-set.vala
+--- synapse-0.2.10.orig/src/core/result-set.vala 2012-03-18 20:02:41.000000000 +0100
++++ synapse-0.2.10/src/core/result-set.vala 2014-08-12 02:52:44.447243355 +0200
+@@ -20,7 +20,7 @@
+
+ namespace Synapse
+ {
+- public class ResultSet : Object, Gee.Iterable <Gee.Map.Entry <Match, int>>
++ public class ResultSet : Object, Gee.Traversable<Match>, Gee.Iterable <Gee.Map.Entry <Match, int>>
+ {
+ protected Gee.Map<Match, int> matches;
+ protected Gee.Set<unowned string> uris;
+@@ -88,6 +88,11 @@
+ return uri in uris;
+ }
+
++ public bool foreach (Gee.ForallFunc<Match> func)
++ {
++ return matches.keys.foreach (func);
++ }
++
+ public Gee.List<Match> get_sorted_list ()
+ {
+ var l = new Gee.ArrayList<Gee.Map.Entry<Match, int>> ();
+diff -Naur synapse-0.2.10.orig/src/plugins/Makefile.am synapse-0.2.10/src/plugins/Makefile.am
+--- synapse-0.2.10.orig/src/plugins/Makefile.am 2012-03-18 20:04:17.000000000 +0100
++++ synapse-0.2.10/src/plugins/Makefile.am 2014-08-12 02:53:26.878288046 +0200
+@@ -8,7 +8,7 @@
+
+ libplugins_la_VALAFLAGS = \
+ --pkg gtk+-2.0 \
+- --pkg gee-1.0 \
++ --pkg gee-0.8 \
+ --pkg json-glib-1.0 \
+ --pkg dbus-glib-1 \
+ --pkg gio-unix-2.0 \
+diff -Naur synapse-0.2.10.orig/src/ui/keybindings.vala synapse-0.2.10/src/ui/keybindings.vala
+--- synapse-0.2.10.orig/src/ui/keybindings.vala 2012-03-18 20:02:41.000000000 +0100
++++ synapse-0.2.10/src/ui/keybindings.vala 2014-08-12 02:52:44.463910433 +0200
+@@ -82,9 +82,9 @@
+ this.cmd = cmd;
+ this.mods = mods;
+ }
+- public static int compare (void* a, void* b)
++ public static int compare (ModCmd a, ModCmd b)
+ {
+- return (int)(((ModCmd)a).mods) - (int)(((ModCmd)b).mods);
++ return (int)(a.mods) - (int)(b.mods);
+ }
+ }
+
+diff -Naur synapse-0.2.10.orig/src/ui/Makefile.am synapse-0.2.10/src/ui/Makefile.am
+--- synapse-0.2.10.orig/src/ui/Makefile.am 2012-03-18 20:05:19.000000000 +0100
++++ synapse-0.2.10/src/ui/Makefile.am 2014-08-12 02:53:46.262098738 +0200
+@@ -12,7 +12,7 @@
+ --pkg gio-2.0 \
+ --pkg gio-unix-2.0 \
+ --pkg zeitgeist-1.0 \
+- --pkg gee-1.0 \
++ --pkg gee-0.8 \
+ --pkg json-glib-1.0 \
+ --pkg unique-1.0 \
+ --pkg libnotify \
diff --git a/gnome-extra/synapse/files/synapse-0.2.10-zeitgeist.patch b/gnome-extra/synapse/files/synapse-0.2.10-zeitgeist.patch
new file mode 100644
index 000000000000..0311ddfa40ae
--- /dev/null
+++ b/gnome-extra/synapse/files/synapse-0.2.10-zeitgeist.patch
@@ -0,0 +1,12 @@
+=== modified file 'src/ui/Makefile.am'
+--- src/ui/Makefile.am 2012-03-18 19:11:23 +0000
++++ src/ui/Makefile.am 2012-03-18 19:55:48 +0000
+@@ -11,7 +11,6 @@
+ --pkg gdk-x11-2.0 \
+ --pkg gio-2.0 \
+ --pkg gio-unix-2.0 \
+- --pkg zeitgeist-1.0 \
+ --pkg gee-0.8 \
+ --pkg json-glib-1.0 \
+ --pkg unique-1.0 \
+
diff --git a/gnome-extra/synapse/files/synapse-0.2.8.2-underlinking.patch b/gnome-extra/synapse/files/synapse-0.2.8.2-underlinking.patch
new file mode 100644
index 000000000000..dc16a09b2e2c
--- /dev/null
+++ b/gnome-extra/synapse/files/synapse-0.2.8.2-underlinking.patch
@@ -0,0 +1,12 @@
+=== modified file 'src/ui/Makefile.am'
+--- src/ui/Makefile.am 2012-03-18 19:55:48 +0000
++++ src/ui/Makefile.am 2012-03-18 19:57:30 +0000
+@@ -40,6 +40,7 @@
+ $(top_builddir)/src/core/libsynapsecore.la \
+ $(top_builddir)/src/plugins/libplugins.la \
+ $(top_builddir)/src/tile-view/libtileview.la \
++ -lm
+ $(NULL)
+
+ if HAVE_INDICATOR
+
diff --git a/gnome-extra/synapse/files/synapse-0.2.8.2-zeitgeist.patch b/gnome-extra/synapse/files/synapse-0.2.8.2-zeitgeist.patch
new file mode 100644
index 000000000000..22ce69928f76
--- /dev/null
+++ b/gnome-extra/synapse/files/synapse-0.2.8.2-zeitgeist.patch
@@ -0,0 +1,12 @@
+=== modified file 'src/ui/Makefile.am'
+--- src/ui/Makefile.am 2012-03-18 19:11:23 +0000
++++ src/ui/Makefile.am 2012-03-18 19:55:48 +0000
+@@ -11,7 +11,6 @@
+ --pkg gdk-x11-2.0 \
+ --pkg gio-2.0 \
+ --pkg gio-unix-2.0 \
+- --pkg zeitgeist-1.0 \
+ --pkg gee-1.0 \
+ --pkg json-glib-1.0 \
+ --pkg unique-1.0 \
+
diff --git a/gnome-extra/synapse/metadata.xml b/gnome-extra/synapse/metadata.xml
new file mode 100644
index 000000000000..16a80f5e7cfe
--- /dev/null
+++ b/gnome-extra/synapse/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="plugins">Build support for plugins using librest</flag>
+ <flag name="zeitgeist">Add support for Zeitgeist event tracking system</flag>
+ </use>
+ <upstream>
+ <remote-id type="launchpad">synapse-project</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gnome-extra/synapse/synapse-0.2.10-r1.ebuild b/gnome-extra/synapse/synapse-0.2.10-r1.ebuild
new file mode 100644
index 000000000000..5a6a519b2fd0
--- /dev/null
+++ b/gnome-extra/synapse/synapse-0.2.10-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no" # gnome2_src_configure is not being used
+AUTOTOOLS_AUTORECONF=true
+
+inherit gnome2 autotools-utils vala
+
+DESCRIPTION="A program launcher in the style of GNOME Do"
+HOMEPAGE="http://launchpad.net/synapse-project/"
+SRC_URI="http://launchpad.net/synapse-project/${PV%.*}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# "ayatana" support pending on GTK+-3.x version of synapse wrt #411613
+IUSE="plugins +zeitgeist"
+
+RDEPEND="
+ dev-libs/libgee:0.8
+ dev-libs/glib:2
+ dev-libs/json-glib
+ dev-libs/libunique:1
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtkhotkey
+ x11-libs/gtk+:2
+ x11-libs/libnotify
+ x11-libs/pango
+ x11-themes/gnome-icon-theme
+ plugins? ( net-libs/rest )
+ zeitgeist? (
+ dev-libs/libzeitgeist
+ gnome-extra/zeitgeist
+ gnome-extra/zeitgeist-extensions
+ || ( gnome-extra/zeitgeist[fts] gnome-extra/zeitgeist-extensions[fts] )
+ )"
+ #ayatana? ( dev-libs/libappindicator )
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-util/intltool
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.8.2-underlinking.patch
+
+ # Don't crash on empty string (from Arch)
+ "${FILESDIR}"/${PN}-0.2.10-check-null-exec.patch
+
+ # XDG_CURRENT_DESKTOP fix (from Arch)
+ "${FILESDIR}"/${PN}-0.2.10-fix-check-desktop.patch
+
+ # Fix newer gnome support (from OpenSuSE)
+ "${FILESDIR}"/${PN}-0.2.10-gnome-3.10.patch
+
+ # Port to gee-0.8 (from Arch)
+ "${FILESDIR}"/${PN}-0.2.10-libgee-0.8.patch
+
+ # Fix border painting (from OpenSuSE)
+ "${FILESDIR}"/${PN}-0.2.10-fix-border-painting.patch
+
+ "${FILESDIR}"/${PN}-0.2.10-zeitgeist.patch
+)
+
+src_prepare() {
+ sed -i -e 's/GNOME/GNOME;GTK/' data/synapse.desktop.in || die
+ vala_src_prepare
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-indicator=no
+ $(use_enable plugins librest yes)
+ $(use_enable zeitgeist)
+ )
+ autotools-utils_src_configure
+}
diff --git a/gnome-extra/synapse/synapse-0.2.10.ebuild b/gnome-extra/synapse/synapse-0.2.10.ebuild
new file mode 100644
index 000000000000..4aafbb06ec94
--- /dev/null
+++ b/gnome-extra/synapse/synapse-0.2.10.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+VALA_MIN_API_VERSION=0.14
+VALA_MAX_API_VERSION=0.20
+
+inherit gnome2 autotools-utils gnome2-utils vala
+
+DESCRIPTION="A program launcher in the style of GNOME Do"
+HOMEPAGE="http://launchpad.net/synapse-project/"
+SRC_URI="http://launchpad.net/synapse-project/${PV%.*}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# "ayatana" support pending on GTK+-3.x version of synapse wrt #411613
+IUSE="plugins +zeitgeist"
+
+RDEPEND="
+ dev-libs/libgee:0
+ dev-libs/glib:2
+ dev-libs/json-glib
+ dev-libs/libunique:1
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtkhotkey
+ x11-libs/gtk+:2
+ x11-libs/libnotify
+ x11-libs/pango
+ x11-themes/gnome-icon-theme
+ plugins? ( net-libs/rest )
+ zeitgeist? (
+ dev-libs/libzeitgeist
+ gnome-extra/zeitgeist
+ gnome-extra/zeitgeist-extensions
+ || ( gnome-extra/zeitgeist[fts] gnome-extra/zeitgeist-extensions[fts] )
+ )"
+ #ayatana? ( dev-libs/libappindicator )
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-util/intltool
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.8.2-underlinking.patch
+ "${FILESDIR}"/${PN}-0.2.8.2-zeitgeist.patch
+ )
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+src_prepare() {
+ sed -i -e 's/GNOME/GNOME;GTK/' data/synapse.desktop.in || die
+ vala_src_prepare
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-indicator=no
+ $(use_enable plugins librest yes)
+ $(use_enable zeitgeist)
+ )
+ autotools-utils_src_configure
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}