summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-12-28 18:20:19 +0200
committerMart Raudsepp <leio@gentoo.org>2018-12-28 18:22:26 +0200
commit802021a945e43c9400779336b0f6d4c0b245531e (patch)
tree83eb359b0b0fdcae1db5ca6b3e2c8761c40aee94 /gnome-extra
parentmedia-sound/mixxx: Added missing dependencies. (diff)
downloadgentoo-802021a945e43c9400779336b0f6d4c0b245531e.tar.gz
gentoo-802021a945e43c9400779336b0f6d4c0b245531e.tar.bz2
gentoo-802021a945e43c9400779336b0f6d4c0b245531e.zip
gnome-extra/libgda: bump to 5.2.8, compatible with openssl-1.1
Also fix JRE 1.8 patch to not be reverted by the eautoreconf - however no clue if it actually works. Closes: https://bugs.gentoo.org/666156 Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.52, Repoman-2.3.11
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/libgda/Manifest1
-rw-r--r--gnome-extra/libgda/libgda-5.2.8.ebuild166
2 files changed, 167 insertions, 0 deletions
diff --git a/gnome-extra/libgda/Manifest b/gnome-extra/libgda/Manifest
index 365859e91e47..ab2677fd0613 100644
--- a/gnome-extra/libgda/Manifest
+++ b/gnome-extra/libgda/Manifest
@@ -1 +1,2 @@
DIST libgda-5.2.4.tar.xz 12320228 BLAKE2B 567b82934e9fe05abdd7405f17c3e8db1a335698236aed069c66037bb387f34adfc41eae7663d8cedb1ba97d2b54afda15280d745c574e5b28cb1856ff8376b1 SHA512 90449795a64136389c26ee4bbdbd5c1330d441e6c11ff15eff83d0ee39c4ce3abd686222aaa468995496ba1417c0fbc963898107f1806d80648cdc939d3c87cc
+DIST libgda-5.2.8.tar.xz 12506208 BLAKE2B 7174aa862f04ec6c73fe98560914ee307afe75b9713adad70fa7dedf97fd4ddb79c98ad1e9a8919218f7453014d8e71e42730e168fae7c6ca0dc58ae99b0558e SHA512 6512d08df072dfc10837b71b2369ab538fa8bf0cdac51ecbb738a138f5b765f030fc7a88b14232eaab2724af8e749898da146bb63969983d3bcfeb11bc22aece
diff --git a/gnome-extra/libgda/libgda-5.2.8.ebuild b/gnome-extra/libgda/libgda-5.2.8.ebuild
new file mode 100644
index 000000000000..1b78dd77194b
--- /dev/null
+++ b/gnome-extra/libgda/libgda-5.2.8.ebuild
@@ -0,0 +1,166 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+GNOME2_EAUTORECONF="yes"
+PYTHON_COMPAT=( python2_7 )
+VALA_USE_DEPEND="vapigen"
+
+inherit db-use eutils flag-o-matic gnome2 java-pkg-opt-2 python-single-r1 vala
+
+DESCRIPTION="GNOME database access library"
+HOMEPAGE="http://www.gnome-db.org/"
+LICENSE="GPL-2+ LGPL-2+"
+
+IUSE="berkdb canvas debug firebird gnome-keyring gtk graphviz http +introspection json ldap mdb mysql oci8 postgres reports sourceview ssl vala"
+REQUIRED_USE="
+ reports? ( ${PYTHON_REQUIRED_USE} )
+ canvas? ( gtk )
+ graphviz? ( gtk )
+ sourceview? ( gtk )
+ vala? ( introspection )
+"
+# firebird license is not GPL compatible
+
+SLOT="5/4" # subslot = libgda-5.0 soname version
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ app-text/iso-codes
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libxml2-2
+ dev-libs/libxslt
+ sys-libs/readline:0=
+ sys-libs/ncurses:0=
+ berkdb? ( sys-libs/db:* )
+ firebird? ( dev-db/firebird )
+ gnome-keyring? ( app-crypt/libsecret )
+ gtk? (
+ >=x11-libs/gtk+-3.0.0:3
+ canvas? ( x11-libs/goocanvas:2.0= )
+ sourceview? ( x11-libs/gtksourceview:3.0 )
+ graphviz? ( media-gfx/graphviz )
+ )
+ http? ( >=net-libs/libsoup-2.24:2.4 )
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+ json? ( dev-libs/json-glib )
+ ldap? ( net-nds/openldap:= )
+ mdb? ( >app-office/mdbtools-0.5:= )
+ mysql? ( virtual/mysql:= )
+ postgres? ( dev-db/postgresql:= )
+ reports? (
+ ${PYTHON_DEPS}
+ dev-java/fop
+ dev-python/reportlab )
+ ssl? ( dev-libs/openssl:0= )
+ >=dev-db/sqlite-3.10.2:3=
+ vala? ( dev-libs/libgee:0.8 )
+"
+
+# java dep shouldn't rely on slots, bug #450004
+DEPEND="${RDEPEND}
+ >=app-text/gnome-doc-utils-0.9
+ app-text/yelp-tools
+ dev-util/glib-utils
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40.6
+ virtual/pkgconfig
+ java? ( >=virtual/jdk-1.6 )
+ vala? ( $(vala_depend) )
+"
+
+# FIXME: lots of tests failing. Check if they still fail in 5.1.2
+# firebird support bindist-restricted because it is not GPL compatible
+RESTRICT="
+ test
+ firebird? ( bindist )
+"
+
+pkg_setup() {
+ java-pkg-opt-2_pkg_setup
+ use reports && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Fix compilation with -Werror=format-security (from 'master')
+ eapply "${FILESDIR}"/${PN}-5.2.4-format-security.patch
+
+ use berkdb && append-cppflags "-I$(db_includedir)"
+
+ use reports ||
+ sed -e '/SUBDIRS =/ s/trml2html//' \
+ -e '/SUBDIRS =/ s/trml2pdf//' \
+ -i libgda-report/RML/Makefile.{am,in} || die
+
+ # Prevent file collisions with libgda:4
+ eapply "${FILESDIR}/${PN}-4.99.1-gda-browser-doc-collision.patch"
+ eapply "${FILESDIR}/${PN}-4.99.1-control-center-icon-collision.patch"
+ # Move files with mv (since epatch can't handle rename diffs) and
+ # update pre-generated gtk-doc files (for non-git versions of libgda)
+ local f
+ for f in tools/browser/doc/gda-browser* ; do
+ mv ${f} ${f/gda-browser/gda-browser-5.0} || die "mv ${f} failed"
+ done
+ for f in tools/browser/doc/html/gda-browser.devhelp* ; do
+ sed -e 's:name="gda-browser":name="gda-browser-5.0":' \
+ -i ${f} || die "sed ${f} failed"
+ mv ${f} ${f/gda-browser/gda-browser-5.0} || die "mv ${f} failed"
+ done
+ for f in control-center/data/*_gda-control-center.png ; do
+ mv ${f} ${f/_gda-control-center.png/_gda-control-center-5.0.png} ||
+ die "mv ${f} failed"
+ done
+
+ gnome2_src_prepare
+ java-pkg-opt-2_src_prepare
+ use vala && vala_src_prepare
+
+ # Support JRE 1.8 (from Fedora) - patches configure, so applied AFTER gnome2_src_prepare runs eautoreconf
+ eapply "${FILESDIR}"/${PN}-5.2.4-jre18.patch
+
+}
+
+src_configure() {
+ # Upstream broken configure handling for UI library introspection and vala bindings if passing a choice with use_enable - https://gitlab.gnome.org/GNOME/libgda/issues/158
+ # But if we don't pass an explicit choice, it behaves as we need (only enable them if --enable-ui AND the appropriate --enable-introspection or --enable-vala)
+ gnome2_src_configure \
+ --with-help \
+ --disable-default-binary \
+ --disable-static \
+ --enable-system-sqlite \
+ $(use_with berkdb bdb /usr) \
+ $(use_with canvas goocanvas) \
+ $(use_enable debug) \
+ $(use_with firebird firebird /usr) \
+ $(use_with gnome-keyring libsecret) \
+ $(use_with graphviz) \
+ $(use_with gtk ui) \
+ $(use_with http libsoup) \
+ $(use_enable introspection) \
+ "$(use_with java java $JAVA_HOME)" \
+ $(use_enable json) \
+ $(use_with ldap) \
+ $(use_with mdb mdb /usr) \
+ $(use_with mysql mysql /usr) \
+ $(use_with oci8 oracle) \
+ $(use_with postgres postgres /usr) \
+ $(use_enable ssl crypto) \
+ $(use_with sourceview gtksourceview) \
+ $(use_enable vala)
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+ java-pkg-opt-2_pkg_preinst
+}
+
+src_install() {
+ gnome2_src_install
+ if use reports; then
+ for t in trml2{html,pdf}; do
+ python_scriptinto /usr/share/libgda-5.0/gda_${t}
+ python_doscript libgda-report/RML/${t}/${t}.py
+ done
+ fi
+}