summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2016-01-04 08:55:01 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2016-01-04 08:55:01 +0100
commitebf3ff828c1015a2be0d02e4bc7e948008400f55 (patch)
treea750fad6801c1380daf9006cbf988921dc1c09d6 /gnome-extra
parentnet-misc/electrum: update SRC_URI (diff)
downloadgentoo-ebf3ff828c1015a2be0d02e4bc7e948008400f55.tar.gz
gentoo-ebf3ff828c1015a2be0d02e4bc7e948008400f55.tar.bz2
gentoo-ebf3ff828c1015a2be0d02e4bc7e948008400f55.zip
gnome-extra/gnome-dvb-daemon simple fixes
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-dvb-daemon/gnome-dvb-daemon-0.2.90.ebuild55
1 files changed, 32 insertions, 23 deletions
diff --git a/gnome-extra/gnome-dvb-daemon/gnome-dvb-daemon-0.2.90.ebuild b/gnome-extra/gnome-dvb-daemon/gnome-dvb-daemon-0.2.90.ebuild
index 6b2e8bdd1a9f..676fe14a04c9 100644
--- a/gnome-extra/gnome-dvb-daemon/gnome-dvb-daemon-0.2.90.ebuild
+++ b/gnome-extra/gnome-dvb-daemon/gnome-dvb-daemon-0.2.90.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
GCONF_DEBUG="no"
-PYTHON_COMPAT=( python{3_3,3_4} )
-VALA_MIN_API_VERSION="0.25"
+PYTHON_COMPAT=( python{3_4,3_5} )
+VALA_MIN_API_VERSION="0.26"
inherit eutils gnome2 multilib python-any-r1 vala
@@ -22,45 +22,54 @@ RDEPEND=">=dev-libs/glib-2.32.0:2
>=media-libs/gst-plugins-good-1.4.0:1.0
>=media-libs/gst-plugins-bad-1.4.0:1.0
>=dev-libs/libgee-0.8:0.8
- >=dev-db/sqlite-3.4
+ >=dev-db/sqlite-3.4:3
>=media-libs/gst-rtsp-server-1.4.5:1.0
media-plugins/gst-plugins-dvb:1.0
dev-python/gst-python:1.0
>=dev-python/pygobject-3.2.1:3
- >=dev-libs/gobject-introspection-1.44.0
+ >=dev-libs/gobject-introspection-1.44.0:0
x11-libs/gtk+:3[introspection]
- virtual/libgudev
+ virtual/libgudev:0
vala? ( $(vala_depend) )
totem? ( media-video/totem )"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
- >=dev-lang/perl-5.8.1
- >=dev-util/intltool-0.40.0
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
- >=sys-devel/libtool-2.2.6"
-
-pkg_setup() {
- G2CONF="${G2CONF} \
- $(use_enable nls)
- $(use_enable totem totem-plugin)"
- use totem && G2CONF="${G2CONF} \
- --with-totem-plugin-dir=/usr/$(get_libdir)/totem/plugins"
- python-any-r1_pkg_setup
-}
+ >=dev-lang/perl-5.8.1:0
+ >=dev-util/intltool-0.40.0:0
+ >=dev-libs/libltdl-2.2.6:0
+ virtual/pkgconfig:0
+ nls? ( >=sys-devel/gettext-0.18.1:0 )"
src_prepare() {
python_fix_shebang .
gnome2_src_prepare
- use vala && vala_src_prepare
+ if use vala ; then
+ vala_src_prepare
+ fi
+}
+
+src_configure() {
+ local myconf
+ if use totem ; then
+ myconf = "${myconf} --with-totem-plugin-dir=/usr/$(get_libdir)/totem/plugins"
+ fi
+ gnome2_src_configure \
+ $(use_enable nls) \
+ $(use_enable totem totem-plugin) \
+ ${myconf}
+ python-any-r1_pkg_setup
}
pkg_postinst() {
- use totem && python_optimize
+ if use totem ; then
+ python_optimize
+ fi
gnome2_pkg_postinst
}
pkg_postrm() {
- use totem && python_optimize
+ if use totem ; then
+ python_optimize
+ fi
gnome2_pkg_postrm
}