summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-06-06 16:01:34 -0400
committerAaron Bauman <bman@gentoo.org>2020-06-06 20:12:14 -0400
commit7646a493e2cc3c12c6154539bb18aa2784291209 (patch)
tree6c7d39e1a9d8d3892b98501c433bc392c6ce07f7 /gui-libs
parentx11-wm/herbstluftwm: Version 0.8.3 (diff)
downloadgentoo-7646a493e2cc3c12c6154539bb18aa2784291209.tar.gz
gentoo-7646a493e2cc3c12c6154539bb18aa2784291209.tar.bz2
gentoo-7646a493e2cc3c12c6154539bb18aa2784291209.zip
gui-libs/wf-config: remove debug symbols
Closes: https://bugs.gentoo.org/727342 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/wf-config/wf-config-0.4.0-r1.ebuild (renamed from gui-libs/wf-config/wf-config-0.4.0.ebuild)17
-rw-r--r--gui-libs/wf-config/wf-config-9999.ebuild15
2 files changed, 5 insertions, 27 deletions
diff --git a/gui-libs/wf-config/wf-config-0.4.0.ebuild b/gui-libs/wf-config/wf-config-0.4.0-r1.ebuild
index b52ae6b08e27..d415dd76e3da 100644
--- a/gui-libs/wf-config/wf-config-0.4.0.ebuild
+++ b/gui-libs/wf-config/wf-config-0.4.0-r1.ebuild
@@ -10,21 +10,20 @@ HOMEPAGE="https://github.com/WayfireWM/wf-config"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+ EGIT_REPO_URI="https://github.com/WayfireWM/wf-config.git"
else
- SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/${PV}/${P}.tar.xz"
+ SRC_URI="https://github.com/WayfireWM/wf-config/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi
LICENSE="MIT"
SLOT="0"
-IUSE="debug"
DEPEND="
dev-libs/libevdev
dev-libs/libxml2
+ ~gui-libs/wlroots-0.10.1
media-libs/glm
- <=gui-libs/wlroots-0.10.1
"
RDEPEND="${DEPEND}"
@@ -34,13 +33,3 @@ BDEPEND="
dev-libs/wayland-protocols
virtual/pkgconfig
"
-
-src_configure () {
- local emesonargs=""
- if use debug; then
- emesonargs+=(
- "-Db_sanitize=address,undefined"
- )
- fi
- meson_src_configure
-}
diff --git a/gui-libs/wf-config/wf-config-9999.ebuild b/gui-libs/wf-config/wf-config-9999.ebuild
index 3efe9aa8cc6b..93cc2eacb2c5 100644
--- a/gui-libs/wf-config/wf-config-9999.ebuild
+++ b/gui-libs/wf-config/wf-config-9999.ebuild
@@ -10,15 +10,14 @@ HOMEPAGE="https://github.com/WayfireWM/wf-config"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+ EGIT_REPO_URI="https://github.com/WayfireWM/wf-config.git"
else
- SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/${PV}/${P}.tar.xz"
+ SRC_URI="https://github.com/WayfireWM/wf-config/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi
LICENSE="MIT"
SLOT="0"
-IUSE="debug"
DEPEND="
dev-libs/libevdev
@@ -34,13 +33,3 @@ BDEPEND="
dev-libs/wayland-protocols
virtual/pkgconfig
"
-
-src_configure () {
- local emesonargs=""
- if use debug; then
- emesonargs+=(
- "-Db_sanitize=address,undefined"
- )
- fi
- meson_src_configure
-}