summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authoryemou Hannam <meeyou@tuta.io>2021-10-21 22:34:17 -0400
committerJoonas Niilola <juippis@gentoo.org>2021-11-10 09:50:39 +0200
commit0088c608826a9ee359815bff9e47201f4a4b8dff (patch)
tree04537d15fa34961238787b6501b45c8756136843 /gui-wm
parentdev-python/flexmock: add 0.11.1 (diff)
downloadgentoo-0088c608826a9ee359815bff9e47201f4a4b8dff.tar.gz
gentoo-0088c608826a9ee359815bff9e47201f4a4b8dff.tar.bz2
gentoo-0088c608826a9ee359815bff9e47201f4a4b8dff.zip
gui-wm/wayfire: add debug useflag
Build wayfire with asan as suggested by upstream for debugging crashes. Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: yemou Hannam <meeyou@tuta.io> Closes: https://github.com/gentoo/gentoo/pull/22665 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/wayfire/wayfire-0.7.2.ebuild10
-rw-r--r--gui-wm/wayfire/wayfire-9999.ebuild10
2 files changed, 16 insertions, 4 deletions
diff --git a/gui-wm/wayfire/wayfire-0.7.2.ebuild b/gui-wm/wayfire/wayfire-0.7.2.ebuild
index eca2999b5712..50b70ce184dc 100644
--- a/gui-wm/wayfire/wayfire-0.7.2.ebuild
+++ b/gui-wm/wayfire/wayfire-0.7.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit meson
+inherit meson toolchain-funcs
DESCRIPTION="compiz like 3D wayland compositor"
HOMEPAGE="https://github.com/WayfireWM/wayfire"
@@ -18,7 +18,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="+gles +system-wfconfig +system-wlroots X"
+IUSE="debug +gles +system-wfconfig +system-wlroots X"
DEPEND="
dev-libs/libevdev
@@ -71,7 +71,13 @@ src_configure() {
$(meson_feature system-wlroots use_system_wlroots)
$(meson_feature X xwayland)
$(meson_use gles enable_gles32)
+ $(usex debug --buildtype=debug "")
+ $(usex debug -Db_sanitize=address,undefined "")
)
+
+ # Clang will fail to link without this
+ tc-is-clang && emesonargs+=( $(usex debug -Db_lundef=false "") )
+
meson_src_configure
}
diff --git a/gui-wm/wayfire/wayfire-9999.ebuild b/gui-wm/wayfire/wayfire-9999.ebuild
index 8c86b4aadda7..aa79e894749c 100644
--- a/gui-wm/wayfire/wayfire-9999.ebuild
+++ b/gui-wm/wayfire/wayfire-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit meson
+inherit meson toolchain-funcs
DESCRIPTION="compiz like 3D wayland compositor"
HOMEPAGE="https://github.com/WayfireWM/wayfire"
@@ -18,7 +18,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="+gles +system-wfconfig +system-wlroots X"
+IUSE="debug +gles +system-wfconfig +system-wlroots X"
DEPEND="
dev-libs/libevdev
@@ -65,7 +65,13 @@ src_configure() {
$(meson_feature system-wlroots use_system_wlroots)
$(meson_feature X xwayland)
$(meson_use gles enable_gles32)
+ $(usex debug --buildtype=debug "")
+ $(usex debug -Db_sanitize=address,undefined "")
)
+
+ # Clang will fail to link without this
+ tc-is-clang && emesonargs+=( $(usex debug -Db_lundef=false "") )
+
meson_src_configure
}