summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-06 21:10:03 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-06 21:11:17 +0200
commitcace445d5118ee027dc43f829fc50f27d623134c (patch)
tree2dfaad77bd443bf2f28d49d3bcf8c2880aa92ff3 /kde-apps/print-manager
parentdev-util/rbtools: maintainer-needed (diff)
downloadgentoo-cace445d5118ee027dc43f829fc50f27d623134c.tar.gz
gentoo-cace445d5118ee027dc43f829fc50f27d623134c.tar.bz2
gentoo-cace445d5118ee027dc43f829fc50f27d623134c.zip
kde-apps: Add KDE Applications 19.08.1
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/print-manager')
-rw-r--r--kde-apps/print-manager/Manifest1
-rw-r--r--kde-apps/print-manager/print-manager-19.08.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-apps/print-manager/Manifest b/kde-apps/print-manager/Manifest
index 04f4a9a3ef85..d28c9286577d 100644
--- a/kde-apps/print-manager/Manifest
+++ b/kde-apps/print-manager/Manifest
@@ -1,2 +1,3 @@
DIST print-manager-19.04.3.tar.xz 240784 BLAKE2B 8f638c84e59bec4897a84f335adbf285df2b5c5d8284f4d7045902aea1a7e099d8d9e4b8ba5f2c398ac2ca18b8cc8a9f4f7c8420a8c349ccc897823d928d6cd6 SHA512 d0e4972c5b2553a1118731c3c0042c907e71feac64b43135463fc909d729bff5b9479804f7793fbc629dffd487123ad9a8a7cadb64a2a3ce1086d9be177a3701
DIST print-manager-19.08.0.tar.xz 241252 BLAKE2B 8550fafa6bf0d39d17211b4bea4faea64ef1b1d0832d5113db714f88ff87d5fad4ab69f8cd76c65cd91019a4f3f206a17b471340da2c303cb2dd76f36d935de7 SHA512 3197faa830f87ffacc080fb8e7c325dac07332175ccd740c4830e58dcb6faad9e277ad0666fdb45729c11851b40f091de9db19f0caed1abf13bfaeedb3127b8a
+DIST print-manager-19.08.1.tar.xz 245276 BLAKE2B 8acaa70bcb3a95e98cd8594949a64a8aff90491f125379ccd4d55e32f7ebf0710f7ee7523df20980994453ffbec66c1cab45665fb16cce76c51af1db231f3b96 SHA512 50d939f16a7d4622a9bfad181b339f31f046b86f7fab16aa17739a8f0e0ee720866d50cb4faeca9d47e0497388e71f71aa4a5c8494cf07f302006b7176f52678
diff --git a/kde-apps/print-manager/print-manager-19.08.1.ebuild b/kde-apps/print-manager/print-manager-19.08.1.ebuild
new file mode 100644
index 000000000000..1ae66560761e
--- /dev/null
+++ b/kde-apps/print-manager/print-manager-19.08.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="Manage print jobs and printers in Plasma"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+gtk"
+
+DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ net-print/cups
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ gtk? ( app-admin/system-config-printer )
+"
+
+pkg_postinst(){
+ kde5_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]] && ! use gtk ; then
+ ewarn "By switching off \"gtk\" USE flag, you have chosen to do without"
+ ewarn "an important, though optional, runtime dependency:"
+ ewarn
+ ewarn "app-admin/system-config-printer"
+ ewarn
+ ewarn "${PN} will work nevertheless, but is going to be less comfortable"
+ ewarn "and will show the following error status during runtime:"
+ ewarn
+ ewarn "\"Failed to group devices: 'The name org.fedoraproject.Config.Printing"
+ ewarn "was not provided by any .service files'\""
+ fi
+}