summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-02-12 00:23:57 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-02-12 00:34:46 +0100
commitac7535cce2ad786c5ec95d8c68902afd64a3cbca (patch)
tree9a69a0ead2c4c2265b549330f34be8e8cad804f1 /kde-apps
parentkde-apps/cantor: Add einfo about LaTeX support (diff)
downloadgentoo-ac7535cce2ad786c5ec95d8c68902afd64a3cbca.tar.gz
gentoo-ac7535cce2ad786c5ec95d8c68902afd64a3cbca.tar.bz2
gentoo-ac7535cce2ad786c5ec95d8c68902afd64a3cbca.zip
kde-apps/cantor: Fix build w/ USE=python and KF-5.31
Package-Manager: portage-2.3.3
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/cantor/cantor-16.12.2.ebuild5
-rw-r--r--kde-apps/cantor/files/cantor-16.12.2-python-kf-5.31.patch28
2 files changed, 32 insertions, 1 deletions
diff --git a/kde-apps/cantor/cantor-16.12.2.ebuild b/kde-apps/cantor/cantor-16.12.2.ebuild
index 19314488a8de..669532f80988 100644
--- a/kde-apps/cantor/cantor-16.12.2.ebuild
+++ b/kde-apps/cantor/cantor-16.12.2.ebuild
@@ -56,7 +56,10 @@ RDEPEND="${RDEPEND}"
RESTRICT+=" test"
-PATCHES=( "${FILESDIR}"/${P}-bashism.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-bashism.patch
+ "${FILESDIR}"/${P}-python-kf-5.31.patch
+)
pkg_pretend() {
kde5_pkg_pretend
diff --git a/kde-apps/cantor/files/cantor-16.12.2-python-kf-5.31.patch b/kde-apps/cantor/files/cantor-16.12.2-python-kf-5.31.patch
new file mode 100644
index 000000000000..b8c5161b49d3
--- /dev/null
+++ b/kde-apps/cantor/files/cantor-16.12.2-python-kf-5.31.patch
@@ -0,0 +1,28 @@
+commit 4b8ef6bed62daced90c7826985650c2a813d2996
+Author: Jonathan Riddell <jr@jriddell.org>
+Date: Wed Feb 8 14:56:48 2017 +0000
+
+ remove modern C++ use to fix compile with current KDE policy
+
+diff --git a/src/backends/python/pythonhighlighter.cpp b/src/backends/python/pythonhighlighter.cpp
+index 4064524..87b10dd 100644
+--- a/src/backends/python/pythonhighlighter.cpp
++++ b/src/backends/python/pythonhighlighter.cpp
+@@ -87,7 +87,7 @@ void PythonHighlighter::highlightBlock(const QString &text)
+ while (pos < text.length()) {
+ // Trying to close current environments
+ bool triggered = false;
+- for (int i = 0; i < flags.size() and not triggered; i++) {
++ for (int i = 0; i < flags.size() && !triggered; i++) {
+ int flag = flags[i];
+ QRegExp &regexp = regexps[i];
+ QTextCharFormat &format = formats[i];
+@@ -126,7 +126,7 @@ void PythonHighlighter::highlightBlock(const QString &text)
+ singleLineCommentStart.indexIn(text, pos);
+
+ if (singleLineCommentStartPos != -1
+- and singleLineCommentStartPos < minPos) {
++ && singleLineCommentStartPos < minPos) {
+ setFormat(pos, text.length() - pos, commentFormat());
+ break;
+ } else if (minRegexp) {