summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-10-19 03:36:05 +1100
committerMichael Palimaka <kensington@gentoo.org>2015-10-19 03:40:37 +1100
commit7521e12452971ebfe46c0fcb3d009689e59d28ca (patch)
tree5400a13c692935424597edb4c70a7a5efb301ed9 /kde-base
parentdev-java/ehcache: Clean up SLOT:0 ebuilds as they're not used in the tree and... (diff)
downloadgentoo-7521e12452971ebfe46c0fcb3d009689e59d28ca.tar.gz
gentoo-7521e12452971ebfe46c0fcb3d009689e59d28ca.tar.bz2
gentoo-7521e12452971ebfe46c0fcb3d009689e59d28ca.zip
kde-base/kactivitymanagerd: skip rpath
Because install is bypassed, cmake's usual rpath processing doesn't happen, resulting in a null rpath. No rpath is required for this package, so skip the whole thing entirely. Gentoo-bug: 563406 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kactivitymanagerd/kactivitymanagerd-4.13.3-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-base/kactivitymanagerd/kactivitymanagerd-4.13.3-r1.ebuild b/kde-base/kactivitymanagerd/kactivitymanagerd-4.13.3-r1.ebuild
new file mode 100644
index 000000000000..09a95b222a26
--- /dev/null
+++ b/kde-base/kactivitymanagerd/kactivitymanagerd-4.13.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KMNAME="kactivities"
+inherit kde4-base
+
+DESCRIPTION="KDE Activity Manager Daemon"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ !<kde-base/kactivities-4.14.3-r1
+ !kde-frameworks/kactivities
+"
+
+S=${WORKDIR}/${KMNAME}-${PV}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_SKIP_RPATH=ON
+ -DWITH_NepomukCore=OFF
+ )
+ kde4-base_src_configure
+}
+
+src_install() {
+ dobin "${BUILD_DIR}/src/service/${PN}"
+}