summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-15 15:52:24 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-11-23 15:59:10 +0100
commit47acd0c95ed6d5cae3026303d7c3fcace06406c4 (patch)
treeafcfbd7ba72ced33b5575aa0905d865aa5d16a0d /kde-frameworks
parentkde-frameworks/kconfigwidgets: Drop 5.88.0 (r0) (diff)
downloadgentoo-47acd0c95ed6d5cae3026303d7c3fcace06406c4.tar.gz
gentoo-47acd0c95ed6d5cae3026303d7c3fcace06406c4.tar.bz2
gentoo-47acd0c95ed6d5cae3026303d7c3fcace06406c4.zip
kde-frameworks/kirigami: PageRowGlobalToolBarUI: don't animate opacity
Upstream commit 67ec2a1873e3d750529043b243043cfd2e2f9ec6 KDE-bug: https://bugs.kde.org/show_bug.cgi?id=417636 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/kirigami/files/kirigami-5.88.0-PageRowGlobalToolBarUI-dont-animate-opacity.patch56
-rw-r--r--kde-frameworks/kirigami/kirigami-5.88.0-r1.ebuild48
2 files changed, 104 insertions, 0 deletions
diff --git a/kde-frameworks/kirigami/files/kirigami-5.88.0-PageRowGlobalToolBarUI-dont-animate-opacity.patch b/kde-frameworks/kirigami/files/kirigami-5.88.0-PageRowGlobalToolBarUI-dont-animate-opacity.patch
new file mode 100644
index 000000000000..85b2a24f5909
--- /dev/null
+++ b/kde-frameworks/kirigami/files/kirigami-5.88.0-PageRowGlobalToolBarUI-dont-animate-opacity.patch
@@ -0,0 +1,56 @@
+From 67ec2a1873e3d750529043b243043cfd2e2f9ec6 Mon Sep 17 00:00:00 2001
+From: Nate Graham <nate@kde.org>
+Date: Wed, 10 Nov 2021 20:44:53 -0700
+Subject: [PATCH] PageRowGlobalToolBarUI: don't animate opacity
+
+Doing so causes flickering in System Settings and KInfoCenter because of
+how the titles are rendered. It also doesn't make conceptual sense since
+the style of toolbar generally doesn't change so the user would never
+actually see the animated opacity change in the first place.
+
+BUG: 417636
+FIXED-IN: 5.89
+---
+ .../globaltoolbar/PageRowGlobalToolBarUI.qml | 13 +++----------
+ 1 file changed, 3 insertions(+), 10 deletions(-)
+
+diff --git a/src/controls/private/globaltoolbar/PageRowGlobalToolBarUI.qml b/src/controls/private/globaltoolbar/PageRowGlobalToolBarUI.qml
+index 640ab51e..c536fed7 100644
+--- a/src/controls/private/globaltoolbar/PageRowGlobalToolBarUI.qml
++++ b/src/controls/private/globaltoolbar/PageRowGlobalToolBarUI.qml
+@@ -106,8 +106,8 @@ Kirigami.AbstractApplicationHeader {
+ Layout.preferredHeight: -1
+ property Kirigami.PageRow pageRow: root
+
+- opacity: layerIsMainRow && active
+- enabled: opacity > 0
++ visible: layerIsMainRow && active
++ enabled: visible
+
+ asynchronous: true
+
+@@ -115,13 +115,6 @@ Kirigami.AbstractApplicationHeader {
+
+ //TODO: different implementation?
+ source: globalToolBar.actualStyle == Kirigami.ApplicationHeaderStyle.TabBar ? Qt.resolvedUrl("TabBarControl.qml") : Qt.resolvedUrl("BreadcrumbControl.qml")
+-
+- Behavior on opacity {
+- OpacityAnimator {
+- duration: Kirigami.Units.longDuration
+- easing.type: Easing.InOutQuad
+- }
+- }
+ }
+
+ Item {
+@@ -137,6 +130,6 @@ Kirigami.AbstractApplicationHeader {
+ Layout.preferredWidth: height
+ }
+ }
+- background.opacity: breadcrumbLoader.opacity
++ background.visible: breadcrumbLoader.visible
+ }
+
+--
+GitLab
+
diff --git a/kde-frameworks/kirigami/kirigami-5.88.0-r1.ebuild b/kde-frameworks/kirigami/kirigami-5.88.0-r1.ebuild
new file mode 100644
index 000000000000..a161344b23b0
--- /dev/null
+++ b/kde-frameworks/kirigami/kirigami-5.88.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_EXAMPLES="true"
+ECM_QTHELP="false"
+ECM_TEST="true"
+KDE_ORG_NAME="${PN}2"
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Lightweight user interface framework for mobile and convergent applications"
+HOMEPAGE="https://techbase.kde.org/Kirigami"
+EGIT_REPO_URI="${EGIT_REPO_URI/${PN}2/${PN}}"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires package to already be installed
+RESTRICT="test"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-${QTMIN}:5
+"
+DEPEND="
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtgraphicaleffects-${QTMIN}:5
+"
+
+PATCHES=( "${FILESDIR}"/${P}-PageRowGlobalToolBarUI-dont-animate-opacity.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=$(usex examples)
+ )
+
+ ecm_src_configure
+}