summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-23 12:16:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-23 18:46:25 +0200
commit04b7a5abc61721150cbdaefb391c4365903d11a1 (patch)
tree17167a551e6bc11df15961a74f7e0e1dbbb04cf6 /kde-plasma/ksshaskpass
parentapp-crypt/argon2: Use optimized code on x86 only (diff)
downloadgentoo-04b7a5abc61721150cbdaefb391c4365903d11a1.tar.gz
gentoo-04b7a5abc61721150cbdaefb391c4365903d11a1.tar.bz2
gentoo-04b7a5abc61721150cbdaefb391c4365903d11a1.zip
kde-plasma: KDE Plasma 5.17.1 version bump
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.17.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 1e4e2ab8961c..1cd5225ddf2c 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1 +1,2 @@
DIST ksshaskpass-5.16.5.tar.xz 21416 BLAKE2B 832f4fcce536feea013ae3b71f1346e6dc6ddddc6036b000979d0860181a40f2eaf016c0ba59ac1fac929eabeed51a494fa55f8da062d58c27bf9cc711787f72 SHA512 b2ca1245ca55fce2fdd722b5b318bf137efffb9d6ee8ece30706cc369b51e1943f738cd95be29a01fd74e184175f4ce0d6fefdc58a2a621d80358dbfe293cfb9
+DIST ksshaskpass-5.17.1.tar.xz 21380 BLAKE2B 1c85ddc3c83020a3d0ca7504cce088a1dee7e7793fa0b295185826069d60ccd57d2be87a8e0c7eb2944b85d51284b3539d3de30e5f6c03e12235bdf513ec41cd SHA512 4b8545201107884f15995b35ee430586dfbac899a37f565c078a181ea4c92035c333bdf6e0b792a5b4887fdf4dcb63ce305c2b04c0312af61d1a3a221bffccec
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.17.1.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.17.1.ebuild
new file mode 100644
index 000000000000..9e6cbd72bddd
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.17.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://cgit.kde.org/ksshaskpass.git"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh (ATTN: Path moved!)"
+ elog
+ elog "In order to have ssh-agent start with Plasma 5, do the following:"
+ elog " * Copy the necessary files to your home directory:"
+ elog " - cp /etc/plasma/startup/10-agent-startup.sh ~/.config/plasma-workspace/env/"
+ elog " - cp /etc/plasma/shutdown/10-agent-shutdown.sh ~/.config/plasma-workspace/shutdown/"
+ elog " * Edit 10-agent-startup.sh and uncomment the lines enabling ssh-agent."
+ elog " * In 10-agent-shutdown.sh uncomment the respective lines to properly kill"
+ elog " the agent when the session ends."
+}