summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-07 19:27:01 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-07 23:08:18 +0100
commit6adb5443037382add02196d68c5612c9aa30693a (patch)
tree6588679e29e2e00df6cae5ab1e06329a49f46f2b /kde-plasma/ksshaskpass
parentmedia-libs/qtav: Fix build w/ Qt 5.14 (diff)
downloadgentoo-6adb5443037382add02196d68c5612c9aa30693a.tar.gz
gentoo-6adb5443037382add02196d68c5612c9aa30693a.tar.bz2
gentoo-6adb5443037382add02196d68c5612c9aa30693a.zip
kde-plasma: Add KDE Plasma 5.17.5
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.17.5.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 40d2861df8e2..5ed44d58f3ee 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1 +1,2 @@
DIST ksshaskpass-5.17.4.tar.xz 21468 BLAKE2B 29dae019ed6d4ee4806540b4e0ca2d3513faa0c9fea6f566172fa3f07745e354dc8821b41e3a282aa8a038efc80ca830d94af0669cd270d625ede355a27b1736 SHA512 fbb1031fd7541f37c4ad1119ad41ea7df6ca783cc6f1b53d40f7a11635fff1f7f60f6bc6d4860ec5e99caa3f293346cd71d7ddd6e05a28d60e71341eaff40121
+DIST ksshaskpass-5.17.5.tar.xz 21372 BLAKE2B 134a533570b75d66cff195819d41b782b67e0f308d6b36efdd7ca223cfb8994baf29506e3cfc34c6786d35eedf792ed6519b40b0f39360468465c76a197c8362 SHA512 c3a6d5b914c13cdd2ca94a237168702729755ba51e036bef1fb5f09f9e7d1c01c176ba14f225c5ae3781434e8fcc047dd250f9da8d3704da09e9712819a5948a
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.17.5.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.17.5.ebuild
new file mode 100644
index 000000000000..2eb06335f07a
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.17.5.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.64.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://cgit.kde.org/ksshaskpass.git"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ ecm_pkg_setup
+
+ local srcfile=/etc/plasma/startup/05-ksshaskpass.sh
+ local newfile=/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh
+ if [[ -f "${EROOT}"${srcfile} ]]; then
+ local md5=$(md5sum "${EROOT}"${srcfile})
+ if [[ ${md5%% *} != 615ae8f5b0090ff7f51d0edee7885d55 ]]; then
+ elog "Existing modified "${EPREFIX}"${srcfile} detected."
+ elog "Copying to "${EPREFIX}"${newfile}..."
+ cp -v "${EROOT}"${srcfile} "${T}"/ || die
+ fi
+ fi
+}
+
+src_prepare() {
+ ecm_src_prepare
+ if [[ ! -f "${T}"/05-ksshaskpass.sh ]]; then
+ cp "${FILESDIR}"/05-ksshaskpass.sh "${T}"/ || die
+ fi
+}
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 5,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+
+ # Clean up pre-5.17.4 script
+ if [[ -e "${EROOT}"/etc/plasma/startup/05-ksshaskpass.sh ]]; then
+ rm "${EROOT}"/etc/plasma/startup/05-ksshaskpass.sh || die
+ elog "Removed obsolete ${EPREFIX}/etc/plasma/startup/05-ksshaskpass.sh"
+ fi
+}