summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-06 21:12:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-07 09:53:59 +0200
commita98fc176b8e977eedb3501cf0617948c22547310 (patch)
tree8cc2b8bc25d8a8e6525b49e531e9a1299553f0a6 /kde-plasma/ksshaskpass
parentdev-python/pebble: Bump to 4.5.2 (diff)
downloadgentoo-a98fc176b8e977eedb3501cf0617948c22547310.tar.gz
gentoo-a98fc176b8e977eedb3501cf0617948c22547310.tar.bz2
gentoo-a98fc176b8e977eedb3501cf0617948c22547310.zip
kde-plasma: Add KDE Plasma 5.18.5
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.18.5.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index c7bcfb07fc55..bd43023e6c12 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.17.5.tar.xz 21372 BLAKE2B 134a533570b75d66cff195819d41b782b67e0f308d6b36efdd7ca223cfb8994baf29506e3cfc34c6786d35eedf792ed6519b40b0f39360468465c76a197c8362 SHA512 c3a6d5b914c13cdd2ca94a237168702729755ba51e036bef1fb5f09f9e7d1c01c176ba14f225c5ae3781434e8fcc047dd250f9da8d3704da09e9712819a5948a
DIST ksshaskpass-5.18.4.1.tar.xz 22228 BLAKE2B 09ef6d7135c68284a4a36ee81c55a15190c372dc77e2c332ec88383684d8ae14603a1109da800279a6f3b71602b3de65f211cfda92b0eaeadaec85422dfaf11e SHA512 42d3615b631b225a455c939a72a0a1cd1766c7baa7bf9396b4509c880f37784beddaf2596d124362d9720901bad776aaf6b248ccf8b53e0691d74c948272c952
+DIST ksshaskpass-5.18.5.tar.xz 22148 BLAKE2B 31521b28a840bfbb14cdef2484dde8908a0ffbeda5d54663243bd93a070d77d72019b5436f0a4f838e7c8b9f60992b06636e181b6ced51d17a13ba4f7c3918b6 SHA512 8cf75491c04537cdbab11613dc0f9317631c282e4f371664164dc0936d08f744a39777b696b772e05b06ef1257d42f7ae29abfbbd022e661073fdf880fe63fcf
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.18.5.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.18.5.ebuild
new file mode 100644
index 000000000000..cf1f23b87d8f
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.18.5.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.66.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://cgit.kde.org/ksshaskpass.git"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ ecm_pkg_setup
+
+ local srcfile=/etc/plasma/startup/05-ksshaskpass.sh
+ local newfile=/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh
+ if [[ -f "${EROOT}"${srcfile} ]]; then
+ local md5=$(md5sum "${EROOT}"${srcfile})
+ if [[ ${md5%% *} != 615ae8f5b0090ff7f51d0edee7885d55 ]]; then
+ elog "Existing modified "${EPREFIX}"${srcfile} detected."
+ elog "Copying to "${EPREFIX}"${newfile}..."
+ cp -v "${EROOT}"${srcfile} "${T}"/ || die
+ fi
+ fi
+}
+
+src_prepare() {
+ ecm_src_prepare
+ if [[ ! -f "${T}"/05-ksshaskpass.sh ]]; then
+ cp "${FILESDIR}"/05-ksshaskpass.sh "${T}"/ || die
+ fi
+}
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 5,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+
+ # Clean up pre-5.17.4 script
+ if [[ -e "${EROOT}"/etc/plasma/startup/05-ksshaskpass.sh ]]; then
+ rm "${EROOT}"/etc/plasma/startup/05-ksshaskpass.sh || die
+ elog "Removed obsolete ${EPREFIX}/etc/plasma/startup/05-ksshaskpass.sh"
+ fi
+}