summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-plasma/oxygen-fonts
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-plasma/oxygen-fonts')
-rw-r--r--kde-plasma/oxygen-fonts/Manifest1
-rw-r--r--kde-plasma/oxygen-fonts/metadata.xml5
-rw-r--r--kde-plasma/oxygen-fonts/oxygen-fonts-5.3.2.ebuild37
3 files changed, 43 insertions, 0 deletions
diff --git a/kde-plasma/oxygen-fonts/Manifest b/kde-plasma/oxygen-fonts/Manifest
new file mode 100644
index 000000000000..f2ff665988bb
--- /dev/null
+++ b/kde-plasma/oxygen-fonts/Manifest
@@ -0,0 +1 @@
+DIST oxygen-fonts-5.3.2.tar.xz 161704 SHA256 ca179061374a0d37f2ae445bd58b339be47dcdf11d349169d71a354ce972e874 SHA512 2a5261b9e3c608a7873155e82a6f7fb80c06859ee6a1153b45eacfbbc4bdcf25767b65a1a77b0dd82ebe729fd9a1a310e837777636d8d02f2a6f82b72710d7a0 WHIRLPOOL fb82daaedb7e597f36505de6d4ebbdf3bac51acbea9353c24fa266a138080b4f5a20977d741715625470873051a5a51ce07a0fc9485e30224ac9bfccfe30d739
diff --git a/kde-plasma/oxygen-fonts/metadata.xml b/kde-plasma/oxygen-fonts/metadata.xml
new file mode 100644
index 000000000000..a23f444b67d6
--- /dev/null
+++ b/kde-plasma/oxygen-fonts/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>
diff --git a/kde-plasma/oxygen-fonts/oxygen-fonts-5.3.2.ebuild b/kde-plasma/oxygen-fonts/oxygen-fonts-5.3.2.ebuild
new file mode 100644
index 000000000000..fd95230a7414
--- /dev/null
+++ b/kde-plasma/oxygen-fonts/oxygen-fonts-5.3.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_AUTODEPS="false"
+KDE_DEBUG="false"
+inherit kde5 font
+
+DESCRIPTION="Desktop/GUI font family for integrated use with the KDE desktop"
+HOMEPAGE="https://projects.kde.org/projects/kde/workspace/oxygen-fonts"
+
+LICENSE="OFL-1.1"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep extra-cmake-modules)
+ media-gfx/fontforge
+"
+RDEPEND="!media-fonts/oxygen-fonts"
+
+DOCS=( README.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DOXYGEN_FONT_INSTALL_DIR="${FONTDIR}"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ font_src_install
+}