summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-09-17 08:46:04 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-09-28 14:12:09 +0300
commitadffe64f47325af8ce665bbbb1493a07cd5505bc (patch)
treeb70ff6c736e833968b61c9e22aec037de0b40079 /lxde-base
parentsys-fs/zfs-auto-snapshot: remove extra postinst message (diff)
downloadgentoo-adffe64f47325af8ce665bbbb1493a07cd5505bc.tar.gz
gentoo-adffe64f47325af8ce665bbbb1493a07cd5505bc.tar.bz2
gentoo-adffe64f47325af8ce665bbbb1493a07cd5505bc.zip
lxde-base/lxterminal: port to EAPI 7, tidy up ebuild
- Adjust DEPEND -> BDEPEND - Update icon cache - Remove ${PV} == *9999* logic - Install locales unconditionally Closes: https://bugs.gentoo.org/739838 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Closes: https://github.com/gentoo/gentoo/pull/17359 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'lxde-base')
-rw-r--r--lxde-base/lxterminal/lxterminal-0.3.2-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/lxde-base/lxterminal/lxterminal-0.3.2-r1.ebuild b/lxde-base/lxterminal/lxterminal-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..be9747b86519
--- /dev/null
+++ b/lxde-base/lxterminal/lxterminal-0.3.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg
+
+DESCRIPTION="Lightweight vte-based tabbed terminal emulator for LXDE"
+HOMEPAGE="https://wiki.lxde.org/en/LXTerminal"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="gtk3"
+
+DEPEND="dev-libs/glib:2
+ !gtk3? (
+ x11-libs/gtk+:2
+ x11-libs/vte:0 )
+ gtk3? (
+ x11-libs/gtk+:3
+ x11-libs/vte:2.91 )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-man $(use_enable gtk3)
+}