summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-fonts/pothana2k
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-fonts/pothana2k')
-rw-r--r--media-fonts/pothana2k/Manifest1
-rw-r--r--media-fonts/pothana2k/files/65-pothana2k.conf31
-rw-r--r--media-fonts/pothana2k/metadata.xml6
-rw-r--r--media-fonts/pothana2k/pothana2k-2006-r1.ebuild31
4 files changed, 69 insertions, 0 deletions
diff --git a/media-fonts/pothana2k/Manifest b/media-fonts/pothana2k/Manifest
new file mode 100644
index 000000000000..d6873950af03
--- /dev/null
+++ b/media-fonts/pothana2k/Manifest
@@ -0,0 +1 @@
+DIST pothana2k-2006.zip 1068921 RMD160 e7a5d10e6cf4eb7c9d8d0bed2b2fd502ebee3210 SHA1 7b709f2f6a70e4d2dc24a2a2845c933eb6821bd0 SHA256 fe6f69cdbc4691f98213624e7cd59f52c7dda7126bdb5c6eb1c9561df26178e1
diff --git a/media-fonts/pothana2k/files/65-pothana2k.conf b/media-fonts/pothana2k/files/65-pothana2k.conf
new file mode 100644
index 000000000000..5577a3567ba8
--- /dev/null
+++ b/media-fonts/pothana2k/files/65-pothana2k.conf
@@ -0,0 +1,31 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<fontconfig>
+<!-- Telugu (te) -->
+<match target="font">
+ <test name="lang" compare="contains">
+ <string>te</string>
+ </test>
+ <alias>
+ <family>sans-serif</family>
+ <prefer>
+ <family>Pothana2000</family>
+ </prefer>
+ </alias>
+</match>
+
+<match target="font">
+ <test name="lang" compare="contains">
+ <string>te</string>
+ </test>
+ <alias>
+ <family>serif</family>
+ <prefer>
+ <family>Vemana</family>
+ </prefer>
+ </alias>
+</match>
+<!-- Telugu (te) ends -->
+
+</fontconfig>
+
diff --git a/media-fonts/pothana2k/metadata.xml b/media-fonts/pothana2k/metadata.xml
new file mode 100644
index 000000000000..356cfa4e60cd
--- /dev/null
+++ b/media-fonts/pothana2k/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>fonts</herd>
+</pkgmetadata>
+
diff --git a/media-fonts/pothana2k/pothana2k-2006-r1.ebuild b/media-fonts/pothana2k/pothana2k-2006-r1.ebuild
new file mode 100644
index 000000000000..8e45f713c0fe
--- /dev/null
+++ b/media-fonts/pothana2k/pothana2k-2006-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit font
+
+DESCRIPTION="Pothana 2000 and Vemana fonts for the Telugu script"
+HOMEPAGE="http://www.kavya-nandanam.com/"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="doc"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}"
+FONT_S="${WORKDIR}"
+FONT_SUFFIX="ttf"
+
+FONT_CONF=( "${FILESDIR}/65-pothana2k.conf" )
+
+src_install() {
+ font_src_install
+ if use doc
+ then
+ dodoc MANUAL.PDF
+ fi
+}