summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJiayi Zhao <jeff.no.zhao@gmail.com>2019-12-28 15:19:49 -0500
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-30 00:48:11 +0100
commit7b3cef697d4af630a8fbe4d31aa9858a3ae43fa6 (patch)
treed2173aef24e21403d077480062604f18e1b823a9 /media-gfx
parentdev-util/perf: fix install with python disabled (diff)
downloadgentoo-7b3cef697d4af630a8fbe4d31aa9858a3ae43fa6.tar.gz
gentoo-7b3cef697d4af630a8fbe4d31aa9858a3ae43fa6.tar.bz2
gentoo-7b3cef697d4af630a8fbe4d31aa9858a3ae43fa6.zip
media-gfx/qimgv: version bump 0.8.8
Signed-off-by: Jiayi Zhao <jeff.no.zhao@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14157 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/qimgv/Manifest1
-rw-r--r--media-gfx/qimgv/qimgv-0.8.8.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/media-gfx/qimgv/Manifest b/media-gfx/qimgv/Manifest
index d974a51f05ef..184ebbc4abed 100644
--- a/media-gfx/qimgv/Manifest
+++ b/media-gfx/qimgv/Manifest
@@ -1 +1,2 @@
DIST qimgv-0.8.5.tar.gz 242650 BLAKE2B 25ac2854b0c35e2288b0e770559bac5ac0152df1e73b025fe99609e3f7126ad0c5342a6f87dd34b0847b22031ca77db7b98b1ef8b9c278fcbebb395454d426a4 SHA512 f4c3df7db433eca04ed0827039a02fcbb6e0d5b2f696010351dc6238c39b7a08784780ad8d56f3701d13506dd6c64671ce361817928d7fb2bb25b88c3f3d32ce
+DIST qimgv-0.8.8.tar.gz 460682 BLAKE2B fb701fbb336bf8e51751f677f7fddfd7eb0e1b770697ee510c0008a3ebddb0a3948d5a3f6f57a676dfa3117ca03b908cc3f88bcaec16a07000108279bd5fed80 SHA512 376f79eba2a625eb0f622494ce7ba98e1182b43cc6d7e268382c794a74d2772bd17083ac9ae45fcafc5eeb0665ef06ab34bdbeee8401a35bd0652744c576e131
diff --git a/media-gfx/qimgv/qimgv-0.8.8.ebuild b/media-gfx/qimgv/qimgv-0.8.8.ebuild
new file mode 100644
index 000000000000..e605fa5db2f8
--- /dev/null
+++ b/media-gfx/qimgv/qimgv-0.8.8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils xdg-utils
+
+DESCRIPTION="A cross-platform image viewer with webm support, written in qt5"
+HOMEPAGE="https://github.com/easymodo/qimgv"
+SRC_URI="https://github.com/easymodo/qimgv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="exif kde video"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ exif? ( media-gfx/exiv2:= )
+ kde? ( kde-frameworks/kwindowsystem:5 )
+ video? ( media-video/mpv[libmpv] )
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ # respect make.conf CXXFLAGS
+ sed -i -e '/set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++17 -lstdc++fs -O3")/d' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DEXIV2=$(usex exif)
+ -DKDE_SUPPORT=$(usex kde)
+ -DVIDEO_SUPPORT=$(usex video)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}