summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/alure
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/alure')
-rw-r--r--media-libs/alure/Manifest1
-rw-r--r--media-libs/alure/alure-1.2.ebuild45
-rw-r--r--media-libs/alure/metadata.xml9
3 files changed, 55 insertions, 0 deletions
diff --git a/media-libs/alure/Manifest b/media-libs/alure/Manifest
new file mode 100644
index 000000000000..6c1347114794
--- /dev/null
+++ b/media-libs/alure/Manifest
@@ -0,0 +1 @@
+DIST alure-1.2.tar.bz2 65210 RMD160 d529e50542e3553a7e6999af8da59658d28fa51e SHA1 f033f0820c449ebff7b4b0254a7b1f26c0ba485b SHA256 465e6adae68927be3a023903764662d64404e40c4c152d160e3a8838b1d70f71
diff --git a/media-libs/alure/alure-1.2.ebuild b/media-libs/alure/alure-1.2.ebuild
new file mode 100644
index 000000000000..3d694ae99770
--- /dev/null
+++ b/media-libs/alure/alure-1.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit cmake-utils
+
+DESCRIPTION="The OpenAL Utility Toolkit"
+HOMEPAGE="http://kcat.strangesoft.net/alure.html"
+SRC_URI="http://kcat.strangesoft.net/alure-releases/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="dumb examples flac fluidsynth mp3 sndfile static-libs vorbis"
+
+RDEPEND=">=media-libs/openal-1.1
+ dumb? ( media-libs/dumb )
+ flac? ( media-libs/flac )
+ fluidsynth? ( >=media-sound/fluidsynth-1.1.1 )
+ mp3? ( media-sound/mpg123 )
+ sndfile? ( media-libs/libsndfile )
+ vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e "/DESTINATION/s:doc/alure:doc/${PF}:" CMakeLists.txt || die
+}
+
+src_configure() {
+ # FIXME: libmodplug/sndfile.h from libmodplug conflict with sndfile.h from libsndfile
+ local mycmakeargs=(
+ $(cmake-utils_use dumb)
+ $(cmake-utils_use_build examples)
+ $(cmake-utils_use flac)
+ $(cmake-utils_use fluidsynth)
+ -DMODPLUG=OFF
+ $(cmake-utils_use mp3 MPG123)
+ $(cmake-utils_use sndfile)
+ $(cmake-utils_use_build static-libs STATIC)
+ $(cmake-utils_use vorbis)
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/media-libs/alure/metadata.xml b/media-libs/alure/metadata.xml
new file mode 100644
index 000000000000..d2599dbf709f
--- /dev/null
+++ b/media-libs/alure/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <use>
+ <flag name="dumb">Enable <pkg>media-libs/dumb</pkg> module library support</flag>
+ <flag name="fluidsynth">Enables Fluidsynth MIDI software synthesis</flag>
+ </use>
+</pkgmetadata>