summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/exempi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/exempi')
-rw-r--r--media-libs/exempi/Manifest2
-rw-r--r--media-libs/exempi/exempi-2.2.0.ebuild50
-rw-r--r--media-libs/exempi/exempi-2.2.1.ebuild49
-rw-r--r--media-libs/exempi/files/exempi-2.1.1-iconv.patch22
-rw-r--r--media-libs/exempi/metadata.xml8
5 files changed, 131 insertions, 0 deletions
diff --git a/media-libs/exempi/Manifest b/media-libs/exempi/Manifest
new file mode 100644
index 000000000000..c4b2de4d53ef
--- /dev/null
+++ b/media-libs/exempi/Manifest
@@ -0,0 +1,2 @@
+DIST exempi-2.2.0.tar.gz 3555957 SHA256 710a01a4e879c3a58304021d8a9624cf8b65f79b2b949951a873c91f6d64d102 SHA512 bb477787204bdc2cc8e9949c8407beb5af2aeab8f3e769ce814ee7eaf7476336b68635d6301cfbd600da34b1003c371e624866ec6c3b426d06076ec90c663f82 WHIRLPOOL 4c4b9a69f24c0ea792062e27a25688cc70a58baa6853a7b2a078732e33281c5ee9d9e21488d90a86a1fe28b6f227cfeb64a7e1524a815fa7a30a955fde2e4983
+DIST exempi-2.2.1.tar.gz 3566843 SHA256 a99e1569047988200e4935cf4395667341a5bd8d6067847a08df4304546cc362 SHA512 f4b97ec7af89924755a0695464bad5081de6a5d6a6f28c06984c051d677f8771c39df12951761ecd28d6ff520ddec4e21179dcba8b58f0ef649bbdad1a53aa9c WHIRLPOOL 622d23cb519f2dda988b7d13dd26be55dd207bfe8ec2f2c0b8b568974571780b51b5284d871a310e461041f1054265efb199cf5c21fcf6eee6619cb85dc335e9
diff --git a/media-libs/exempi/exempi-2.2.0.ebuild b/media-libs/exempi/exempi-2.2.0.ebuild
new file mode 100644
index 000000000000..f038706bcfa5
--- /dev/null
+++ b/media-libs/exempi/exempi-2.2.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="Exempi is a port of the Adobe XMP SDK to work on UNIX"
+HOMEPAGE="http://libopenraw.freedesktop.org/wiki/Exempi"
+SRC_URI="http://libopenraw.freedesktop.org/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd"
+IUSE="examples static-libs"
+
+RDEPEND=">=dev-libs/expat-2
+ virtual/libiconv
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+RESTRICT="test" #295875
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.1.1-iconv.patch
+ cp /usr/share/gettext/config.rpath . || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --disable-unittest
+}
+
+src_install() {
+ default
+
+ rm -f "${ED}"usr/lib*/lib*.la
+
+ if use examples; then
+ emake -C samples/source distclean
+ rm -f samples/{,source,testfiles}/Makefile*
+ insinto /usr/share/doc/${PF}/examples
+ doins -r samples/*
+ fi
+}
diff --git a/media-libs/exempi/exempi-2.2.1.ebuild b/media-libs/exempi/exempi-2.2.1.ebuild
new file mode 100644
index 000000000000..bf8258f87538
--- /dev/null
+++ b/media-libs/exempi/exempi-2.2.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Exempi is a port of the Adobe XMP SDK to work on UNIX"
+HOMEPAGE="http://libopenraw.freedesktop.org/wiki/Exempi"
+SRC_URI="http://libopenraw.freedesktop.org/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd"
+IUSE="examples static-libs"
+
+RDEPEND=">=dev-libs/expat-2:=
+ virtual/libiconv
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+RESTRICT="test" #295875
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.1.1-iconv.patch
+ cp /usr/share/gettext/config.rpath . || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --disable-unittest
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+
+ if use examples; then
+ emake -C samples/source distclean
+ rm -f samples/{,source,testfiles}/Makefile*
+ insinto /usr/share/doc/${PF}/examples
+ doins -r samples/*
+ fi
+}
diff --git a/media-libs/exempi/files/exempi-2.1.1-iconv.patch b/media-libs/exempi/files/exempi-2.1.1-iconv.patch
new file mode 100644
index 000000000000..69c8196b6922
--- /dev/null
+++ b/media-libs/exempi/files/exempi-2.1.1-iconv.patch
@@ -0,0 +1,22 @@
+http://bugs.gentoo.org/show_bug.cgi?id=242812
+
+--- configure.ac
++++ configure.ac
+@@ -104,6 +104,8 @@
+ AC_CHECK_HEADER(zlib.h, ,
+ AC_MSG_ERROR([zlib headers missing]))
+
++AM_ICONV_LINK
++
+ dnl Blatently copied from iconv.m4 to remove the crack about libtool
+ dnl But check for constness of the iconv parameters.
+ AC_MSG_CHECKING([for iconv declaration])
+--- source/XMPFiles/Makefile.am
++++ source/XMPFiles/Makefile.am
+@@ -62,5 +62,5 @@
+
+
+ libXMPFiles_la_LIBADD = ./FileHandlers/libxmpfilehandlers.la \
+- ./FormatSupport/libformatsupport.la
++ ./FormatSupport/libformatsupport.la @LTLIBICONV@
+ #libXMPFiles_la_LDFLAGS = -version-info @LIBXMPCORE_VERSION_INFO@
diff --git a/media-libs/exempi/metadata.xml b/media-libs/exempi/metadata.xml
new file mode 100644
index 000000000000..9879e83b822e
--- /dev/null
+++ b/media-libs/exempi/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>freedesktop</herd>
+ <maintainer>
+ <email>freedesktop-bugs@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>