summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-09-16 18:17:33 -0700
committerMatt Turner <mattst88@gentoo.org>2019-09-16 18:48:07 -0700
commitb7993fe3d0d8f8267e170695ac146436cc3a2390 (patch)
tree19be279ffe26de44ad3e692832d8820dc7cd92d3 /media-libs/freeglut
parentapp-crypt/libb2: arm64 stable (bug #694366) (diff)
downloadgentoo-b7993fe3d0d8f8267e170695ac146436cc3a2390.tar.gz
gentoo-b7993fe3d0d8f8267e170695ac146436cc3a2390.tar.bz2
gentoo-b7993fe3d0d8f8267e170695ac146436cc3a2390.zip
media-libs/freeglut: Version bump to 3.2.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/freeglut')
-rw-r--r--media-libs/freeglut/Manifest1
-rw-r--r--media-libs/freeglut/freeglut-3.2.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/freeglut/Manifest b/media-libs/freeglut/Manifest
index c7cddf1667c3..1fd8ae404dec 100644
--- a/media-libs/freeglut/Manifest
+++ b/media-libs/freeglut/Manifest
@@ -1 +1,2 @@
DIST freeglut-3.0.0.tar.gz 419095 BLAKE2B 6065044fb2816ddfebd363189cdb897e00fa433d79c09f5a705b80ff730e1312158ed5db8d7a2cbfc2ddac0d0a9400300c5c245d967c33c937da11303fc316de SHA512 9c45d5b203b26a7ff92331b3e080a48e806c92fbbe7c65d9262dd18c39cd6efdad8a795a80f499a2d23df84b4909dbd7c1bab20d7dd3555d3d88782ce9dd15b0
+DIST freeglut-3.2.0.tar.gz 443147 BLAKE2B e33ad6e0aae49350a0268413791ebf0b8a416a0c590a058063038a3d4f5405c24e743218633c25a4f5393754c41531631feaac1eb1a290ff1c4cc1dc3d97d98a SHA512 78da1eaa845607ddd97a6744f3a97ff26cdb562fdf990695c8ac97a60d9d692496e4bf3672acfc522add60823c2f3bc7435e19e8041fbbb5d95851c0b641a818
diff --git a/media-libs/freeglut/freeglut-3.2.0.ebuild b/media-libs/freeglut/freeglut-3.2.0.ebuild
new file mode 100644
index 000000000000..78f9dc109c4f
--- /dev/null
+++ b/media-libs/freeglut/freeglut-3.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib
+
+DESCRIPTION="A free OpenGL utility toolkit, the open-sourced alternative to the GLUT library"
+HOMEPAGE="http://freeglut.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug static-libs"
+
+# enabling GLES support seems to cause build failures
+RDEPEND=">=virtual/glu-9.0-r1[${MULTILIB_USEDEP}]
+ >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXi-1.7.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrandr-1.4.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXxf86vm-1.1.3[${MULTILIB_USEDEP}]"
+# gles? ( media-libs/mesa[egl,gles1,gles2,${MULTILIB_USEDEP}] )
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+HTML_DOCS=( doc/. )
+
+src_configure() {
+ local mycmakeargs=(
+ "-DFREEGLUT_GLES=OFF"
+ "-DFREEGLUT_BUILD_STATIC_LIBS=$(usex static-libs ON OFF)"
+ )
+# $(cmake-utils_use gles FREEGLUT_GLES)
+ cmake-multilib_src_configure
+}