summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-06-16 03:13:27 +0300
committerMart Raudsepp <leio@gentoo.org>2018-06-16 21:26:51 +0300
commitead3282655e2748a654012bdfb03e528883e3823 (patch)
treef3225a706eaa9c731469c33113929d5ce550ce41 /media-libs/gst-plugins-ugly
parentprofiles: p.mask gst-plugins-schroedinger (diff)
downloadgentoo-ead3282655e2748a654012bdfb03e528883e3823.tar.gz
gentoo-ead3282655e2748a654012bdfb03e528883e3823.tar.bz2
gentoo-ead3282655e2748a654012bdfb03e528883e3823.zip
media-libs/gst-plugins-ugly: bump to 1.14.1
orc IUSE and dep is removed because only split package a52dec makes use of it, thus we don't need it here. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'media-libs/gst-plugins-ugly')
-rw-r--r--media-libs/gst-plugins-ugly/Manifest1
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-1.14.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-ugly/Manifest b/media-libs/gst-plugins-ugly/Manifest
index 0e92f18074c2..6bb366151f53 100644
--- a/media-libs/gst-plugins-ugly/Manifest
+++ b/media-libs/gst-plugins-ugly/Manifest
@@ -1,3 +1,4 @@
DIST gst-plugins-ugly-0.10.19.tar.xz 882452 BLAKE2B df5319481ade22d7acdee6e22ca57a444e104c8540bc4b578cfe7554c79bb4ee33b23a8516940f6504c30d9403c4ced2434e11f3a48548c3721d3d3db2016757 SHA512 16d030998142f698f8ab7dbe55c0c6c8db05ade6b3c007a3aacb5491592e8c60e0a9d62f1a840eab4d57825b1beb9017e3f68f5a90288435216586d67040deda
DIST gst-plugins-ugly-1.12.3.tar.xz 903784 BLAKE2B f0a9538f8d3c2500470a721a998d385af3611aaa003e1f0f315747f8df1680529c4c0332c5b4130eadfbcbd57d18b7fa1deb794e07cc9b0d8db22b98e27d9cee SHA512 9ca5769c325df3d2d97ba83d785fab08da5119f6d26c4ac4db72853af143477ea8fb7087464a8614b6e59f384463ac01087ee76cec2af8acd80a4dc15e392e34
DIST gst-plugins-ugly-1.12.4.tar.xz 904592 BLAKE2B 6ec59cea23ba45e705fc3140530576232c758884cc7cdcc293022233f4aeb440918c147563706a7309253dab318190bd6484fe2ac21af4b54af61ede349a1e82 SHA512 920f5be5a060293319f4c45bf7f28e14953e897473a04e1c83bce61261365198a6dc2d7ad6cf5396b2bbdc35a5f77014741e902e67c00c3c6596680ab9924e8a
+DIST gst-plugins-ugly-1.14.1.tar.xz 884668 BLAKE2B 8e1cef0ebabac65ad2b1d6ac3fdc04fbb3ae0da0b9f4c0d18f03533ae12dda03d04763bbeab079aebe3637df664dc2e94adc36008cacfb6c00b9ac8b4a228241 SHA512 0eaa9435e93596cb2c2ed1d3540dd3c4f4de1dd18da8359ca5918b0fbdccda9d5b8f33e5aeb54186ed9d70518712aca92e8ffe7884fc13a3ca3174552c10a688
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.14.1.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.14.1.ebuild
new file mode 100644
index 000000000000..852081d080d9
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.14.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE="gst-plugins-ugly"
+
+inherit eutils gstreamer
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+multilib_src_configure() {
+ gstreamer_multilib_src_configure
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/plugins/html docs/plugins/html || die
+ fi
+
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+}