summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2022-08-26 13:54:02 +0100
committerSam James <sam@gentoo.org>2022-08-26 14:09:38 +0100
commit730b8eb47b1743544e210f63c995866f23ac911b (patch)
tree1d28c05d211abb076e5c0e7ea467a950b8853c68 /media-libs/gstreamer-editing-services
parentmedia-libs/gstreamer: add 1.20.3 (diff)
downloadgentoo-730b8eb47b1743544e210f63c995866f23ac911b.tar.gz
gentoo-730b8eb47b1743544e210f63c995866f23ac911b.tar.bz2
gentoo-730b8eb47b1743544e210f63c995866f23ac911b.zip
media-libs/gstreamer-editing-services: add 1.20.3
Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com>
Diffstat (limited to 'media-libs/gstreamer-editing-services')
-rw-r--r--media-libs/gstreamer-editing-services/Manifest1
-rw-r--r--media-libs/gstreamer-editing-services/gstreamer-editing-services-1.20.3.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/media-libs/gstreamer-editing-services/Manifest b/media-libs/gstreamer-editing-services/Manifest
index 7b204a6f864e..5147a1319051 100644
--- a/media-libs/gstreamer-editing-services/Manifest
+++ b/media-libs/gstreamer-editing-services/Manifest
@@ -1,2 +1,3 @@
DIST gst-editing-services-1.20.2.tar.xz 977092 BLAKE2B f64a922006ac4d8dde429a718a7e41360c83af1a6854baf68fbd2372ac3aa852f47cc986ae58fe6564044dee00484aaa36d66cd4d3f5ffe34153446b38c7d476 SHA512 a9f9dd196d838fab8727de6fd0c52fde6a1b56ba801b7b608e0f2d30abc38bf586f02c20bedcb1ba384089cf97e8d0db1719ed1c9e8c18c7e56ff732bb8e5de5
+DIST gst-editing-services-1.20.3.tar.xz 979284 BLAKE2B 3d512a7bc17273dcb55c3a0dd18326fd8069c6eab9fe8c91e79b10b69000ab21ed3c7cffa0c480d2a047637cd84d5a6f08fea3c264ff5cab16a70c133a6c6223 SHA512 380cea0abda043a5aaee11981c85a03e59f4a5ac9221342c09d1875477dc327210ad0705e537538a981bef4de99b1aa7ac92fb37c77fc60b44219d673f97f56f
DIST gstreamer-editing-services-1.16.3.tar.xz 1091208 BLAKE2B d88bed4e8958a6bad05aab8d6c19cd737c6812e0780c420fd144d58fe416cd5dbd01e019c3fc53417d65cb2d6e100de123dc8183c8c3dab329fd677ba55644c5 SHA512 c84cc2dab2b1644ab118794b7aeb98748f893a26070359850f48e87cf362fd53b54baf8754a07e1d412cacb85cf9cfcafb3cf10d79c67bbe077e4d763f9703ef
diff --git a/media-libs/gstreamer-editing-services/gstreamer-editing-services-1.20.3.ebuild b/media-libs/gstreamer-editing-services/gstreamer-editing-services-1.20.3.ebuild
new file mode 100644
index 000000000000..7caf66f5d784
--- /dev/null
+++ b/media-libs/gstreamer-editing-services/gstreamer-editing-services-1.20.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit meson python-r1
+
+DESCRIPTION="SDK for making video editors and more"
+HOMEPAGE="http://wiki.pitivi.org/wiki/GES"
+SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P/gstreamer/gst}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+introspection test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.40.0:2
+ dev-libs/libxml2:2
+ >=media-libs/gstreamer-${PV}:1.0[introspection?]
+ >=media-libs/gst-plugins-base-${PV}:1.0[introspection?]
+ >=media-libs/gst-plugins-bad-${PV}:1.0[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+# Some tests are failing
+RESTRICT="test"
+
+S="${WORKDIR}"/${P/gstreamer/gst}
+
+src_configure() {
+ local emesonargs=(
+ -Ddoc=disabled # hotdoc not packaged
+ $(meson_feature introspection)
+ $(meson_feature test tests)
+ -Dbash-completion=disabled
+ -Dxptv=disabled
+ -Dpython=enabled
+ -Dvalidate=disabled
+ -Dexamples=disabled
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_moduleinto gi.overrides
+ python_foreach_impl python_domodule bindings/python/gi/overrides/GES.py
+}