summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrahmajit das <listout@protonmail.com>2022-11-02 11:16:36 +0530
committerMart Raudsepp <leio@gentoo.org>2022-11-20 18:12:28 +0000
commit99857f45011b1da80a5fc0ec73050dec67c65d35 (patch)
treeb65eb27a4f21bd0d77606696f383ff49c467bd9b /media-libs/gstreamer-editing-services
parentpackage.mask: Stop last rite of media-libs/libvisual for now (diff)
downloadgentoo-99857f45011b1da80a5fc0ec73050dec67c65d35.tar.gz
gentoo-99857f45011b1da80a5fc0ec73050dec67c65d35.tar.bz2
gentoo-99857f45011b1da80a5fc0ec73050dec67c65d35.zip
media-libs/gstreamer: Version bump to 1.20.4
Closes: https://bugs.gentoo.org/877325 Signed-off-by: brahmajit das <listout@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/28086 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-libs/gstreamer-editing-services')
-rw-r--r--media-libs/gstreamer-editing-services/Manifest1
-rw-r--r--media-libs/gstreamer-editing-services/gstreamer-editing-services-1.20.4.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/media-libs/gstreamer-editing-services/Manifest b/media-libs/gstreamer-editing-services/Manifest
index 4a0d7f0f7508..d04b4415c0bd 100644
--- a/media-libs/gstreamer-editing-services/Manifest
+++ b/media-libs/gstreamer-editing-services/Manifest
@@ -1 +1,2 @@
DIST gst-editing-services-1.20.3.tar.xz 979284 BLAKE2B 3d512a7bc17273dcb55c3a0dd18326fd8069c6eab9fe8c91e79b10b69000ab21ed3c7cffa0c480d2a047637cd84d5a6f08fea3c264ff5cab16a70c133a6c6223 SHA512 380cea0abda043a5aaee11981c85a03e59f4a5ac9221342c09d1875477dc327210ad0705e537538a981bef4de99b1aa7ac92fb37c77fc60b44219d673f97f56f
+DIST gst-editing-services-1.20.4.tar.xz 982400 BLAKE2B 00ce8918be05dd2a417eaa61ff7994b8ec169149e46fc90062a816bdf3680a6946cf04aed4867b00869fea3e533169335fbf247d0a061e6a214e0c6b7a2e47cb SHA512 6322f5da61a9004480392169a40790fb0e4b50350e960d5d6383dd431f58fe8452b9ab163cbf7307fe12fbdc5a6276f670af4ad02528799e689b490880f10a8c
diff --git a/media-libs/gstreamer-editing-services/gstreamer-editing-services-1.20.4.ebuild b/media-libs/gstreamer-editing-services/gstreamer-editing-services-1.20.4.ebuild
new file mode 100644
index 000000000000..e8379f98b1d8
--- /dev/null
+++ b/media-libs/gstreamer-editing-services/gstreamer-editing-services-1.20.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit meson python-r1
+
+DESCRIPTION="SDK for making video editors and more"
+HOMEPAGE="http://wiki.pitivi.org/wiki/GES"
+SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P/gstreamer/gst}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+introspection test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.40.0:2
+ dev-libs/libxml2:2
+ >=media-libs/gstreamer-${PV}:1.0[introspection?]
+ >=media-libs/gst-plugins-base-${PV}:1.0[introspection?]
+ >=media-libs/gst-plugins-bad-${PV}:1.0[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+# Some tests are failing
+RESTRICT="test"
+
+S="${WORKDIR}"/${P/gstreamer/gst}
+
+src_configure() {
+ local emesonargs=(
+ -Ddoc=disabled # hotdoc not packaged
+ $(meson_feature introspection)
+ $(meson_feature test tests)
+ -Dbash-completion=disabled
+ -Dxptv=disabled
+ -Dpython=enabled
+ -Dvalidate=disabled
+ -Dexamples=disabled
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_moduleinto gi.overrides
+ python_foreach_impl python_domodule bindings/python/gi/overrides/GES.py
+}