summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/lib3ds
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/lib3ds')
-rw-r--r--media-libs/lib3ds/Manifest2
-rw-r--r--media-libs/lib3ds/files/lib3ds-1.3.0-r1-mesh.c.patch17
-rw-r--r--media-libs/lib3ds/files/lib3ds-1.3.0-r1-pkgconfig.patch94
-rw-r--r--media-libs/lib3ds/files/lib3ds-2.0.0_rc1-underlinking-no-autoreconf.patch45
-rw-r--r--media-libs/lib3ds/files/lib3ds-2.0.0_rc1-underlinking.patch56
-rw-r--r--media-libs/lib3ds/lib3ds-1.3.0-r1.ebuild25
-rw-r--r--media-libs/lib3ds/lib3ds-2.0.0_rc1.ebuild30
-rw-r--r--media-libs/lib3ds/metadata.xml12
8 files changed, 281 insertions, 0 deletions
diff --git a/media-libs/lib3ds/Manifest b/media-libs/lib3ds/Manifest
new file mode 100644
index 000000000000..18a4c259d5e2
--- /dev/null
+++ b/media-libs/lib3ds/Manifest
@@ -0,0 +1,2 @@
+DIST lib3ds-1.3.0.zip 443675 SHA256 f5b00c302955a67fa5fb1f2d3f2583767cdc61fdbc6fd843c0c7c9d95c5629e3 SHA512 7c866ea9721a7a124c25b4962e933a7066ec2e3c7998e5ae2ba93727f19b91bdb103699bada6d1e04b67e0a54b9f58d09382093569114a1846d86bb03821b8ac WHIRLPOOL 33adf50f5afff3563dabd48844cb0ea0631a4c2ce047fc7998139b15293f7de68646465ce0956918e1e3d04ece5efdd575d172c5d4183a73bb816d3d262c3682
+DIST lib3ds-20080909.zip 427233 SHA256 5d4df5f86a17a1aba58e9f54fe6a43c825bab15d8439ac9416c3f0c30fd1cca2 SHA512 ba7166dbd9fb97edc0f5cf0df56747b7e3c5aa1e62334ca995020a6ccd77284abc58e3fba80ec96ecf3765f5ce3121612c9f8c7dfedb2322f1cd2af85d567f87 WHIRLPOOL fd9c19a3fe6341cbf970d2c75352cb317c8073b23e94b792c4e905aa0a79e7c31d7ca1dd35dbef11f891052438c9216faee8245470423d5d8e206ea4981a9aa5
diff --git a/media-libs/lib3ds/files/lib3ds-1.3.0-r1-mesh.c.patch b/media-libs/lib3ds/files/lib3ds-1.3.0-r1-mesh.c.patch
new file mode 100644
index 000000000000..1455660596bf
--- /dev/null
+++ b/media-libs/lib3ds/files/lib3ds-1.3.0-r1-mesh.c.patch
@@ -0,0 +1,17 @@
+diff -Naur lib3ds-1.3.0.orig/lib3ds/mesh.c lib3ds-1.3.0/lib3ds/mesh.c
+--- lib3ds-1.3.0.orig/lib3ds/mesh.c 2007-06-20 19:04:08.000000000 +0200
++++ lib3ds-1.3.0/lib3ds/mesh.c 2010-09-14 06:34:39.987807911 +0200
+@@ -87,8 +87,11 @@
+ faces=lib3ds_io_read_word(io);
+ for (i=0; i<faces; ++i) {
+ index=lib3ds_io_read_word(io);
+- ASSERT(index<mesh->faces);
+- strcpy(mesh->faceL[index].material, name);
++ if (index<mesh->faces) {
++ strncpy(mesh->faceL[index].material, name, 64);
++ } else {
++ // TODO warning
++ }
+ }
+ }
+ break;
diff --git a/media-libs/lib3ds/files/lib3ds-1.3.0-r1-pkgconfig.patch b/media-libs/lib3ds/files/lib3ds-1.3.0-r1-pkgconfig.patch
new file mode 100644
index 000000000000..41f658e5311b
--- /dev/null
+++ b/media-libs/lib3ds/files/lib3ds-1.3.0-r1-pkgconfig.patch
@@ -0,0 +1,94 @@
+diff -uNr lib3ds-1.2.0.orig/lib3ds-config.in lib3ds-1.2.0/lib3ds-config.in
+--- lib3ds-1.2.0.orig/lib3ds-config.in 2000-05-23 14:13:08.000000000 +0200
++++ lib3ds-1.2.0/lib3ds-config.in 2007-10-21 06:37:48.000000000 +0200
+@@ -1,9 +1,5 @@
+ #!/bin/sh
+
+-prefix=@prefix@
+-exec_prefix=@exec_prefix@
+-exec_prefix_set=no
+-
+ usage()
+ {
+ cat <<EOF
+@@ -22,6 +18,8 @@
+ usage 1 1>&2
+ fi
+
++PKG_CONFIG_ARGS=
++
+ while test $# -gt 0; do
+ case "$1" in
+ -*=*) optarg=`echo "$1" | sed 's/[-_a-zA-Z0-9]*=//'` ;;
+@@ -30,23 +28,23 @@
+
+ case $1 in
+ --prefix=*)
+- prefix=$optarg
++ PKG_CONFIG_ARGS="$PKG_CONFIG_ARGS --define-variable=prefix=$optarg"
+ if test $exec_prefix_set = no ; then
+- exec_prefix=$optarg
++ PKG_CONFIG_ARGS="$PKG_CONFIG_ARGS --define-variable=exec_prefix=$optarg"
+ fi
+ ;;
+ --prefix)
+ echo_prefix=yes
+ ;;
+ --exec-prefix=*)
+- exec_prefix=$optarg
++ PKG_CONFIG_ARGS="$PKG_CONFIG_ARGS --define-variable=exec_prefix=$optarg"
+ exec_prefix_set=yes
+ ;;
+ --exec-prefix)
+ echo_exec_prefix=yes
+ ;;
+ --version)
+- echo @LIB3DS_VERSION@
++ pkg-config --modversion lib3ds
+ ;;
+ --cflags)
+ echo_cflags=yes
+@@ -62,23 +60,18 @@
+ done
+
+ if test "$echo_prefix" = "yes"; then
+- echo $prefix
++ pkg-config $PKG_CONFIG_ARGS --variable=prefix lib3ds
+ fi
+
+ if test "$echo_exec_prefix" = "yes"; then
+- echo $exec_prefix
++ pkg-config $PKG_CONFIG_ARGS --variable=exec_prefix lib3ds
+ fi
+
+ if test "$echo_cflags" = "yes"; then
+- if test @includedir@ != /usr/include ; then
+- echo -I@includedir@
+- fi
++ pkg-config $PKG_CONFIG_ARGS --cflags lib3ds
+ fi
+
+ if test "$echo_libs" = "yes"; then
+- if test @libdir@ != /usr/lib ; then
+- my_linker_flags="-L@libdir@"
+- fi
+- echo ${my_linker_flags} -l3ds
+-fi
++ pkg-config $PKG_CONFIG_ARGS --libs lib3ds
++fi
+
+diff -uNr lib3ds-1.2.0.orig/lib3ds.pc.in lib3ds-1.2.0/lib3ds.pc.in
+--- lib3ds-1.2.0.orig/lib3ds.pc.in 1970-01-01 01:00:00.000000000 +0100
++++ lib3ds-1.2.0/lib3ds.pc.in 2007-10-21 06:23:53.000000000 +0200
+@@ -0,0 +1,11 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: lib3ds
++Description: lib3ds
++Version: @VERSION@
++Requires:
++Libs: -L${libdir} -l3ds -lm
++Cflags: -I${includedir}
diff --git a/media-libs/lib3ds/files/lib3ds-2.0.0_rc1-underlinking-no-autoreconf.patch b/media-libs/lib3ds/files/lib3ds-2.0.0_rc1-underlinking-no-autoreconf.patch
new file mode 100644
index 000000000000..af9040883c10
--- /dev/null
+++ b/media-libs/lib3ds/files/lib3ds-2.0.0_rc1-underlinking-no-autoreconf.patch
@@ -0,0 +1,45 @@
+commit 562d1412a705b6667bc9fa594133366fb7e787ab
+Author: hasufell <hasufell@gentoo.org>
+Date: Thu Sep 26 20:49:44 2013 +0200
+
+ avoid autoreconf
+
+diff --git a/examples/3ds2obj/Makefile.in b/examples/3ds2obj/Makefile.in
+index 1b5b1fe..d2fda8a 100644
+--- a/examples/3ds2obj/Makefile.in
++++ b/examples/3ds2obj/Makefile.in
+@@ -180,7 +180,7 @@ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ INCLUDES = -I$(top_srcdir)/src
+ 3ds2obj_SOURCES = 3ds2obj.c
+-LDADD = $(top_builddir)/src/lib3ds.la
++LDADD = $(top_builddir)/src/lib3ds.la -lm
+ EXTRA_DIST = 3ds2obj.vcproj
+ all: all-am
+
+diff --git a/examples/3dsdump/Makefile.in b/examples/3dsdump/Makefile.in
+index 4c915cc..f9f7bba 100644
+--- a/examples/3dsdump/Makefile.in
++++ b/examples/3dsdump/Makefile.in
+@@ -180,7 +180,7 @@ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ INCLUDES = -I$(top_srcdir)/src
+ 3dsdump_SOURCES = 3dsdump.c
+-LDADD = $(top_builddir)/src/lib3ds.la
++LDADD = $(top_builddir)/src/lib3ds.la -lm
+ EXTRA_DIST = 3dsdump.vcproj
+ all: all-am
+
+diff --git a/examples/cube/Makefile.in b/examples/cube/Makefile.in
+index 76b7946..1c4b5b6 100644
+--- a/examples/cube/Makefile.in
++++ b/examples/cube/Makefile.in
+@@ -180,7 +180,7 @@ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ INCLUDES = -I$(top_srcdir)/src
+ cube_SOURCES = cube.c
+-LDADD = $(top_builddir)/src/lib3ds.la
++LDADD = $(top_builddir)/src/lib3ds.la -lm
+ EXTRA_DIST = cube.vcproj cube.tga
+ all: all-am
+
diff --git a/media-libs/lib3ds/files/lib3ds-2.0.0_rc1-underlinking.patch b/media-libs/lib3ds/files/lib3ds-2.0.0_rc1-underlinking.patch
new file mode 100644
index 000000000000..b9001af2993a
--- /dev/null
+++ b/media-libs/lib3ds/files/lib3ds-2.0.0_rc1-underlinking.patch
@@ -0,0 +1,56 @@
+commit 158cf6f8deaac69eba0c5941f809469cc3eefb43
+Author: hasufell <hasufell@gentoo.org>
+Date: Thu Sep 26 20:49:01 2013 +0200
+
+ fix underlinking
+
+diff --git a/configure.in b/configure.in
+index 7bf17c2..fa5bd3f 100644
+--- a/configure.in
++++ b/configure.in
+@@ -16,6 +16,8 @@ AM_INIT_AUTOMAKE(lib3ds, $LIB3DS_VERSION)
+ AC_PROG_CC
+ AC_PROG_LIBTOOL
+
++AC_CHECK_LIBM
++
+ AC_OUTPUT([ \
+ lib3ds-config \
+ Makefile \
+diff --git a/examples/3ds2obj/Makefile.am b/examples/3ds2obj/Makefile.am
+index 8213225..4214675 100644
+--- a/examples/3ds2obj/Makefile.am
++++ b/examples/3ds2obj/Makefile.am
+@@ -3,6 +3,6 @@ INCLUDES = -I$(top_srcdir)/src
+ bin_PROGRAMS = 3ds2obj
+ 3ds2obj_SOURCES = 3ds2obj.c
+
+-LDADD = $(top_builddir)/src/lib3ds.la
++LDADD = $(top_builddir)/src/lib3ds.la $(LIBM)
+
+ EXTRA_DIST = 3ds2obj.vcproj
+diff --git a/examples/3dsdump/Makefile.am b/examples/3dsdump/Makefile.am
+index 98ec5d1..ef19b04 100644
+--- a/examples/3dsdump/Makefile.am
++++ b/examples/3dsdump/Makefile.am
+@@ -3,6 +3,6 @@ INCLUDES = -I$(top_srcdir)/src
+ bin_PROGRAMS = 3dsdump
+ 3dsdump_SOURCES = 3dsdump.c
+
+-LDADD = $(top_builddir)/src/lib3ds.la
++LDADD = $(top_builddir)/src/lib3ds.la $(LIBM)
+
+ EXTRA_DIST = 3dsdump.vcproj
+diff --git a/examples/cube/Makefile.am b/examples/cube/Makefile.am
+index c79c0ee..539813d 100644
+--- a/examples/cube/Makefile.am
++++ b/examples/cube/Makefile.am
+@@ -3,7 +3,7 @@ INCLUDES = -I$(top_srcdir)/src
+ bin_PROGRAMS = cube
+ cube_SOURCES = cube.c
+
+-LDADD = $(top_builddir)/src/lib3ds.la
++LDADD = $(top_builddir)/src/lib3ds.la $(LIBM)
+
+ EXTRA_DIST = cube.vcproj cube.tga
+
diff --git a/media-libs/lib3ds/lib3ds-1.3.0-r1.ebuild b/media-libs/lib3ds/lib3ds-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..6ac25a9c1095
--- /dev/null
+++ b/media-libs/lib3ds/lib3ds-1.3.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools-utils
+
+DESCRIPTION="library for managing 3D-Studio Release 3 and 4 .3DS files"
+HOMEPAGE="https://code.google.com/p/lib3ds/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="static-libs"
+
+RDEPEND="media-libs/freeglut
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+PATCHES=(
+ "${FILESDIR}/lib3ds-1.3.0-r1-pkgconfig.patch"
+ "${FILESDIR}/lib3ds-1.3.0-r1-mesh.c.patch"
+)
diff --git a/media-libs/lib3ds/lib3ds-2.0.0_rc1.ebuild b/media-libs/lib3ds/lib3ds-2.0.0_rc1.ebuild
new file mode 100644
index 000000000000..a6a6ecf0ea20
--- /dev/null
+++ b/media-libs/lib3ds/lib3ds-2.0.0_rc1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+MY_PV="20080909"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="library for managing 3D-Studio Release 3 and 4 .3DS files"
+HOMEPAGE="http://code.google.com/p/lib3ds/"
+SRC_URI="http://lib3ds.googlecode.com/files/${MY_P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+RDEPEND="media-libs/freeglut
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_prepare() {
+# epatch "${FILESDIR}"/${P}-underlinking.patch
+ epatch "${FILESDIR}"/${P}-underlinking-no-autoreconf.patch
+}
diff --git a/media-libs/lib3ds/metadata.xml b/media-libs/lib3ds/metadata.xml
new file mode 100644
index 000000000000..6dd50faab98c
--- /dev/null
+++ b/media-libs/lib3ds/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<herd>3dprint</herd>
+<maintainer>
+ <email>amynka@gentoo.org</email>
+</maintainer>
+<longdescription>
+lib3ds is an overall software library for managing 3D-Studio Release 3 and 4 ".3DS" files.
+</longdescription>
+</pkgmetadata>