summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libde265
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libde265')
-rw-r--r--media-libs/libde265/Manifest1
-rw-r--r--media-libs/libde265/libde265-0.9.ebuild43
-rw-r--r--media-libs/libde265/libde265-9999.ebuild43
-rw-r--r--media-libs/libde265/metadata.xml20
4 files changed, 107 insertions, 0 deletions
diff --git a/media-libs/libde265/Manifest b/media-libs/libde265/Manifest
new file mode 100644
index 000000000000..5872f638c205
--- /dev/null
+++ b/media-libs/libde265/Manifest
@@ -0,0 +1 @@
+DIST libde265-0.9.tar.gz 258887 SHA256 226856358b1cb7aa54d3f3e1bc9bb9f062b867c6de58ab1ee94cfcb8a111cda2 SHA512 1e519cea8447bffd14dd1b78d9ab07f3e558e5f3731e26a3d5c3bd8c4a67e05c1ab228f1f82d671d64442ca78e6ead9305edd19bb17fa62c27253616ff6a84d2 WHIRLPOOL 0c0ee2cc844c2551ae1effa1305d6413a5a4a81406f1957f4d48fe74d9e1c912e424106d4c3290100b15c2d8277833cc07931fb30c4e14e827e86e785ff7f3d3
diff --git a/media-libs/libde265/libde265-0.9.ebuild b/media-libs/libde265/libde265-0.9.ebuild
new file mode 100644
index 000000000000..d42d386340ad
--- /dev/null
+++ b/media-libs/libde265/libde265-0.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-multilib
+
+DESCRIPTION="Open h.265 video codec implementation"
+HOMEPAGE="https://github.com/strukturag/libde265"
+SRC_URI="https://github.com/strukturag/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug qt4 qt5 static-libs cpu_flags_x86_sse tools"
+
+DEPEND="
+ qt4? ( dev-qt/qtgui:4 dev-qt/qtcore:4 )
+ qt5? ( dev-qt/qtgui:5 dev-qt/qtcore:5 dev-qt/qtwidgets:5 )
+ media-libs/libsdl
+ virtual/ffmpeg
+"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="tools? ( || ( qt4 qt5 ) )"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable cpu_flags_x86_sse sse)
+ $(use_enable static-libs static)
+ $(use_enable debug log-info)
+ $(use_enable debug log-debug)
+ $(use_enable debug log-trace)
+ $(use_enable tools dec265)
+ $(use_enable tools sherlock265)
+ --disable-silent-rules
+ --enable-log-error
+ )
+ autotools-multilib_src_configure "${myeconfargs[@]}"
+}
diff --git a/media-libs/libde265/libde265-9999.ebuild b/media-libs/libde265/libde265-9999.ebuild
new file mode 100644
index 000000000000..74f8da72d15a
--- /dev/null
+++ b/media-libs/libde265/libde265-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+inherit git-r3 autotools-multilib
+
+DESCRIPTION="Open h.265 video codec implementation"
+HOMEPAGE="https://github.com/strukturag/libde265"
+EGIT_REPO_URI="git://github.com/strukturag/libde265.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug qt4 qt5 static-libs cpu_flags_x86_sse tools"
+
+DEPEND="
+ qt4? ( dev-qt/qtgui:4 dev-qt/qtcore:4 )
+ qt5? ( dev-qt/qtgui:5 dev-qt/qtcore:5 dev-qt/qtwidgets:5 )
+ media-libs/libsdl
+ virtual/ffmpeg
+"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="tools? ( || ( qt4 qt5 ) )"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable cpu_flags_x86_sse sse)
+ $(use_enable static-libs static)
+ $(use_enable debug log-info)
+ $(use_enable debug log-debug)
+ $(use_enable debug log-trace)
+ $(use_enable tools dec265)
+ $(use_enable tools sherlock265)
+ --disable-silent-rules
+ --enable-log-error
+ )
+ autotools-multilib_src_configure "${myeconfargs[@]}"
+}
diff --git a/media-libs/libde265/metadata.xml b/media-libs/libde265/metadata.xml
new file mode 100644
index 000000000000..dba98e6d2a82
--- /dev/null
+++ b/media-libs/libde265/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ </maintainer>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <use>
+ <flag name="tools">Install addtional tools, require USE=qt4 or qt5</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">strukturag/libde265</remote-id>
+ </upstream>
+</pkgmetadata>