summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2017-12-09 13:51:58 -0500
committerCraig Andrews <candrews@gentoo.org>2017-12-16 00:40:09 -0500
commit13f83e359897d22599bc21bf0959a7a67ed0adbe (patch)
treed1ca4266b3e1590ca7f34360aeda1d580fba7fb0 /media-libs/libdvbpsi
parentsys-apps/systemd: 236 version bump (diff)
downloadgentoo-13f83e359897d22599bc21bf0959a7a67ed0adbe.tar.gz
gentoo-13f83e359897d22599bc21bf0959a7a67ed0adbe.tar.bz2
gentoo-13f83e359897d22599bc21bf0959a7a67ed0adbe.zip
media-libs/libdvbpsi: 1.3.1 version bump
Use EAPI=6 Closes: https://bugs.gentoo.org/640412 Package-Manager: Portage-2.3.17, Repoman-2.3.6
Diffstat (limited to 'media-libs/libdvbpsi')
-rw-r--r--media-libs/libdvbpsi/Manifest1
-rw-r--r--media-libs/libdvbpsi/libdvbpsi-1.3.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/media-libs/libdvbpsi/Manifest b/media-libs/libdvbpsi/Manifest
index ca5e549b5e07..e169df3fef60 100644
--- a/media-libs/libdvbpsi/Manifest
+++ b/media-libs/libdvbpsi/Manifest
@@ -4,3 +4,4 @@ DIST libdvbpsi-1.1.0.tar.bz2 443464 BLAKE2B cdfe5dcaf3ab326e2014248a75c5e04cf6a4
DIST libdvbpsi-1.1.2.tar.bz2 450573 BLAKE2B 118a8bad293c9186086cfeccfef444ff14c7d9625ba351e2f12f2b7e40991792f03dd6db2190f279ffbc561bc6f32bf9c5a382323065b450b5cf70895c497772 SHA512 9102157467b5b1d1cc42574ce0b6e250974a138ad402eff6707fed1656aeefc19ccff8b041cfef8dd10d8ca3914e83272c0683aa8e7cb59970e619db65eb6167
DIST libdvbpsi-1.2.0.tar.bz2 461372 BLAKE2B 1094c988d7db32736dc6b77d920432b642db11824c3e60622277057dc5ddbb70c1574f8e91a42a5fdc88fd59d36218e67482e3820afaa46994827abf778e07fa SHA512 951db13f5645d4d6a160719fc6ac97fd31a32d5d17cb8e26db94702e65b6fac3d4e7a99c3c417e09fe5ce33f3b0c0ef86206c77b36816dcd8a3bd5b0bb4a9684
DIST libdvbpsi-1.3.0.tar.bz2 459083 BLAKE2B 50e8e1780ddaf9a07bd8121d1e179464a6105eaad3d0aa162f9b217863cfc63168a84f60be9de071cf5ee8389a671fcd1375629d452ed77727bb3eaed19a7b19 SHA512 59f097a1032e8cf461210128c7468da4204f077a61f68f2be3310e60004774157335cd7cba82271fcc89b7b6b17a12a06b6214357227ec9976281d9b50565c54
+DIST libdvbpsi-1.3.1.tar.bz2 479964 BLAKE2B a29522d39544d90b34915e2ca9fc9ca455a556097c63639d7604679275b57378822adfb4c022478884c897cdde2c0e5f84355fdecf35fd6bb305d1fc275eed8b SHA512 015d586d1ef1fd35fc4b6a5b79d1ce4570e07070840d7070938c38be64853fb987172ad225f000156166559709061de6f901237bfc0f7f26f219b5950b57c27a
diff --git a/media-libs/libdvbpsi/libdvbpsi-1.3.1.ebuild b/media-libs/libdvbpsi/libdvbpsi-1.3.1.ebuild
new file mode 100644
index 000000000000..ee86fd889ddd
--- /dev/null
+++ b/media-libs/libdvbpsi/libdvbpsi-1.3.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="library for MPEG TS/DVB PSI tables decoding and generation"
+HOMEPAGE="https://www.videolan.org/libdvbpsi"
+SRC_URI="https://download.videolan.org/pub/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+# Sublot == libdvbpsi.so major
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc static-libs"
+
+RDEPEND=""
+DEPEND="
+ doc? (
+ app-doc/doxygen
+ >=media-gfx/graphviz-2.26
+ )"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ sed -e '/CFLAGS/s:-O2::' -e '/CFLAGS/s:-O6::' -e '/CFLAGS/s:-Werror::' -i configure || die
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --enable-release
+}
+
+src_compile() {
+ default
+ use doc && emake doc
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/doxygen/html/. )
+ default
+ find "${D}" -name '*.la' -delete || die
+}