summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-01-07 13:08:43 +0200
committerDavid Seifert <soap@gentoo.org>2017-01-07 14:06:11 +0200
commit480cd80a39b11c69d1adf903e33b76567b10828e (patch)
treed70a9693a08094dfc916a3e54ed57002949013f7 /media-libs/libsidplay/libsidplay-1.36.59-r2.ebuild
parentmedia-libs/kodi-platform: version bump 17.1.0.1, add live 9999 ebuild (diff)
downloadgentoo-480cd80a39b11c69d1adf903e33b76567b10828e.tar.gz
gentoo-480cd80a39b11c69d1adf903e33b76567b10828e.tar.bz2
gentoo-480cd80a39b11c69d1adf903e33b76567b10828e.zip
media-libs/libsidplay: Fix building with GCC 6
Gentoo-bug: 594326 * EAPI=6 * -Wnarrowing patch by Debian * Make GCC 4.3 patch -p1 compliant Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-libs/libsidplay/libsidplay-1.36.59-r2.ebuild')
-rw-r--r--media-libs/libsidplay/libsidplay-1.36.59-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/libsidplay/libsidplay-1.36.59-r2.ebuild b/media-libs/libsidplay/libsidplay-1.36.59-r2.ebuild
new file mode 100644
index 000000000000..b9f175a73b3f
--- /dev/null
+++ b/media-libs/libsidplay/libsidplay-1.36.59-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit libtool multilib-minimal
+
+DESCRIPTION="C64 SID player library"
+HOMEPAGE="http://critical.ch/distfiles/"
+SRC_URI="http://critical.ch/distfiles/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="static-libs"
+DEPEND=""
+RDEPEND=""
+
+DOCS=( AUTHORS DEVELOPER )
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-fix-c++14.patch
+)
+
+src_prepare() {
+ default
+ elibtoolize # required for fbsd .so versioning
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+}