summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-12 22:05:57 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-12 22:27:32 +0200
commit2625db1102136ed3bacd079e2e3178a08a1513b4 (patch)
tree29b4dfbce8fced66548558151ca8c18765aab165 /media-libs/libvisio
parentkde-apps/kdepim-addons: Drop unused DEPEND (diff)
downloadgentoo-2625db1102136ed3bacd079e2e3178a08a1513b4.tar.gz
gentoo-2625db1102136ed3bacd079e2e3178a08a1513b4.tar.bz2
gentoo-2625db1102136ed3bacd079e2e3178a08a1513b4.zip
media-libs/libvisio: EAPI-7 bump
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/libvisio')
-rw-r--r--media-libs/libvisio/libvisio-9999.ebuild36
1 files changed, 21 insertions, 15 deletions
diff --git a/media-libs/libvisio/libvisio-9999.ebuild b/media-libs/libvisio/libvisio-9999.ebuild
index 1f7cc355b43d..e4147a14c125 100644
--- a/media-libs/libvisio/libvisio-9999.ebuild
+++ b/media-libs/libvisio/libvisio-9999.ebuild
@@ -1,35 +1,39 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libvisio.git"
-[[ ${PV} == 9999 ]] && inherit autotools git-r3
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libvisio.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev-www.libreoffice.org/src/libvisio/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
-DESCRIPTION="Library parsing the visio documents"
+DESCRIPTION="Library parsing the file format of MS Visio documents"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libvisio"
-[[ ${PV} == 9999 ]] || SRC_URI="https://dev-www.libreoffice.org/src/libvisio/${P}.tar.xz"
LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
IUSE="doc static-libs test tools"
+BDEPEND="
+ dev-lang/perl
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
RDEPEND="
dev-libs/icu:=
dev-libs/librevenge
dev-libs/libxml2
"
DEPEND="${RDEPEND}
- dev-lang/perl
dev-libs/boost
dev-util/gperf
sys-devel/libtool
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
test? ( dev-util/cppunit )
"
@@ -43,11 +47,13 @@ src_configure() {
# bug 619688
append-cxxflags -std=c++14
- econf \
- $(use_with doc docs) \
- $(use_enable static-libs static) \
- $(use_enable test tests) \
+ local myeconfargs=(
+ $(use_with doc docs)
+ $(use_enable static-libs static)
+ $(use_enable test tests)
$(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {