summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-02-19 19:17:20 +0100
committerDavid Seifert <soap@gentoo.org>2018-02-19 20:40:32 +0100
commita73c3126a8421173437c7bb100aec8e100ae399b (patch)
treee7e413d297ec6978fb6911a88c465a7b9eaa1e8b /media-libs/libvisio
parentmedia-libs/libfreehand: Always build in C++14 mode (diff)
downloadgentoo-a73c3126a8421173437c7bb100aec8e100ae399b.tar.gz
gentoo-a73c3126a8421173437c7bb100aec8e100ae399b.tar.bz2
gentoo-a73c3126a8421173437c7bb100aec8e100ae399b.zip
media-libs/libvisio: Always build in C++14 mode
Closes: https://bugs.gentoo.org/619688 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-libs/libvisio')
-rw-r--r--media-libs/libvisio/libvisio-0.1.6.ebuild7
-rw-r--r--media-libs/libvisio/libvisio-9999.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/media-libs/libvisio/libvisio-0.1.6.ebuild b/media-libs/libvisio/libvisio-0.1.6.ebuild
index 404db3604d3a..ccb6e687a432 100644
--- a/media-libs/libvisio/libvisio-0.1.6.ebuild
+++ b/media-libs/libvisio/libvisio-0.1.6.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit flag-o-matic
+
EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libvisio.git"
[[ ${PV} == 9999 ]] && inherit autotools git-r3
@@ -38,6 +40,9 @@ src_prepare() {
}
src_configure() {
+ # bug 619688
+ append-cxxflags -std=c++14
+
econf \
$(use_with doc docs) \
$(use_enable static-libs static) \
diff --git a/media-libs/libvisio/libvisio-9999.ebuild b/media-libs/libvisio/libvisio-9999.ebuild
index 79aa9cdc0188..1f7cc355b43d 100644
--- a/media-libs/libvisio/libvisio-9999.ebuild
+++ b/media-libs/libvisio/libvisio-9999.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit flag-o-matic
+
EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libvisio.git"
[[ ${PV} == 9999 ]] && inherit autotools git-r3
@@ -38,6 +40,9 @@ src_prepare() {
}
src_configure() {
+ # bug 619688
+ append-cxxflags -std=c++14
+
econf \
$(use_with doc docs) \
$(use_enable static-libs static) \