summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2023-03-18 07:49:08 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-04-10 10:37:23 +0300
commit511aa1e14b487d38be0774048ca42ca4aaed8359 (patch)
tree345adb90eed20d696e1af21429167a8bc7a518f6 /media-libs/openexr
parentapp-misc/broot: drop 1.20.1 (diff)
downloadgentoo-511aa1e14b487d38be0774048ca42ca4aaed8359.tar.gz
gentoo-511aa1e14b487d38be0774048ca42ca4aaed8359.tar.bz2
gentoo-511aa1e14b487d38be0774048ca42ca4aaed8359.zip
media-libs/openexr: add 3.1.7
Closes: https://bugs.gentoo.org/901201 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/30203 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs/openexr')
-rw-r--r--media-libs/openexr/Manifest1
-rw-r--r--media-libs/openexr/openexr-3.1.7.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/media-libs/openexr/Manifest b/media-libs/openexr/Manifest
index 3a13467779b7..b628bae952f4 100644
--- a/media-libs/openexr/Manifest
+++ b/media-libs/openexr/Manifest
@@ -1 +1,2 @@
DIST openexr-3.1.5.tar.gz 20327926 BLAKE2B 77ece3c62b34292d4714873149a5a54a47fe811e96f992f1082e7dca99ad7717649f937c2dd7b18011c4201f15056526fc4b706c4d2f1b7fa593b9f1ed6314bd SHA512 01ef16eacd2dde83c67b81522bae87f47ba272a41ce7d4e35d865dbdcaa03093e7ac504b95d2c1b3a19535f2364a4f937b0e0570c74243bb1c6e021fce7b620c
+DIST openexr-3.1.7.tar.gz 20494812 BLAKE2B 2cc03ed8da77f4a9523b7a0f55c78e78ab55f8f6de67cb68f1b2b4ad4b512448d80f39d60a0cc9eab451da35539027a573a0c6d6900e7f81b39f90703909b5af SHA512 f72f5e728f10c06fca0172c9b4c1df752225c3aed7384b4eaa502f92f8547bb1df93fe96d4d132a81eb32b729cb9fd615be825aa6c5de78481d3038c0d47c4d5
diff --git a/media-libs/openexr/openexr-3.1.7.ebuild b/media-libs/openexr/openexr-3.1.7.ebuild
new file mode 100644
index 000000000000..6022920a5566
--- /dev/null
+++ b/media-libs/openexr/openexr-3.1.7.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+MY_PN=OpenEXR
+
+DESCRIPTION="ILM's OpenEXR high dynamic-range image file format libraries"
+HOMEPAGE="https://www.openexr.com/"
+SRC_URI="https://github.com/AcademySoftwareFoundation/openexr/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/30" # based on SONAME
+# -ppc -sparc because broken on big endian, bug #818424
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong -ppc ~ppc64 ~riscv -sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE="cpu_flags_x86_avx examples large-stack utils test threads"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/imath-3.1.6:=
+ sys-libs/zlib
+ !media-libs/openexr:3
+ !media-libs/ilmbase
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.1.1-0003-disable-failing-test.patch )
+DOCS=( CHANGES.md GOVERNANCE.md PATENTS README.md SECURITY.md )
+
+src_prepare() {
+ # Fix path for testsuite
+ sed -e "s:/var/tmp/:${T}:" \
+ -i "${S}"/src/test/${MY_PN}Test/tmpDir.h || die "failed to set temp path for tests"
+
+ if use x86; then
+ eapply "${FILESDIR}"/${PN}-3.1.5-drop-failing-testDwaLookups.patch
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ if use x86; then
+ replace-cpu-flags native i686
+ fi
+
+ local mycmakeargs=(
+ -DBUILD_DOCS=OFF # needs sphinx_press_theme which we don't have in ::gentoo
+ -DBUILD_TESTING=$(usex test)
+ -DOPENEXR_BUILD_TOOLS=$(usex utils)
+ -DOPENEXR_ENABLE_LARGE_STACK=$(usex large-stack)
+ -DOPENEXR_ENABLE_THREADING=$(usex threads)
+ -DOPENEXR_INSTALL_EXAMPLES=$(usex examples)
+ -DOPENEXR_INSTALL_PKG_CONFIG=ON
+ -DOPENEXR_INSTALL_TOOLS=$(usex utils)
+ -DOPENEXR_USE_CLANG_TIDY=OFF # don't look for clang-tidy
+ )
+
+ use test && mycmakeargs+=( -DOPENEXR_RUN_FUZZ_TESTS=ON )
+
+ cmake_src_configure
+}
+
+src_install() {
+ use examples && docompress -x /usr/share/doc/${PF}/examples
+
+ cmake_src_install
+}