summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-12 12:39:23 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-12 12:39:33 +0100
commit01d54dcfff9f02fc3acd31acce03d3d2011e6346 (patch)
treecd4b9a4ded65dbbc043b86f4c4a0efe57e8a3dc6 /media-libs/x265
parentprofiles: mask power8 useflag in arch/base and unmask it for ppc, part of bug... (diff)
downloadgentoo-01d54dcfff9f02fc3acd31acce03d3d2011e6346.tar.gz
gentoo-01d54dcfff9f02fc3acd31acce03d3d2011e6346.tar.bz2
gentoo-01d54dcfff9f02fc3acd31acce03d3d2011e6346.zip
media-libs/x265: Add power8 useflag, bug #611906
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'media-libs/x265')
-rw-r--r--media-libs/x265/metadata.xml1
-rw-r--r--media-libs/x265/x265-2.2.ebuild4
-rw-r--r--media-libs/x265/x265-2.3.ebuild4
-rw-r--r--media-libs/x265/x265-9999.ebuild4
4 files changed, 10 insertions, 3 deletions
diff --git a/media-libs/x265/metadata.xml b/media-libs/x265/metadata.xml
index ed61a9259d5f..534499f3593e 100644
--- a/media-libs/x265/metadata.xml
+++ b/media-libs/x265/metadata.xml
@@ -9,6 +9,7 @@
<flag name="12bit">Add support for producing 12bits HEVC.</flag>
<flag name="numa">Build with support for NUMA nodes.</flag>
<flag name="pic">Disable optimized assembly code that is not PIC friendly</flag>
+ <flag name="power8">Enable support for Power 8 assembly optimizations.</flag>
</use>
<upstream>
<remote-id type="bitbucket">multicoreware/x265</remote-id>
diff --git a/media-libs/x265/x265-2.2.ebuild b/media-libs/x265/x265-2.2.ebuild
index 31477382476f..379c18e775a6 100644
--- a/media-libs/x265/x265-2.2.ebuild
+++ b/media-libs/x265/x265-2.2.ebuild
@@ -21,7 +21,7 @@ HOMEPAGE="http://x265.org/"
LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/102"
-IUSE="+10bit +12bit neon numa pic test"
+IUSE="+10bit +12bit neon numa pic power8 test"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
RDEPEND="numa? ( >=sys-process/numactl-2.0.10-r1[${MULTILIB_USEDEP}] )"
@@ -139,6 +139,8 @@ multilib_src_configure() {
$(cmake-utils_use_enable test TESTS)
$(multilib_is_native_abi || echo "-DENABLE_CLI=OFF")
-DENABLE_LIBNUMA=$(usex numa ON OFF)
+ -DCPU_POWER8=$(usex power8 ON OFF)
+ -DENABLE_ALTIVEC=$(usex power8 ON OFF)
-DLIB_INSTALL_DIR="$(get_libdir)"
)
diff --git a/media-libs/x265/x265-2.3.ebuild b/media-libs/x265/x265-2.3.ebuild
index 6a97b960617f..ed35ad6d5104 100644
--- a/media-libs/x265/x265-2.3.ebuild
+++ b/media-libs/x265/x265-2.3.ebuild
@@ -21,7 +21,7 @@ HOMEPAGE="http://x265.org/"
LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/110"
-IUSE="+10bit +12bit neon numa pic test"
+IUSE="+10bit +12bit neon numa pic power8 test"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
RDEPEND="numa? ( >=sys-process/numactl-2.0.10-r1[${MULTILIB_USEDEP}] )"
@@ -139,6 +139,8 @@ multilib_src_configure() {
$(cmake-utils_use_enable test TESTS)
$(multilib_is_native_abi || echo "-DENABLE_CLI=OFF")
-DENABLE_LIBNUMA=$(usex numa ON OFF)
+ -DCPU_POWER8=$(usex power8 ON OFF)
+ -DENABLE_ALTIVEC=$(usex power8 ON OFF)
-DLIB_INSTALL_DIR="$(get_libdir)"
)
diff --git a/media-libs/x265/x265-9999.ebuild b/media-libs/x265/x265-9999.ebuild
index 5efa377f90f1..65e1f961e655 100644
--- a/media-libs/x265/x265-9999.ebuild
+++ b/media-libs/x265/x265-9999.ebuild
@@ -21,7 +21,7 @@ HOMEPAGE="http://x265.org/"
LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/111"
-IUSE="+10bit +12bit neon numa pic test"
+IUSE="+10bit +12bit neon numa pic power8 test"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
RDEPEND="numa? ( >=sys-process/numactl-2.0.10-r1[${MULTILIB_USEDEP}] )"
@@ -139,6 +139,8 @@ multilib_src_configure() {
$(cmake-utils_use_enable test TESTS)
$(multilib_is_native_abi || echo "-DENABLE_CLI=OFF")
-DENABLE_LIBNUMA=$(usex numa ON OFF)
+ -DCPU_POWER8=$(usex power8 ON OFF)
+ -DENABLE_ALTIVEC=$(usex power8 ON OFF)
-DLIB_INSTALL_DIR="$(get_libdir)"
)