summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-12-26 16:54:41 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-12-26 17:45:06 +0100
commitea8f708e33d62490087d32e29809354931a4b301 (patch)
treeefe33f51672d740bd210c7f029108fcafef19854 /media-libs/x265
parentapp-eselect/eselect-ruby: add version with ruby24 support (diff)
downloadgentoo-ea8f708e33d62490087d32e29809354931a4b301.tar.gz
gentoo-ea8f708e33d62490087d32e29809354931a4b301.tar.bz2
gentoo-ea8f708e33d62490087d32e29809354931a4b301.zip
media-libs/x265: bump to 2.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-libs/x265')
-rw-r--r--media-libs/x265/Manifest1
-rw-r--r--media-libs/x265/x265-2.2.ebuild171
-rw-r--r--media-libs/x265/x265-9999.ebuild2
3 files changed, 173 insertions, 1 deletions
diff --git a/media-libs/x265/Manifest b/media-libs/x265/Manifest
index 49bb0222ca90..59c60b476095 100644
--- a/media-libs/x265/Manifest
+++ b/media-libs/x265/Manifest
@@ -4,3 +4,4 @@ DIST x265_1.8.tar.gz 918469 SHA256 760e6280c688f1ea90c492d19fc6d4084ca1c4b0ea9b2
DIST x265_1.9.tar.gz 956101 SHA256 3e4654133ed957a98708fdb4cb9a154d9e80922b84e26e43fc462a101c5b15c8 SHA512 1c399101374da58d0661786a6144dd25a2028e25bcb99b3084d8839b0bd9c20bccf5c0e4413882f16b3b1c49f96710746a16cb690f3811dffb08c3befdc8e5f1 WHIRLPOOL 508d21ad0ff7ed8eb2fe9a9a69113dc7dca07306ddace6de22b29e71dad7242fae0b6e4864a409a0279d85adbe054b4ffbc8c95fe915163b506f5bab25245f8c
DIST x265_2.0.tar.gz 1028299 SHA256 5a7f6797bee33310c690be5d9a6c63125f36663ac3478e98ac6b6142a70bce1f SHA512 4262a32cf9a34c494770c7917fbaba88e8211c332a91932f4cd096ce25394979e1d43ae641be0aa480af1d0580e842ca70f58005dd41361b78dfd25870035a1e WHIRLPOOL c85e42a3bbf3ee9d84a69615b117444088e16c45cea7362956c92dc1097babdc8cb819d101bf17a97bfb0128e93a5c85cf9c8d980dc75de9de90dcf6a3e46b09
DIST x265_2.1.tar.gz 1037400 SHA256 b3bc83754e91ed5655c8cba5a2ed48e6b9ab39699c9ed6554c670211d5870f9c SHA512 44ad6815efb039054935f2887f0c98604898a6b5bf144f845df92038ef47ea1c21f2942501294514b05e7eaffd988e52ca777da0be97e57fdd77c89ff0fda421 WHIRLPOOL f91e7fffdccb494c32a6a4b18b72e72537c89bc0a1117e26f2030b9f3d5d11a0e642e25faa83c0b59ca117666d1d81a21823b653d3e0d138073478176908f83b
+DIST x265_2.2.tar.gz 1203801 SHA256 b872552535e41fbffa03ba7cbcd3479c42c4053868309292e78e147b7773ac4b SHA512 335bb38cf0892f2c4310033b076d51115c0b7faa9596a4f556dde5e3d1378d04f3d0055cb0bf2441eb725b7f84c246174bdc315eeb4ddde61ef9d79469f44eef WHIRLPOOL 6aa6fb3669abbb6e3fd9dd9ffe38f595805a61beedcfccd509606a9c3a19f79037a518269206ddcac7231de45165f000e59c3b0f279921a6aa8de2cb5b38a7ec
diff --git a/media-libs/x265/x265-2.2.ebuild b/media-libs/x265/x265-2.2.ebuild
new file mode 100644
index 000000000000..32a4c1f498e0
--- /dev/null
+++ b/media-libs/x265/x265-2.2.ebuild
@@ -0,0 +1,171 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils multilib-minimal multilib multibuild flag-o-matic
+
+if [[ ${PV} = 9999* ]]; then
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/multicoreware/x265"
+else
+ SRC_URI="
+ https://bitbucket.org/multicoreware/x265/downloads/${PN}_${PV}.tar.gz
+ http://ftp.videolan.org/pub/videolan/x265/${PN}_${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Library for encoding video streams into the H.265/HEVC format"
+HOMEPAGE="http://x265.org/"
+
+LICENSE="GPL-2"
+# subslot = libx265 soname
+SLOT="0/102"
+IUSE="+10bit +12bit numa pic test"
+
+ASM_DEPEND=">=dev-lang/yasm-1.2.0"
+RDEPEND="numa? ( >=sys-process/numactl-2.0.10-r1[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ abi_x86_32? ( ${ASM_DEPEND} )
+ abi_x86_64? ( ${ASM_DEPEND} )"
+
+src_unpack() {
+ if [[ ${PV} = 9999* ]]; then
+ mercurial_src_unpack
+ # Can't set it at global scope due to mercurial.eclass limitations...
+ export S=${WORKDIR}/${P}/source
+ else
+ unpack ${A}
+ export S="$(echo "${WORKDIR}/${PN}_"*"/source")"
+ fi
+}
+
+# By default, the library and the encoder is configured for only one output bit
+# depth. Meaning, one has to rebuild libx265 if (s)he wants to produce HEVC
+# files with a different bit depth, which is annoying. However, upstream
+# supports proper namespacing for 8bits, 10bits & 12bits HEVC and linking all
+# that together so that the resulting library can produce all three of them
+# instead of only one.
+# The API requires the bit depth parameter, so that libx265 can then chose which
+# variant of the encoder to use.
+# To achieve this, we have to build one (static) library for each non-main
+# variant, and link it into the main library.
+# Upstream documents using the 8bit variant as main library, hence we do not
+# allow disabling it: "main" *MUST* come last in the following list.
+
+x265_get_variants() {
+ local variants=""
+ use 12bit && variants+="main12 "
+ use 10bit && variants+="main10 "
+ variants+="main"
+ echo "${variants}"
+}
+
+x265_variant_src_configure() {
+ mkdir -p "${BUILD_DIR}" || die
+ pushd "${BUILD_DIR}" >/dev/null || die
+
+ local mycmakeargs=( "${myabicmakeargs[@]}" )
+ case "${MULTIBUILD_VARIANT}" in
+ "main12")
+ mycmakeargs+=(
+ -DHIGH_BIT_DEPTH=ON
+ -DEXPORT_C_API=OFF
+ -DENABLE_SHARED=OFF
+ -DENABLE_CLI=OFF
+ -DMAIN12=ON
+ )
+ if [[ ${ABI} = x86 ]] ; then
+ mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
+ fi
+ ;;
+ "main10")
+ mycmakeargs+=(
+ -DHIGH_BIT_DEPTH=ON
+ -DEXPORT_C_API=OFF
+ -DENABLE_SHARED=OFF
+ -DENABLE_CLI=OFF
+ )
+ if [[ ${ABI} = x86 ]] ; then
+ mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
+ fi
+ ;;
+ "main")
+ if (( "${#MULTIBUILD_VARIANTS[@]}" > 1 )) ; then
+ local myvariants=( "${MULTIBUILD_VARIANTS[@]}" )
+ unset myvariants[${#MULTIBUILD_VARIANTS[@]}-1]
+ local liblist=""
+ for v in "${myvariants[@]}" ; do
+ ln -s "${BUILD_DIR%-*}-${v}/libx265.a" "libx265_${v}.a" || die
+ liblist+="libx265_${v}.a;"
+ done
+ mycmakeargs+=(
+ -DEXTRA_LIB="${liblist}"
+ -DEXTRA_LINK_FLAGS=-L.
+ -DLINKED_10BIT=$(usex 10bit)
+ -DLINKED_12BIT=$(usex 12bit)
+ )
+ fi
+ ;;
+ *)
+ die "Unknown variant: ${MULTIBUILD_VARIANT}";;
+ esac
+ cmake-utils_src_configure
+ popd >/dev/null || die
+}
+
+multilib_src_configure() {
+ append-cflags -fPIC
+ append-cxxflags -fPIC
+ local myabicmakeargs=(
+ $(cmake-utils_use_enable test TESTS)
+ $(multilib_is_native_abi || echo "-DENABLE_CLI=OFF")
+ -DENABLE_LIBNUMA=$(usex numa ON OFF)
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ )
+
+ if [[ ${ABI} = x86 ]] ; then
+ # Bug #528202
+ if use pic ; then
+ ewarn "PIC has been requested but x86 asm is not PIC-safe, disabling it."
+ myabicmakeargs+=( -DENABLE_ASSEMBLY=OFF )
+ fi
+ elif [[ ${ABI} = x32 ]] ; then
+ # bug #510890
+ myabicmakeargs+=( -DENABLE_ASSEMBLY=OFF )
+ fi
+
+ local MULTIBUILD_VARIANTS=( $(x265_get_variants) )
+ multibuild_foreach_variant x265_variant_src_configure
+}
+
+multilib_src_compile() {
+ local MULTIBUILD_VARIANTS=( $(x265_get_variants) )
+ multibuild_foreach_variant cmake-utils_src_compile
+}
+
+x265_variant_src_test() {
+ if [ -x "${BUILD_DIR}/test/TestBench" ] ; then
+ "${BUILD_DIR}/test/TestBench" || die
+ else
+ einfo "Unit tests check only assembly."
+ einfo "You do not seem to have any for ABI=${ABI}, x265 variant=${MULTIBUILD_VARIANT}"
+ einfo "Skipping tests."
+ fi
+}
+
+multilib_src_test() {
+ local MULTIBUILD_VARIANTS=( $(x265_get_variants) )
+ multibuild_foreach_variant x265_variant_src_test
+}
+
+multilib_src_install() {
+ # Install only "main" variant since the others are already linked into it.
+ local MULTIBUILD_VARIANTS=( "main" )
+ multibuild_foreach_variant cmake-utils_src_install
+}
+
+multilib_src_install_all() {
+ dodoc -r "${S}/../doc/"*
+}
diff --git a/media-libs/x265/x265-9999.ebuild b/media-libs/x265/x265-9999.ebuild
index 3864484ff4a9..3ac5bf949e37 100644
--- a/media-libs/x265/x265-9999.ebuild
+++ b/media-libs/x265/x265-9999.ebuild
@@ -21,7 +21,7 @@ HOMEPAGE="http://x265.org/"
LICENSE="GPL-2"
# subslot = libx265 soname
-SLOT="0/95"
+SLOT="0/104"
IUSE="+10bit +12bit numa pic test"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"