summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2021-02-27 14:34:49 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-02-27 20:48:54 +0200
commit2d2b3017b0c6c93e17967e82369090e9f0d889b2 (patch)
treeb36349d5a0fca6319e70303c3f30f4abc5c58f3a /media-plugins
parentdev-python/python-slip: Drop 0.6.5 (r0) (diff)
downloadgentoo-2d2b3017b0c6c93e17967e82369090e9f0d889b2.tar.gz
gentoo-2d2b3017b0c6c93e17967e82369090e9f0d889b2.tar.bz2
gentoo-2d2b3017b0c6c93e17967e82369090e9f0d889b2.zip
media-plugins/vdr-epgsearch: fix for 2.4.0_p20200402-r1
the useflag logic is wrong since commit 290ec0e38b, fix this here fix sendmail path Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-epgsearch/vdr-epgsearch-2.4.0_p20200402-r1.ebuild96
1 files changed, 96 insertions, 0 deletions
diff --git a/media-plugins/vdr-epgsearch/vdr-epgsearch-2.4.0_p20200402-r1.ebuild b/media-plugins/vdr-epgsearch/vdr-epgsearch-2.4.0_p20200402-r1.ebuild
new file mode 100644
index 000000000000..cf3297423806
--- /dev/null
+++ b/media-plugins/vdr-epgsearch/vdr-epgsearch-2.4.0_p20200402-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR plugin: create timers from epg content based on saved search expressions"
+HOMEPAGE="http://winni.vdr-developer.org/epgsearch/index_eng.html"
+GIT_COMMIT_ID="d8cff1a251ef2b54f1de3f8e6ea55a838eeb73c3"
+SRC_URI="https://projects.vdr-developer.org/git/vdr-plugin-epgsearch.git/snapshot/vdr-plugin-epgsearch-${GIT_COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="conflictcheckonly epgsearchonly pcre quicksearch tre"
+REQUIRED_USE="?? ( pcre tre )"
+
+DEPEND="
+ >=media-video/vdr-2.4
+ pcre? ( dev-libs/libpcre )
+ tre? ( dev-libs/tre )"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-apps/groff
+ dev-lang/perl"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4.0_makefile.patch"
+ "${FILESDIR}/${PN}-2.4.0_docsrc2man-no-gzip.patch"
+ "${FILESDIR}/${P}_clang.patch"
+)
+
+QA_FLAGS_IGNORED="
+ usr/lib/vdr/plugins/libvdr-.*
+ usr/lib64/vdr/plugins/libvdr-.*
+ usr/bin/createcats"
+S="${WORKDIR}/vdr-plugin-epgsearch-${GIT_COMMIT_ID}"
+
+src_prepare() {
+ # remove untranslated .po files
+ rm "${S}"/po/{ca_ES,da_DK,el_GR,et_EE,hr_HR,hu_HU,nn_NO,pl_PL,pt_PT,ro_RO,ru_RU,sl_SI,sv_SE,tr_TR}.po \
+ || die "cannot remove untranslated .po files"
+
+ if ! use conflictcheckonly; then
+ sed -e "s:install-\$(PLUGIN3)::" -i Makefile || die "cannot modify Makefile"
+ fi
+
+ if ! use epgsearchonly; then
+ sed -e "s:install-\$(PLUGIN2)::" -i Makefile || die "cannot modify Makefile"
+ fi
+
+ if ! use quicksearch; then
+ sed -e "s:install-\$(PLUGIN4)::" -i Makefile || die "cannot modify Makefile"
+ fi
+
+ vdr-plugin-2_src_prepare
+
+ fix_vdr_libsi_include conflictcheck.c
+
+ # install conf-file disabled
+ sed -e '/^Menu/s:^:#:' -i conf/epgsearchmenu.conf || die "cannot modify epgsearchmenu.conf"
+
+ # Get rid of the broken symlink
+ rm README || die "cannot remove broken symlink"
+}
+
+src_compile() {
+ BUILD_PARAMS="SENDMAIL=/usr/sbin/sendmail AUTOCONFIG=0"
+
+ if use pcre; then
+ BUILD_PARAMS+=" REGEXLIB=pcre"
+ einfo "Using pcre for regexp searches"
+ fi
+
+ if use tre; then
+ BUILD_PARAMS+=" REGEXLIB=tre"
+ einfo "Using tre for unlimited fuzzy searches"
+ fi
+
+ vdr-plugin-2_src_compile
+}
+
+src_install() {
+ local DOCS=( conf/*.templ HISTORY* README.Translators )
+ vdr-plugin-2_src_install
+
+ diropts -m 755 -o vdr -g vdr
+ insopts -m 644 -o vdr -g vdr
+ keepdir /etc/vdr/plugins/epgsearch
+ insinto /etc/vdr/plugins/epgsearch
+ doins conf/*
+
+ doman man/en/*
+ doman -i18n=de man/de/*
+}