summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-radio/dxcc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-radio/dxcc')
-rw-r--r--media-radio/dxcc/Manifest1
-rw-r--r--media-radio/dxcc/dxcc-20080225-r1.ebuild27
-rw-r--r--media-radio/dxcc/files/Makefile.patch28
-rw-r--r--media-radio/dxcc/metadata.xml8
4 files changed, 64 insertions, 0 deletions
diff --git a/media-radio/dxcc/Manifest b/media-radio/dxcc/Manifest
new file mode 100644
index 000000000000..fd57065398af
--- /dev/null
+++ b/media-radio/dxcc/Manifest
@@ -0,0 +1 @@
+DIST dxcc-20080225.tar.gz 110774 SHA256 a2fbd272b4b8494929a750df8f5eec704a8b469ee007d925b9ef20d7012aa274 SHA512 ef976d5c94b488d3dec132850f9c4da34caf02eee77a8c38a3fce5ccb033ffb848d5814eb72756d04235b9cc454f17f4c31aa47295c9e9cecec716ff32bf3df7 WHIRLPOOL 41a799b5e5d819cf9850e1b62d2555b5628bac2ac2413b730f5f2574afdcadf5911986e7b8e0ec9cb2dc90aaae23fd9ab686bacbed356c17d7e350022f63b3aa
diff --git a/media-radio/dxcc/dxcc-20080225-r1.ebuild b/media-radio/dxcc/dxcc-20080225-r1.ebuild
new file mode 100644
index 000000000000..dc1cf731af0e
--- /dev/null
+++ b/media-radio/dxcc/dxcc-20080225-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="A ham radio callsign DXCC lookup utility"
+HOMEPAGE="http://fkurz.net/ham/dxcc.html"
+SRC_URI="http://fkurz.net/ham/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="tk"
+
+RDEPEND="dev-lang/perl
+ tk? ( dev-perl/perl-tk )"
+
+src_prepare() {
+ epatch "${FILESDIR}/Makefile.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}/usr" install
+ dodoc README ChangeLog
+}
diff --git a/media-radio/dxcc/files/Makefile.patch b/media-radio/dxcc/files/Makefile.patch
new file mode 100644
index 000000000000..d4f391bed094
--- /dev/null
+++ b/media-radio/dxcc/files/Makefile.patch
@@ -0,0 +1,28 @@
+--- Makefile.orig 2009-04-07 19:10:23.000000000 +0200
++++ Makefile 2009-04-07 19:11:12.000000000 +0200
+@@ -4,19 +4,22 @@
+ DESTDIR ?= /usr
+
+ all:
+- @echo -e "dxcc - make [install|uninstall|clean|dist] \nCheck README for help."
+
+ install:
+- install -d -v $(DESTDIR)/share/man/man1/
+- install -d -v $(DESTDIR)/share/dxcc/
++ install -d $(DESTDIR)/share/man/man1/
++ install -d $(DESTDIR)/share/dxcc/
++ install -d $(DESTDIR)/share/pixmaps/
++ install -d $(DESTDIR)/bin/
+ install -m 0644 dxcc.1 $(DESTDIR)/share/man/man1/
+ install -m 0644 earth.gif $(DESTDIR)/share/dxcc/
++ install -m 0644 dxcc.png $(DESTDIR)/share/pixmaps/
+ install -m 0755 dxcc $(DESTDIR)/bin/
+
+ uninstall:
+ rm -f $(DESTDIR)/bin/dxcc
+ rm -f $(DESTDIR)/share/man/man1/dxcc.1
+ rm -f $(DESTDIR)/share/dxcc/earth.gif
++ rm -r $(DESTDIR)/share/pixmaps/dxcc.png
+
+ clean:
+ rm -f *~
diff --git a/media-radio/dxcc/metadata.xml b/media-radio/dxcc/metadata.xml
new file mode 100644
index 000000000000..835c76cab148
--- /dev/null
+++ b/media-radio/dxcc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tomjbe@gentoo.org</email>
+ <name>Thomas Beierlein</name>
+ </maintainer>
+</pkgmetadata>