summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-radio/radiotray
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-radio/radiotray')
-rw-r--r--media-radio/radiotray/Manifest1
-rw-r--r--media-radio/radiotray/metadata.xml22
-rw-r--r--media-radio/radiotray/radiotray-0.7.3-r2.ebuild37
-rw-r--r--media-radio/radiotray/radiotray-9999.ebuild59
4 files changed, 119 insertions, 0 deletions
diff --git a/media-radio/radiotray/Manifest b/media-radio/radiotray/Manifest
new file mode 100644
index 000000000000..111b7192bcbd
--- /dev/null
+++ b/media-radio/radiotray/Manifest
@@ -0,0 +1 @@
+DIST radiotray-0.7.3.tar.gz 94678 SHA256 709cbabbd03627270f60cd56084803d6f03fe0e14fbfc15b6325b4c5bd9faf2d SHA512 84e32d7be0db87e7a42464dae5207fd4c0f52208f4c92c5033fd51695276be5af013c824bcfbf1944d34977a82702c6d00f31079563c8ce477d166df64bcfb84 WHIRLPOOL b32b9f9a35bfbd6d4fd5ca86ed3ab878c24e45b3ec70372c2508985b9240458bb56d44465f1ddf3a58eac70700820451bc06bad25adf670a54e8343a915cec1c
diff --git a/media-radio/radiotray/metadata.xml b/media-radio/radiotray/metadata.xml
new file mode 100644
index 000000000000..1f35d6b306a9
--- /dev/null
+++ b/media-radio/radiotray/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<upstream>
+ <maintainer>
+ <email>carlosmribeiro1@gmail.com</email>
+ <name>Carlos Ribeiro</name>
+ </maintainer>
+ <maintainer>
+ <email>ogmaciel@gnome.org</email>
+ <name>Og Maciel</name>
+ </maintainer>
+ <changelog>http://radiotray.sourceforge.net/</changelog>
+</upstream>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-radio/radiotray/radiotray-0.7.3-r2.ebuild b/media-radio/radiotray/radiotray-0.7.3-r2.ebuild
new file mode 100644
index 000000000000..6027c21425e8
--- /dev/null
+++ b/media-radio/radiotray/radiotray-0.7.3-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="Online radio streaming player"
+HOMEPAGE="http://radiotray.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-1+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="sys-apps/dbus[X]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/gst-python:0.10[${PYTHON_USEDEP}]
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/notify-python[${PYTHON_USEDEP}]
+ media-libs/gst-plugins-good:0.10
+ media-libs/gst-plugins-ugly:0.10
+ media-plugins/gst-plugins-alsa:0.10
+ media-plugins/gst-plugins-libmms:0.10
+ media-plugins/gst-plugins-ffmpeg:0.10
+ media-plugins/gst-plugins-mad:0.10
+ media-plugins/gst-plugins-ogg:0.10
+ media-plugins/gst-plugins-soup:0.10
+ media-plugins/gst-plugins-vorbis:0.10"
+
+DEPEND="dev-python/pyxdg[${PYTHON_USEDEP}]"
diff --git a/media-radio/radiotray/radiotray-9999.ebuild b/media-radio/radiotray/radiotray-9999.ebuild
new file mode 100644
index 000000000000..96553be270c1
--- /dev/null
+++ b/media-radio/radiotray/radiotray-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+DISTUTILS_NO_PARALLEL_BUILD=1
+
+inherit distutils-r1 mercurial
+
+DESCRIPTION="Online radio streaming player"
+HOMEPAGE="http://radiotray.sourceforge.net/"
+SRC_URI=""
+EHG_REPO_URI="http://radiotray.hg.sourceforge.net:8000/hgroot/radiotray/radiotray"
+
+LICENSE="GPL-1+"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+LANGS="ca de el en_GB es fi fr gl gu hu it ko lt pl pt_BR pt ro ru sk sl sv te
+tr uk zh_CN"
+
+for x in ${LANGS}; do
+ IUSE="${IUSE} linguas_${x}"
+done
+
+RDEPEND="sys-apps/dbus[X]
+ dev-python/gst-python:0.10[${PYTHON_USEDEP}]
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/notify-python[${PYTHON_USEDEP}]
+ media-libs/gst-plugins-good:0.10
+ media-libs/gst-plugins-ugly:0.10
+ media-plugins/gst-plugins-alsa:0.10
+ media-plugins/gst-plugins-libmms:0.10
+ media-plugins/gst-plugins-ffmpeg:0.10
+ media-plugins/gst-plugins-mad:0.10
+ media-plugins/gst-plugins-ogg:0.10
+ media-plugins/gst-plugins-soup:0.10
+ media-plugins/gst-plugins-vorbis:0.10"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS CONTRIBUTORS NEWS README )
+
+python_prepare_all() {
+ # remove LINUGAS file so we can create our
+ rm "${S}"/po/LINGUAS
+ for x in ${LANGS}; do
+ use "linguas_${x}" && echo "${x}" >> "${S}"/po/LINGUAS
+ ! use "linguas_${x}" && rm "${S}"/po/${x}.po
+ done
+
+ distutils-r1_python_prepare_all
+}