summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-11-08 13:09:25 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2019-11-08 13:09:25 +0100
commitf54e363826efd2dc53347a8657282df93fa2fd8c (patch)
treec1911f2bd5ccd56c59bf90dbf659a0f0a35b87b8 /media-sound/cadence
parentapp-office/scribus-9999: python-3, eapi7, qa fixes (diff)
downloadgentoo-f54e363826efd2dc53347a8657282df93fa2fd8c.tar.gz
gentoo-f54e363826efd2dc53347a8657282df93fa2fd8c.tar.bz2
gentoo-f54e363826efd2dc53347a8657282df93fa2fd8c.zip
media-sound/cadence: fixes
1) updated python-3 2) switched from xdg-utils to xdg 3) keeping more apps Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/cadence')
-rw-r--r--media-sound/cadence/cadence-0.9.0-r2.ebuild (renamed from media-sound/cadence/cadence-0.9.0-r1.ebuild)16
-rw-r--r--media-sound/cadence/cadence-9999.ebuild16
2 files changed, 8 insertions, 24 deletions
diff --git a/media-sound/cadence/cadence-0.9.0-r1.ebuild b/media-sound/cadence/cadence-0.9.0-r2.ebuild
index 0bfc569c9cb8..c3fac92fcd8d 100644
--- a/media-sound/cadence/cadence-0.9.0-r1.ebuild
+++ b/media-sound/cadence/cadence-0.9.0-r2.ebuild
@@ -3,8 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python3_{4,5,6} )
-inherit python-single-r1 xdg-utils desktop
+PYTHON_COMPAT=( python3_{6,7} )
+inherit python-single-r1 xdg desktop
DESCRIPTION="Collection of tools useful for audio production"
HOMEPAGE="http://kxstudio.linuxaudio.org/Applications:Cadence"
@@ -17,6 +17,7 @@ IUSE="-pulseaudio opengl"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# for jack project rendering also needs media-sound/jack_capture which is not in the tree yet
RDEPEND="${PYTHON_DEPS}
media-sound/jack2[dbus]
dev-python/PyQt5[dbus,gui,opengl?,svg,widgets,${PYTHON_USEDEP}]
@@ -57,8 +58,6 @@ src_install() {
rm -rf "${D}"/etc/X11/xinit/xinitrc.d/61cadence-session-inject
rm -rf "${D}"/etc/xdg/autostart/cadence-session-start.desktop
rm -rf "${D}"/usr/share/applications/*.desktop
- rm -rf "${D}"/usr/bin/{catarina,claudia*}
- rm -rf "${D}"/usr/share/cadence/icons/claudia-hicolor/
if use !pulseaudio; then
rm -rf "${D}"/usr/bin/cadence-pulse2{jack,loopback}
@@ -68,12 +67,5 @@ src_install() {
# Replace desktop entries with QA issues with these
make_desktop_entry cadence Cadence cadence "AudioVideo;AudioVideoEditing;Qt"
make_desktop_entry catia Catia catia "AudioVideo;AudioVideoEditing;Qt"
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
+ make_desktop_entry catarina Catarina catarina "AudioVideo;AudioVideoEditing;Qt"
}
diff --git a/media-sound/cadence/cadence-9999.ebuild b/media-sound/cadence/cadence-9999.ebuild
index f005484a5a4e..b8f9be329785 100644
--- a/media-sound/cadence/cadence-9999.ebuild
+++ b/media-sound/cadence/cadence-9999.ebuild
@@ -3,8 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python3_{4,5,6} )
-inherit git-r3 python-single-r1 xdg-utils desktop
+PYTHON_COMPAT=( python3_{6,7} )
+inherit git-r3 python-single-r1 xdg desktop
DESCRIPTION="Collection of tools useful for audio production"
HOMEPAGE="http://kxstudio.linuxaudio.org/Applications:Cadence"
@@ -17,6 +17,7 @@ IUSE="-pulseaudio opengl"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# for jack project rendering also needs media-sound/jack_capture which is not in the tree yet
RDEPEND="${PYTHON_DEPS}
media-sound/jack2[dbus]
dev-python/PyQt5[dbus,gui,opengl?,svg,widgets,${PYTHON_USEDEP}]
@@ -55,8 +56,6 @@ src_install() {
rm -rf "${D}"/etc/X11/xinit/xinitrc.d/61cadence-session-inject
rm -rf "${D}"/etc/xdg/autostart/cadence-session-start.desktop
rm -rf "${D}"/usr/share/applications/*.desktop
- rm -rf "${D}"/usr/bin/{catarina,claudia*}
- rm -rf "${D}"/usr/share/cadence/icons/claudia-hicolor/
if use !pulseaudio; then
rm -rf "${D}"/usr/bin/cadence-pulse2{jack,loopback}
@@ -66,12 +65,5 @@ src_install() {
# Replace desktop entries with QA issues with these
make_desktop_entry cadence Cadence cadence "AudioVideo;AudioVideoEditing;Qt"
make_desktop_entry catia Catia catia "AudioVideo;AudioVideoEditing;Qt"
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
+ make_desktop_entry catarina Catarina catarina "AudioVideo;AudioVideoEditing;Qt"
}