summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/forked-daapd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/forked-daapd')
-rw-r--r--media-sound/forked-daapd/Manifest1
-rw-r--r--media-sound/forked-daapd/files/daapd.confd11
-rw-r--r--media-sound/forked-daapd/files/daapd.initd31
-rw-r--r--media-sound/forked-daapd/files/forked-daapd-23.2-fix-arg-enable.patch57
-rw-r--r--media-sound/forked-daapd/forked-daapd-23.2.ebuild79
-rw-r--r--media-sound/forked-daapd/metadata.xml27
6 files changed, 206 insertions, 0 deletions
diff --git a/media-sound/forked-daapd/Manifest b/media-sound/forked-daapd/Manifest
new file mode 100644
index 000000000000..fac1baf27345
--- /dev/null
+++ b/media-sound/forked-daapd/Manifest
@@ -0,0 +1 @@
+DIST 23.2.tar.gz 325895 SHA256 8a85dfc479cfb3aeb01f5cec7f782b9eee749121f2d8a2b30932de9fbb31d19c SHA512 11b5c6c16c0c9e20f1c196941cd09602d90b5e2ed0765e4fac25c6aeba388706bd7ede9f6c467227c245f2597466e8658f9db75073ee8b47b16f947514eb1511 WHIRLPOOL 05fd527a3ae57bb3ff3bf11b455bd926ee76d4358a569da674745a6e2b30343a35bc40cc44c90aaa10b70f496ddbf99e0975910b8ab3f759cc43929a0d19119f
diff --git a/media-sound/forked-daapd/files/daapd.confd b/media-sound/forked-daapd/files/daapd.confd
new file mode 100644
index 000000000000..8b268509861b
--- /dev/null
+++ b/media-sound/forked-daapd/files/daapd.confd
@@ -0,0 +1,11 @@
+# Set the log level (0-5)
+#LOG_LEVEL=2
+
+# Specify the log domains. Comma-separated, choose from: config,
+# daap, db, httpd, main, mdns, misc, rsp, scan, xcode, event, remote,
+# dacp, ffmpeg, artwork, player, raop, laudio, dmap, dbperf, spotify,
+# lastfm, cache
+#LOG_DOMAINS=main,config
+
+# ffid to be broadcast in mDNS records
+#FFID=homeserver
diff --git a/media-sound/forked-daapd/files/daapd.initd b/media-sound/forked-daapd/files/daapd.initd
new file mode 100644
index 000000000000..cc3c8e8d6e6e
--- /dev/null
+++ b/media-sound/forked-daapd/files/daapd.initd
@@ -0,0 +1,31 @@
+#!/sbin/runscript
+
+# Override in /etc/conf.d/daapd
+LOG_LEVEL=${LOG_LEVEL:-2}
+LOG_DOMAINS=${LOG_DOMAINS:-'main,mdns,db,scan'}
+FFID=${FFID:-daapd}
+
+PIDFILE=/var/run/forked-daapd.pid
+
+depend() {
+ need avahi-dnsconfd
+}
+
+start() {
+ ebegin "Starting daapd"
+ start-stop-daemon --start forked-daapd \
+ --pidfile "$PIDFILE" \
+ -- \
+ -P "$PIDFILE" \
+ -d "$LOG_LEVEL" \
+ -b "$FFID" \
+ -D "$LOG_DOMAINS"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping daapd"
+ start-stop-daemon --stop forked-daapd \
+ --pidfile "$PIDFILE"
+ eend $?
+}
diff --git a/media-sound/forked-daapd/files/forked-daapd-23.2-fix-arg-enable.patch b/media-sound/forked-daapd/files/forked-daapd-23.2-fix-arg-enable.patch
new file mode 100644
index 000000000000..7c4297ef0e9f
--- /dev/null
+++ b/media-sound/forked-daapd/files/forked-daapd-23.2-fix-arg-enable.patch
@@ -0,0 +1,57 @@
+--- configure.ac.orig 2015-07-20 18:03:12.270584746 -0500
++++ configure.ac 2015-07-20 18:03:00.050585581 -0500
+@@ -51,25 +51,35 @@
+ AC_SYS_LARGEFILE
+ AC_TYPE_OFF_T
+
+-AC_ARG_ENABLE(flac, AS_HELP_STRING([--enable-flac], [extract FLAC metadata with libflac (default=no)]),
+- use_flac=true;
+- CPPFLAGS="${CPPFLAGS} -DFLAC")
+-
+-AC_ARG_ENABLE(musepack, AS_HELP_STRING([--enable-musepack], [extract Musepack metadata with taglib (default=no)]),
+- use_musepack=true;
+- CPPFLAGS="${CPPFLAGS} -DMUSEPACK")
+-
+-AC_ARG_ENABLE(itunes, AS_HELP_STRING([--enable-itunes], [enable iTunes library support (default=no)]),
+- use_itunes=true;
+- CPPFLAGS="${CPPFLAGS} -DITUNES")
+-
+-AC_ARG_ENABLE(spotify, AS_HELP_STRING([--enable-spotify], [enable Spotify library support (default=no)]),
+- use_spotify=true;
+- CPPFLAGS="${CPPFLAGS} -DSPOTIFY")
+-
+-AC_ARG_ENABLE(lastfm, AS_HELP_STRING([--enable-lastfm], [enable LastFM support (default=no)]),
+- use_lastfm=true;
+- CPPFLAGS="${CPPFLAGS} -DLASTFM")
++AC_ARG_ENABLE(flac, AS_HELP_STRING([--enable-flac], [extract FLAC metadata with libflac (default=no)]))
++AS_IF([test "x$enable_flac" = "xyes"], [
++ use_flac=true;
++ CPPFLAGS="${CPPFLAGS} -DFLAC"
++])
++
++AC_ARG_ENABLE(musepack, AS_HELP_STRING([--enable-musepack], [extract Musepack metadata with taglib (default=no)]))
++AS_IF([test "x$enable_musepack" = "xyes"], [
++ use_musepack=true;
++ CPPFLAGS="${CPPFLAGS} -DMUSEPACK"
++])
++
++AC_ARG_ENABLE(itunes, AS_HELP_STRING([--enable-itunes], [enable iTunes library support (default=no)]))
++AS_IF([test "x$enable_itunes" = "xyes"], [
++ use_itunes=true;
++ CPPFLAGS="${CPPFLAGS} -DITUNES"
++])
++
++AC_ARG_ENABLE(spotify, AS_HELP_STRING([--enable-spotify], [enable Spotify library support (default=no)]))
++AS_IF([test "x$enable_spotify" = "xyes"], [
++ use_spotify=true;
++ CPPFLAGS="${CPPFLAGS} -DSPOTIFY"
++])
++
++AC_ARG_ENABLE(lastfm, AS_HELP_STRING([--enable-lastfm], [enable LastFM support (default=no)]))
++AS_IF([test "x$enable_lastfm" = "xyes"], [
++ use_lastfm=true;
++ CPPFLAGS="${CPPFLAGS} -DLASTFM"
++])
+
+ case "$host" in
+ *-*-linux-*)
diff --git a/media-sound/forked-daapd/forked-daapd-23.2.ebuild b/media-sound/forked-daapd/forked-daapd-23.2.ebuild
new file mode 100644
index 000000000000..1a759656c323
--- /dev/null
+++ b/media-sound/forked-daapd/forked-daapd-23.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO:
+# Add --enable-spotify when it works
+
+EAPI=5
+
+inherit autotools eutils user
+
+DESCRIPTION="A DAAP (iTunes) media server"
+HOMEPAGE="https://github.com/ejurgensen/forked-daapd"
+SRC_URI="https://github.com/ejurgensen/forked-daapd/archive/${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="alsa flac itunes lastfm mpd musepack"
+
+# Note: mpd support appears to be standalone, e.g. --enable-mpd doesn't
+# result in additional linkage.
+RDEPEND="
+ >=dev-libs/antlr-c-3.1.3
+ dev-db/sqlite:3
+ dev-libs/confuse
+ dev-libs/libevent
+ dev-libs/libgcrypt:0
+ dev-libs/libunistring
+ dev-libs/mini-xml[threads]
+ media-libs/alsa-lib
+ net-dns/avahi[dbus]
+ virtual/ffmpeg
+
+ flac? ( media-libs/flac )
+ itunes? ( app-pda/libplist )
+ lastfm? ( net-misc/curl )
+ musepack? ( media-libs/taglib )
+"
+
+DEPEND="
+ dev-java/antlr:3
+ virtual/jre
+ ${RDEPEND}
+"
+
+pkg_setup() {
+ enewuser daapd
+ enewgroup daapd
+}
+
+src_prepare() {
+ # Required until upstream accepts https://github.com/ejurgensen/forked-daapd/pull/179
+ epatch "${FILESDIR}/${P}-fix-arg-enable.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-alsa \
+ $(use_enable flac) \
+ $(use_enable musepack) \
+ $(use_enable itunes) \
+ $(use_enable lastfm) \
+ $(use_enable mpd)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newinitd "${FILESDIR}/daapd.initd" daapd
+ newconfd "${FILESDIR}/daapd.confd" daapd
+
+ # dodir by itself fails in the likely case of /srv/music having a
+ # volume mounted already.
+ test -d /srv/music || dodir /srv/music
+
+ fowners -R daapd:daapd /var/lib/cache/forked-daapd
+}
diff --git a/media-sound/forked-daapd/metadata.xml b/media-sound/forked-daapd/metadata.xml
new file mode 100644
index 000000000000..d38687d58122
--- /dev/null
+++ b/media-sound/forked-daapd/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>erikmack@gmail.com</email>
+ <name>Erik Mackdanz</name>
+ </maintainer>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription>
+ This is a much updated version of the original
+ forked-daapd 0.19 (non-gcd), a Linux/FreeBSD DAAP
+ (iTunes) media server with support for AirPlay
+ devices, Apple Remote (and compatibles), Spotify and
+ internet radio.
+ </longdescription>
+ <use>
+ <flag name="itunes">Enable support for iTunes library XML</flag>
+ <flag name="lastfm">Enable LastFM scrobbling support</flag>
+ <flag name="mpd">Enable streaming to mpd</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">ejurgensen/forked-daapd</remote-id>
+ </upstream>
+</pkgmetadata>