summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/musique
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/musique')
-rw-r--r--media-sound/musique/Manifest2
-rw-r--r--media-sound/musique/files/musique-1.1-gcc47.patch13
-rw-r--r--media-sound/musique/metadata.xml5
-rw-r--r--media-sound/musique/musique-1.2.1.ebuild48
-rw-r--r--media-sound/musique/musique-1.3.ebuild48
5 files changed, 116 insertions, 0 deletions
diff --git a/media-sound/musique/Manifest b/media-sound/musique/Manifest
new file mode 100644
index 000000000000..e22fbb7353d9
--- /dev/null
+++ b/media-sound/musique/Manifest
@@ -0,0 +1,2 @@
+DIST musique-1.2.1.tar.gz 374601 SHA256 cc0f626d7de981ff7fdd776fb9eab6a7750443ad55f6978132d9c9d11abd1f38 SHA512 b6d52d8345c69e5b4bfa6419cab4baeb5ed1c81106fbe98b74943cc4c6aa0712444e2189605132da2a2362d38de322926eb3f6ef0b8f25bb45e3e86e3b74cd33 WHIRLPOOL 775751a857dd2e4fbc1f9e50dea9ed0c9d40edd8af7c1bc0a9c7eb186aad39680760825b5c04bbc439d9ac98682952cf5fc2d8e8db595e0f0a99125e6112a078
+DIST musique-1.3.tar.gz 399750 SHA256 401643ad9c750270a89d431806044c626dee3fe7ebc14d0ac72917197cdd0592 SHA512 eb197c315b77d4053960c8c18d012635f957eb9ae89bb8b576f938013db43f78ab0d5a0fe0d46fb32cc9f398f9d7f96a37cf975b2f192a6cbc3dd294c4cad279 WHIRLPOOL b4a48d2e8d57d3cfb6cb3d705b4cccbbaf9ae642f16864bb9c61ece02e658b941472a2767d82218c5bf36031af52354fd2868014d8af0a4b2bb71abdf96f3e6e
diff --git a/media-sound/musique/files/musique-1.1-gcc47.patch b/media-sound/musique/files/musique-1.1-gcc47.patch
new file mode 100644
index 000000000000..6350578103bb
--- /dev/null
+++ b/media-sound/musique/files/musique-1.1-gcc47.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/show_bug.cgi?id=422665
+Index: musique/src/qtsingleapplication/qtlocalpeer.cpp
+===================================================================
+--- musique.orig/src/qtsingleapplication/qtlocalpeer.cpp
++++ musique/src/qtsingleapplication/qtlocalpeer.cpp
+@@ -57,6 +57,7 @@ typedef BOOL(WINAPI*PProcessIdToSessionI
+ static PProcessIdToSessionId pProcessIdToSessionId = 0;
+ #endif
+ #if defined(Q_OS_UNIX)
++#include <unistd.h>
+ #include <time.h>
+ #endif
+
diff --git a/media-sound/musique/metadata.xml b/media-sound/musique/metadata.xml
new file mode 100644
index 000000000000..dc439f7e84f5
--- /dev/null
+++ b/media-sound/musique/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qt</herd>
+</pkgmetadata>
diff --git a/media-sound/musique/musique-1.2.1.ebuild b/media-sound/musique/musique-1.2.1.ebuild
new file mode 100644
index 000000000000..039837676c5a
--- /dev/null
+++ b/media-sound/musique/musique-1.2.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils qt4-r2
+
+DESCRIPTION="Qt4 music player"
+HOMEPAGE="http://flavio.tordini.org/musique"
+# Same tarball for every release. We repackage it
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4[gtkstyle]
+ dev-qt/qtsql:4[sqlite]
+ || ( dev-qt/qtphonon:4 media-libs/phonon[qt4] )
+ media-libs/taglib
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+DOCS="CHANGES TODO"
+
+src_prepare () {
+ # bug 422665. Upstream only cares about ubuntu
+ # so this bug will be fixed once ubuntu moves
+ # to gcc-4.7. No, I will not send this patch upstream
+ # *again*
+ epatch "${FILESDIR}"/${PN}-1.1-gcc47.patch
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ eqmake4 ${PN}.pro PREFIX="/usr"
+}
+
+src_install() {
+ qt4-r2_src_install
+ doicon data/${PN}.svg
+}
diff --git a/media-sound/musique/musique-1.3.ebuild b/media-sound/musique/musique-1.3.ebuild
new file mode 100644
index 000000000000..039837676c5a
--- /dev/null
+++ b/media-sound/musique/musique-1.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils qt4-r2
+
+DESCRIPTION="Qt4 music player"
+HOMEPAGE="http://flavio.tordini.org/musique"
+# Same tarball for every release. We repackage it
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4[gtkstyle]
+ dev-qt/qtsql:4[sqlite]
+ || ( dev-qt/qtphonon:4 media-libs/phonon[qt4] )
+ media-libs/taglib
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+DOCS="CHANGES TODO"
+
+src_prepare () {
+ # bug 422665. Upstream only cares about ubuntu
+ # so this bug will be fixed once ubuntu moves
+ # to gcc-4.7. No, I will not send this patch upstream
+ # *again*
+ epatch "${FILESDIR}"/${PN}-1.1-gcc47.patch
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ eqmake4 ${PN}.pro PREFIX="/usr"
+}
+
+src_install() {
+ qt4-r2_src_install
+ doicon data/${PN}.svg
+}