summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-08-08 11:38:49 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-08-08 11:38:49 +0200
commit350df4f0652cb7fb512ef0ec749d1918566f4a03 (patch)
tree9cb95c889402c92390097a942dc3c783c51e7866 /media-sound/potamus/potamus-17.ebuild
parentmedia-sound/moc: switched to virtual/jack + eapi7 in 2.6_alpha3 (diff)
downloadgentoo-350df4f0652cb7fb512ef0ec749d1918566f4a03.tar.gz
gentoo-350df4f0652cb7fb512ef0ec749d1918566f4a03.tar.bz2
gentoo-350df4f0652cb7fb512ef0ec749d1918566f4a03.zip
media-sound/potamus: bump to 17
1) eapi 7 2) dropped gnome2.eclass, added xdg.eclass 3) switched to virtual/jack 4) updated deps Closes: https://bugs.gentoo.org/736312 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/potamus/potamus-17.ebuild')
-rw-r--r--media-sound/potamus/potamus-17.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-sound/potamus/potamus-17.ebuild b/media-sound/potamus/potamus-17.ebuild
new file mode 100644
index 000000000000..20cdf12c8897
--- /dev/null
+++ b/media-sound/potamus/potamus-17.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg
+
+DESCRIPTION="A lightweight audio player with a simple interface and an emphasis on high audio quality"
+HOMEPAGE="http://offog.org/code/potamus/"
+SRC_URI="http://offog.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+ao audiofile flac jack mad modplug opus vorbis"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ x11-libs/gtk+:2
+ gnome-base/libglade
+ media-libs/libsamplerate
+ media-video/ffmpeg:0=
+ ao? ( media-libs/libao )
+ audiofile? ( media-libs/audiofile )
+ flac? ( media-libs/flac )
+ jack? ( virtual/jack )
+ mad? ( media-libs/libmad )
+ modplug? ( media-libs/libmodplug )
+ opus? ( media-libs/opusfile )
+ vorbis? ( media-libs/libvorbis )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable audiofile input-audiofile) \
+ $(use_enable flac input-flac) \
+ $(use_enable mad input-mad) \
+ $(use_enable modplug input-modplug) \
+ $(use_enable opus input-opus) \
+ $(use_enable vorbis input-vorbis) \
+ $(use_enable ao output-ao) \
+ $(use_enable jack output-jack)
+
+}