summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-08-08 11:38:49 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-08-08 11:38:49 +0200
commit350df4f0652cb7fb512ef0ec749d1918566f4a03 (patch)
tree9cb95c889402c92390097a942dc3c783c51e7866 /media-sound/potamus
parentmedia-sound/moc: switched to virtual/jack + eapi7 in 2.6_alpha3 (diff)
downloadgentoo-350df4f0652cb7fb512ef0ec749d1918566f4a03.tar.gz
gentoo-350df4f0652cb7fb512ef0ec749d1918566f4a03.tar.bz2
gentoo-350df4f0652cb7fb512ef0ec749d1918566f4a03.zip
media-sound/potamus: bump to 17
1) eapi 7 2) dropped gnome2.eclass, added xdg.eclass 3) switched to virtual/jack 4) updated deps Closes: https://bugs.gentoo.org/736312 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/potamus')
-rw-r--r--media-sound/potamus/Manifest2
-rw-r--r--media-sound/potamus/files/ffmpeg29.patch22
-rw-r--r--media-sound/potamus/potamus-17.ebuild (renamed from media-sound/potamus/potamus-16.ebuild)21
3 files changed, 11 insertions, 34 deletions
diff --git a/media-sound/potamus/Manifest b/media-sound/potamus/Manifest
index 2b6b1613ff53..e1f532da073a 100644
--- a/media-sound/potamus/Manifest
+++ b/media-sound/potamus/Manifest
@@ -1 +1 @@
-DIST potamus-16.tar.gz 144874 BLAKE2B ca18b2a6e948a913f652383a81a9e637265c7cf78126846c6824fe12f8a34ab2902ade69366e036b00da61604780e340671a68588b52576c0e5827f07b1b7ba8 SHA512 e4c87d4166d958d200edc13835c57c894b0803b243fd79fb211480a217a33ca34fbd451622842efc47c0ed1b79bcd0fa4f0258f129f70678f14c373234b1b32d
+DIST potamus-17.tar.gz 146822 BLAKE2B 9fa7beabcd4e0ce8a3a6adda4fa425d0a6789c85cc1852bcf528c709574097f5fc34127cb8404d2d8b01c0f961026439786f58a0afd3bd022ed9efe22790bcf9 SHA512 655ac7c99e252c200bb012b1076850ae8c4307ac57dd8d6cb86fc0da0a0ea3b3193c617a365889485a4cab87cb113e40f1d828585e5bdf20c5f2b1b0a2c51099
diff --git a/media-sound/potamus/files/ffmpeg29.patch b/media-sound/potamus/files/ffmpeg29.patch
deleted file mode 100644
index 8565d7d3d99f..000000000000
--- a/media-sound/potamus/files/ffmpeg29.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: potamus-16/src/input-avcodec.c
-===================================================================
---- potamus-16.orig/src/input-avcodec.c
-+++ potamus-16/src/input-avcodec.c
-@@ -41,7 +41,7 @@ static int input_avcodec_open(input *p,
- g_error("out of memory");
- p->data = a;
-
-- a->frame = avcodec_alloc_frame();
-+ a->frame = av_frame_alloc();
-
- for (int pass = 0; pass < 2; pass++) {
- a->format = NULL;
-@@ -114,7 +114,7 @@ static int input_avcodec_get_audio(input
-
- // Decode the packet.
- while (packet.size > 0) {
-- avcodec_get_frame_defaults(a->frame);
-+ av_frame_unref(a->frame);
-
- int got_frame = 0;
- int in_used = avcodec_decode_audio4(a->codec_ctx,
diff --git a/media-sound/potamus/potamus-16.ebuild b/media-sound/potamus/potamus-17.ebuild
index fe984ebe363a..20cdf12c8897 100644
--- a/media-sound/potamus/potamus-16.ebuild
+++ b/media-sound/potamus/potamus-17.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit gnome2
+EAPI=7
+inherit xdg
DESCRIPTION="A lightweight audio player with a simple interface and an emphasis on high audio quality"
HOMEPAGE="http://offog.org/code/potamus/"
@@ -13,28 +13,27 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="+ao audiofile flac jack mad modplug opus vorbis"
+BDEPEND="
+ virtual/pkgconfig
+"
RDEPEND="
x11-libs/gtk+:2
- >=gnome-base/libglade-2
+ gnome-base/libglade
media-libs/libsamplerate
+ media-video/ffmpeg:0=
ao? ( media-libs/libao )
audiofile? ( media-libs/audiofile )
flac? ( media-libs/flac )
- jack? ( media-sound/jack-audio-connection-kit )
- >=media-video/ffmpeg-2.8:0=
+ jack? ( virtual/jack )
mad? ( media-libs/libmad )
modplug? ( media-libs/libmodplug )
opus? ( media-libs/opusfile )
vorbis? ( media-libs/libvorbis )
"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-PATCHES=( "${FILESDIR}/ffmpeg29.patch" )
+DEPEND="${RDEPEND}"
src_configure() {
- gnome2_src_configure \
+ econf \
$(use_enable audiofile input-audiofile) \
$(use_enable flac input-flac) \
$(use_enable mad input-mad) \