summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-09-18 12:16:32 +0200
committerPacho Ramos <pacho@gentoo.org>2016-09-18 13:01:15 +0200
commit5ccd54626f39461a4096c6d322482998636c6268 (patch)
tree40ee884ec663b75ccaab75f6571dc24a0cee8e06 /media-sound/potamus
parentx11-misc/xmonad-log-applet: Use newer eapi (diff)
downloadgentoo-5ccd54626f39461a4096c6d322482998636c6268.tar.gz
gentoo-5ccd54626f39461a4096c6d322482998636c6268.tar.bz2
gentoo-5ccd54626f39461a4096c6d322482998636c6268.zip
media-sound/potamus: Update ffmpeg handling, bump eapi
Package-Manager: portage-2.3.0
Diffstat (limited to 'media-sound/potamus')
-rw-r--r--media-sound/potamus/potamus-16.ebuild38
1 files changed, 17 insertions, 21 deletions
diff --git a/media-sound/potamus/potamus-16.ebuild b/media-sound/potamus/potamus-16.ebuild
index aa6e6654887e..01b06d0a8c71 100644
--- a/media-sound/potamus/potamus-16.ebuild
+++ b/media-sound/potamus/potamus-16.ebuild
@@ -1,42 +1,42 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
+inherit gnome2
-inherit gnome2 eutils
-
-DESCRIPTION="a lightweight audio player with a simple interface and an emphasis on high audio quality"
-HOMEPAGE="http://offog.org/code/potamus.html"
+DESCRIPTION="A lightweight audio player with a simple interface and an emphasis on high audio quality"
+HOMEPAGE="http://offog.org/code/potamus/"
SRC_URI="http://offog.org/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="audiofile flac mad modplug opus vorbis +ao jack"
+IUSE="+ao audiofile flac jack libav mad modplug opus vorbis"
-RDEPEND="x11-libs/gtk+:2
+RDEPEND="
+ x11-libs/gtk+:2
>=gnome-base/libglade-2
media-libs/libsamplerate
- virtual/ffmpeg
+ ao? ( media-libs/libao )
audiofile? ( media-libs/audiofile )
flac? ( media-libs/flac )
+ jack? ( media-sound/jack-audio-connection-kit )
+ libav? ( media-video/libav:= )
+ !libav? ( >=media-video/ffmpeg-2.8:0= )
mad? ( media-libs/libmad )
modplug? ( media-libs/libmodplug )
opus? ( media-libs/opusfile )
vorbis? ( media-libs/libvorbis )
- ao? ( media-libs/libao )
- jack? ( media-sound/jack-audio-connection-kit )"
+"
DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
-src_prepare() {
- gnome2_src_prepare
- has_version '>=media-video/ffmpeg-2.8' && epatch "${FILESDIR}/ffmpeg29.patch"
-}
+PATCHES=( "${FILESDIR}/ffmpeg29.patch" )
src_configure() {
- econf \
+ gnome2_src_configure \
$(use_enable audiofile input-audiofile) \
$(use_enable flac input-flac) \
$(use_enable mad input-mad) \
@@ -47,7 +47,3 @@ src_configure() {
$(use_enable jack output-jack)
}
-
-src_install() {
- default
-}